LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   I can access router settings but no internet access (http://www.linuxquestions.org/questions/linux-wireless-networking-41/i-can-access-router-settings-but-no-internet-access-390914/)

overclock 12-09-2005 10:32 AM

I can access router settings but no internet access
 
I can access my wireless router settings (192.168.1.1) but I can't access the internet. The router itself can ping sites. linux dist is suse 10.0. I'm new to the world of linux, so if you can walk me through some steps, that'll be great. thanks

fouldsy 12-09-2005 12:20 PM

How have you configured you wireless connection to your router, and also what wireless card do you actually have in your Linux machine? Can you ping the router itself?

At a guess, if you type "route" from the command line, you'll be missing an entry for default gateway which defines where you system will look for it's Internet connection. To fix this, type:
Code:

route add default gw 192.168.1.1 dev wlan0
assuming wlan0 is what your wireless card is configured as. Otherwise, if you have a look within /etc/resolv.conf you might not have correct DNS servers set which should be available from your ISP.

Cogar 12-09-2005 12:29 PM

Check out my post from another forum. It may help.

Quote:

I had a similar problem with SUSE Linux 10.0 on my machine as well. In my case, the problem arose from the DHCP function overwriting one of the two DNS servers with the gateway IP address. I believe this is common, as it is the same in Linux and Windows. Apparently, Windows can handle this behavior and Linux cannot (or not as well, anyway).

Here is the solution I used.

1. Log in as root. (K-menu --> System --> File Manager --> File Manager - Super User Mode). Open up the resolve.conf file (located at /etc/resolv.conf) with Kwrite and edit the resolve.conf file so that it contains both DNS server numbers. (I overwrote the gateway IP address with the DNS #1 address. It was the one that was overwritten.) Save the modified file as resolve2.conf. You will need this backup file.
2. Open up the config file (located at /etc/sysconfig/network/config). Make a backup of that as well. Next, change MODIFY_RESOLV_CONF_DYNAMICALLY = “yes” to MODIFY_RESOLV_CONF_DYNAMICALLY = “no”.
3. Restart. (I think you can also do this by logging off and logging back in.) Log in as root. You will find the resolve.conf file messed up. (We switched off "MODIFY_RESOLV_CONF_DYNAMICALLY," so the file was not "created" this time around.) Open the backup copy (resolv2.conf) and save it as resolv.conf. This file will remain untouched. (As far as I can tell, anyway.)
4. Restart and log in normally. It should work.

I hope that helps.

overclock 12-09-2005 02:51 PM

I believe i'm doing something wrong while using your walkthrough. I still can't access the internet through wifi and now my ethernet is performing extremely terrible even when I restored everything back to my previous setup.

here's my resolv.conf:

nameserver 178.16.1.1
nameserver 139.78.200.1
search suites.rl suites.rl

The "MODIFY_RESOLV_CONF_DYNAMICALLY" was already "="no""

In wifi connectivity only, I get the error "The connection was refused when attempting to contact X." X = any ip (excluding my router's ip) and url.

Cogar 12-09-2005 03:47 PM

OK, that makes me wonder if you set up your wireless card correctly. You might recheck and make sure your network name (ESSID), operating mode (Ad-hoc/Managed/Master), authentication mode (Open/Shared Key/WPA-PSK/WPA-EAP), passkey, and passkey type (passphrase/ascii/hexadecimal) are entered correctly.

overclock 12-09-2005 04:09 PM

I rechecked my setup and everything seems to be correct.

overclock 12-10-2005 07:50 PM

it says that the connection is refused even when i'm not connected through eth0 or wlan0

BrianW 12-13-2005 07:59 PM

Do you use dhcpcd or do you have it set for a manual IP? Use the same IP for your previously working eth0 connection as wlan0? It sounds to me more like you maybe have the wrong dns address. If you can connect to your router but not to a url, that would lead me to believe its the dns (as fouldsy has stated already).
I doubt its any security settings in your router since you are able to log into it. (From what I gather.)

Whats the output of ifconfig and iwconfig?


All times are GMT -5. The time now is 12:59 AM.