LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-04-2012, 07:50 PM   #1
Bourbon
Member
 
Registered: Dec 2011
Location: Windhoek - Namibia
Distribution: Slackware 14.1 KDE 32 bit
Posts: 32

Rep: Reputation: Disabled
Question Huawei E173 can work with Slackware 13.37?


Hi All,

Please, I am here wishing to ask if someone knowing how to connect Slackware 13.37 KDE 32 bit with Internet key Huawei mod. E173.
I have been installing the script "Sakis3G" and I get connected, but not surfing!
$ lsusb = Bus 002 Device 003: ID 12d1:1c08 Huawei Technologies Co., Ltd.

Thank you for your attention, ciao

P.S.
With the same key I have full connection on Ubuntu 12.04
 
Old 05-05-2012, 10:06 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,517

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Have you seen this? http://www.draisberghof.de/usb_modes...aa8aa5276e7e29
[edit] or perhaps clearer is this http://www.draisberghof.de/usb_modes...opic.php?t=552 [/edit]

Try adding this to /etc/usb_modeswitch.d/12d1:1c0b
Code:
TargetVendor=  0x12d1
TargetProduct= 0x1c08
Then, rather than using Sakis3G, I would try configuring the modem in kppp. This guide, starting at step 4, may be useful.
http://www.novatelwireless.com/stage...=article&id=74

Last edited by allend; 05-05-2012 at 12:54 PM. Reason: Added additional URL
 
Old 05-05-2012, 01:49 PM   #3
Bourbon
Member
 
Registered: Dec 2011
Location: Windhoek - Namibia
Distribution: Slackware 14.1 KDE 32 bit
Posts: 32

Original Poster
Rep: Reputation: Disabled
Hi Allend,

Thank you very much for your kind and precious help I have been trying to add the line "TargetProduct= 0x1c08" (commenting the old one) on /etc/usb_modeswitch.d/12d1:1c0b (the other line was already over there) and configured the connection using KPPP; the KPPP's connection has been correctly configured, but I don't surf on Internet yet (Sakis3G does not connecting anymore, even after cancelling the KPPP connection).
Maybe useless, but also I have been trying to configure "pppoe" (hoping with the right values), nothing changed.
I am awaiting to get time to try again, also going to read with attention the two new links you suggesting to me.

Thank you again, ciao
 
Old 07-16-2012, 06:10 AM   #4
Bourbon
Member
 
Registered: Dec 2011
Location: Windhoek - Namibia
Distribution: Slackware 14.1 KDE 32 bit
Posts: 32

Original Poster
Rep: Reputation: Disabled
SOLVED

Steps:
1 - Installing Wicd (to switch off the wired connection)
Mr. Patrick Wolkerding wrote:
Quote:
After installing this package, make sure the /etc/rc.d/rc.wicd
script is executable; if necessary, do:
chmod +x /etc/rc.d/rc.wicd

Results have varied, but you will probably need/want to remove
any references to interfaces from /etc/rc.d/rc.inet1.conf - in
other words, make that file look as if netconfig has never been
run.

When you start X, you should see a wicd icon in the system tray;
click on it to open the gui interface and configure as desired.
Your user account will need to be a member of the 'netdev' group
in order to use wicd.

Note that urwid will need to be installed if you want to use the
curses client.

Also, if you don't have kde installed, you won't have a graphical
sudo client available; you might wish to consider ktsuss from
SlackBuilds.org.
2 - Create file # nano /etc/udev/rules.d/20-hsdpa.rules
Contents:
Quote:
SUBSYSTEM=="usb",SYSFS{idVendor}=="12d1",
SYSFS{idProduct}=="1c0b",RUN+="/usr/sbin/usb_modeswitch
--default-vendor 0x12d1 --default-product 0x1c0b --message-content
55534243123456780000000000000011062000000100000000000000000000"
3 - Downloading the script Sakis3g (Binary free version) http://www.sakis3g.org/
4 - Configuring the connection (when asking for username and password write "admin")
You can put the script everywhere you want, but to do something "clean" I suggest to put it in /opt or even inside a directory where you can add the icon for the launcher and a file reminding you the command to start Sakis3g.
The generic command is: ./sakis3g --interactive
Mine is: /opt/Sakis/sakis3g --interactive (footpath=/opt/Sakis).

I am very happy Cheers!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
huwawi E173 modem install in CentOS release 4.9 (Final) narakaya Linux - Hardware 1 11-28-2011 07:50 AM
Huawei 1261 with Slackware 12.1 shivkiyer Slackware 5 10-15-2010 02:21 AM
Huawei EC 1260 to work on Hardy-Heron @mi|- Linux - Hardware 2 04-21-2010 05:01 AM
My E160G HUAWEI DOESN'T WORK cavaldea Linux - Newbie 1 12-29-2009 09:08 PM
Huawei E172 + slackware 12.1 + kernel 2.6.28.7 + wvdial didn't work. pianeta_rosso Linux - Hardware 1 02-25-2009 05:39 AM


All times are GMT -5. The time now is 02:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration