LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   How to Install Madwifi Driver for TL-WN821N (http://www.linuxquestions.org/questions/linux-wireless-networking-41/how-to-install-madwifi-driver-for-tl-wn821n-861437/)

dbboy 02-08-2011 10:53 AM

How to Install Madwifi Driver for TL-WN821N
 
Dear Friends,
I am fairly new to Fedora and I have Fedora 13 and I have a USB wireless card (TL-WN821N) which I would like to install MadWifi Driver for it.
Would you please help me on this.
Thank you in advance,
Regards,
dbboy

reed9 02-08-2011 11:08 AM

Madwifi is deprecated and shouldn't be needed for this card.

It looks like the driver for this card is ar9170. Plug in the device and check the output of
Code:

lsusb
to confirm.

The usbid should be 0cf3:1002.

You'll need firmware, which should be available in the Fedora repositories.

dbboy 02-08-2011 12:04 PM

Dear reed9,
Thanks a lot. It's working now. There is One more thing if you can help me please. I have a built in WLAN card in my laptop (Intel Wifi link 5100) and in order not to use it I turned off the switch on the laptop but when I do that both Wlan cards will be disabled and I can't work with the USB wlan card only unless I turn on that Switch which cause both Wlan cards to work and I dont want that. I only want to use the USB wlan card.
Thank you in advance,
Best Regards,
dbboy

reed9 02-08-2011 12:25 PM

Seems odd that the kill switch for the onboard card would turn off the USB card too, but anyway.

I suppose you could blacklist the driver for the intel card. Add a line to /etc/modprobe.d/blacklist.conf reading blacklist iwlagn. You can do so as follows

Code:

su -
echo "blacklist iwlagn" >> /etc/modprobe.d/blacklist.conf

That should prevent it from loading at boot. Make sure you use two >>, just one and you'll overwrite the file.

Check that it's not loading when you reboot
Code:

/sbin/lsmod | grep iwl
No output means it isn't there.


All times are GMT -5. The time now is 08:05 AM.