LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 03-17-2007, 05:51 PM   #1
GamerX
Member
 
Registered: Nov 2006
Location: Vancouver, BC
Distribution: Slackware
Posts: 102

Rep: Reputation: Disabled
How to force atheros card to use 11b instead of 11g?


Long story short, 2wire's all-in-one-wonder-DSL-modem-and-WAP (2700HG-E) and D-Link's AirPLus extreme G PCI card (DWL-G520) - which lives in a desktop - don't get along that well, except in 11b mode.

How is this done with madwifi drivers?

Additional Info:
Strong signal, no interference, everything is fine while doing stuff in the LAN full network speed and such. However when I try to access the outside world instead of getting a 1.5Mbits DSL connection it's about 1/4 of that speed.
2 IBM laptops in the house neither one has problems, one uses 11b (it's old), the other one 11g.

The desktop has dual-boot linux (slack 11) and winxp and the problem is consistent in both OSes, when I used d-link's utility in windows to make the card use 11b mode the problem went away. Now I'd like to do the same in linux.

Thanks in advance!
 
Old 03-17-2007, 08:20 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
As far as I know, manually changing the operating mode from B to G in Windows just changes the transmit rate of the device.

If that is the case, then you should be able to do the same thing under Linux with a command like:

Code:
sudo iwconfig wlan0 rate 11M
 
Old 03-17-2007, 10:13 PM   #3
short101
Member
 
Registered: May 2004
Location: Aust.
Distribution: Debian
Posts: 424

Rep: Reputation: 30
iwpriv ath0 mode 2
lots of info over at madwifi.org
 
Old 03-18-2007, 02:51 PM   #4
GamerX
Member
 
Registered: Nov 2006
Location: Vancouver, BC
Distribution: Slackware
Posts: 102

Original Poster
Rep: Reputation: Disabled
"iwpriv ath0 mode 2" that works, thanks a bunch! actually i tried searching madwifi.org but didn't come up with the right stuff, i really need to get acquainted with the networking tools better...

MS3FGX: That wouldn't do anything, in windows as well I had to use an additional utility to force the card to use 11b. You can have 11M rate in 11b or 11M in 11g mode, it's just that the maximum rate for 11b is 11M so the rate will get bumped down from 54M or whatever you used with 11g.

Thanks for the replies!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Atheros Wireless LAN (802.11b/g) with Redhat Linix EL 4 hitesh_linux Linux - Wireless Networking 2 11-13-2006 03:01 PM
Slackware-compatible USB wifi adapter 802.11b or 802.11g sah Linux - Wireless Networking 3 07-24-2006 10:21 AM
Integrated 802.11b/g Atheros AR5212 Wireless LAN not detected Pap00se Suse/Novell 3 07-03-2006 11:19 AM
slackware 10.0 pcmcia atheros ar5212 (802.11g) t163r Slackware 3 09-16-2005 01:07 AM
iwconfig thinks my 802.11g card is 802.11b Relativity Linux - Wireless Networking 1 04-04-2005 10:17 PM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration