LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 02-26-2005, 10:24 PM   #1
exitsfunnel
Member
 
Registered: May 2003
Distribution: RedHat
Posts: 60

Rep: Reputation: 15
How to disable eth1 (wireless nic card) at startup?


Hello,

I have an IBM T40 with a wireless nic card (which I've never used under Linux) running RHEL 3.0. I just recently upgraded my kernel to 2.4.21-20 and in general everything works fine. However, one affect of the upgrade seems to be that support was added for the wireless nic. The problem with this is that when I boot the machine I have to wait a considerable amount of time while it tries to bring up eth1 (which I'm assuming is the wireless card). The process invariably fails because there is no signal. The delay each time I reboot has started to annoy me. How can I disable eth1? I though chkconfig would be the answer but it seems it's not a service. Help!

Another quick (mostly unrelated) question. I've been poking around the /etc/rc stuff and I think that I have the general idea which is that the files in each directory determine which services to start at the corresponding runlevel. I gather that if the symlink starts with 'S' the service is active at the runlevel and if it starts with 'K' the service is not. But what do the numbers mean? For instance in /etc/rc.d/rc5.d I find the file 'S90xfs' I assume that this means that xfs should be started when the machine enters runlevel 5 but what does the '90' mean? If anyone can point me to any documentation which describes this whole system that would be great.

Thanks in advance for any replies!

-exits
 
Old 02-26-2005, 11:30 PM   #2
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Regarding disabling eth1, I'm sure Red Hat has a graphical section about network cards (I know Mandrake does as I have done it myself!). You should be able to disable it from there if you can find it.
 
Old 02-27-2005, 01:40 PM   #3
Does
LQ Newbie
 
Registered: Jan 2005
Location: USA
Distribution: Slackware-current 2.6.10, Mandrake 10.1
Posts: 24

Rep: Reputation: 15
If you are running X:
http://elibrary.fultus.com/technical...-ethernet.html

Otherwise I think this might be the text interface but I'm not sure:
system-config-network-tui


About the RC directories.

S scripts:
The S scripts mean they will be started at that runlevel.

K scripts:
These scripts run when you shutdown your computer.

The numbers are just the order in which the startup and kill scripts run. So a script with a lower number will run before a scripts with a higher number. For instance you want to up your iptables before you startup the rest of your networking. And vice versa, shutdown the networking services before shutting down your iptables.

To read more about the booting proces:
http://elibrary.fultus.com/technical...down-sysv.html

Peter
 
Old 02-27-2005, 11:07 PM   #4
exitsfunnel
Member
 
Registered: May 2003
Distribution: RedHat
Posts: 60

Original Poster
Rep: Reputation: 15
Thanks Peter, your reply was a big help. The fultus links especially are helpful; that's a great site!

-exits
 
Old 02-27-2005, 11:27 PM   #5
drj000
Member
 
Registered: Sep 2004
Location: Hagerstown, MD
Distribution: Ubuntu Natty Narwahl
Posts: 258

Rep: Reputation: 31
The GUI tools are easy enough to use, but I've always found editing text files directly to be the quickest way. RHEL is probably the same as Fedora. For Fedora, what I would do is edit the file /etc/sysconfig/network-scripts/ifcfg-eth1, and where it says ONBOOT=yes, change it to no. Of course, you have to be root to edit this file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable Intel Pro Wireless 2100 Centrino NIC using HD install of Knoppix Substandard Linux - Newbie 1 02-04-2005 12:08 AM
wireless card + nic = no connection miyagi Linux - Wireless Networking 3 08-26-2004 07:11 PM
wireless card showing as eth1 adambeazley Linux - Wireless Networking 12 04-29-2004 11:01 AM
Wireless card works but nic does not? guitarnix Linux - Wireless Networking 0 01-06-2004 02:13 AM
wireless card not recognized as eth1 mpo Linux - Wireless Networking 42 04-23-2003 06:13 PM


All times are GMT -5. The time now is 08:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration