LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 12-17-2003, 05:25 PM   #1
-=Sabin=-
Member
 
Registered: Jul 2003
Location: Anchorage, Alaska
Distribution: Suse 9.0
Posts: 33

Rep: Reputation: 15
How I got the Microsoft MN-720 (802.11g) card working in Suse 9.0


I went with the Microsoft MN-720 card. I used the Linuxant Driver to make it work. The driver worked great. The problems I had were with the way Suse 9.0 does WiFi cards.

The driver makes the WiFi card ETH1. But Suse makes it WLAN0. The way I had to fix it so it works was to edit the /etc/sysconfig/network/ifcfg-eth1 file. I copyed the info from the WLAN0 file and put it in to ETH1 file. Then I changed all NIC cards to 'hotplug'. When I did this and rebooted, the card could get on the network and run at 54mb.

I am not sure if this has to be done with other distributions of Linux. I have run Mandrake 9.1 and it ran WiFi cards as ETH not WLAN so it should work with driver.

I hope this helps. It worked for me and I'm a .

This what my ETH1 file looks like:

BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='hotplug'
UNIQUE=''
WIRELESS_ESSID='powerhouse'
WIRELESS_KEY='xxxxxxxxxx'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''

Last edited by -=Sabin=-; 12-17-2003 at 05:29 PM.
 
Old 12-17-2003, 07:34 PM   #2
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Well, maybe you can help me with my problem. I'm trying to setup a MS MN-520 card in my Dell Inspiron 4000, and the MN-500 base station.
I'm running Slackware 9.1 and I'm clueless! I've been reading and searching online for something to help me find a driver and configure things but nothing, short of your post, has seemed to come close.
I've looked for the /etc/sysconfig/network... file but I don't have it.
I've done the obvious netconfig but without drivers for my wireless card I know it's useless.
I'm finding that every distro has a different layout - a really different layout from what I can see. Nothing seems easy to solve but I'm going to keep at it until I'm windows free and able to survive happily with Linux.

Any help setting this up would be a great start!
 
Old 12-17-2003, 07:52 PM   #3
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Vincent,
Your MN-520 is a Prism-based card and will happily use the orinoco_cs driver.
In Slackware, the files are different. You edit /etc/pcmcia/wireless.opts with the specific parameters for your network after loading the drivers. Assuming you installed the PCMCIA kernel, try:
insmod hermes
insmod orinoco
insmod orinoco_cs

Here's a similar post that may help with the specifics of the wireless.opts file.

Lastly, restart pcmcia services:
/etc/rc.d/rc.pcmcia restart

Listen for two happy beeps and hopefully, connect.
 
Old 12-17-2003, 09:00 PM   #4
Fold Zandura
LQ Newbie
 
Registered: Feb 2003
Location: Anchorage ,AK
Distribution: SuSE 9.0
Posts: 23

Rep: Reputation: 15
Here is how I got my MN-520 to work in Mandrak 9.X

Do this at your own risk.

Advantage:
In a dual boot environment same hardware can be used by both Windows as well as Linux.

hardware:
1. Microsoft Wireless Notebook Adapter MN-520

Login as root and follow these steps.

1. Add the following entries to /etc/pcmcia/config file right after the line that reads "# Wireless network adapters". You can copy these 3 lines and paste into the file:

card "Microsoft Wireless Notebook Adapter MN-520 1.0.3"
version "Microsoft", "Wireless Notebook Adapter MN-520", "", "1.0.3"
bind "orinoco_cs"

2. Restart the system. Your Microsoft Wireless Notebook Adapter will be recognised as "Lucent Orinoco and Prism II-based PCMCIA wireless" hardware device. When your system is up, "Wireless" indicator on the adapter starts blinking.
 
Old 12-17-2003, 09:05 PM   #5
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
2Gnu,
Thanks for the help! I did the 'insmod's you said to - does that setup the driver? Otherwise, I have no driver but I do see that those modules exist now. (you can see that I'm still sort of lost...)
I also followed the other post and modified my /etc/pcmcia/wireless.opts to make it like the one you posted using essid='Wireless' and key='' since i'm not using a key for now. will that work?
I tried iwconfig eth0 which told me 'no wireless extensions'
basically, what i've tried didn't work and i think i followed your instructions alright with the exception of the driver...can you help me again??

thanks again. your help is appreciated!
 
Old 12-17-2003, 10:09 PM   #6
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Fold Zandura,
I checked my /etc/pcmcia/wireless.opts file and it's not the same as yours so I'm not sure if it'll work. I added the lines anyway and I'm not getting anything. when I run iwconfig I get:
lo no wireless connections
eth0 no wireless connections

What do I do for a key? I'm not looking to have key for now. Should I leave that blank (key="") or something else? For not I left it key='s:secu1'.
Thanks again for the help.
 
Old 12-17-2003, 11:23 PM   #7
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Well, I'm happy to say that I'm online via Konqueror, but not with my wireless adapter. I did manage to get my 3Com working after reading the posts here so thank you. I'll just keep working on the MS-520 - that's a better way to surf the net!
When I try using the iwconfig <any command such as 'channel 6'> I get an error. Nothing seems to be setup for that card at this point. I'm still not sure the driver is installed. Does insmod install drivers?? That's all I did for the orinoco_cs driver.
I'll do some researching but for now, I'm finally online for the first time with Linux! Thanks again for the help!!!

Last edited by Vincent_Vega; 01-05-2004 at 02:14 PM.
 
Old 12-18-2003, 10:01 AM   #8
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
insmod does install, or rather load, the drivers. lsmod will list the driver modules loaded. rmmod unloads them. modprobe loads and attempts to load any dependent modules as well. All of this is in RAM. To make the modules load at boot, you'll need to edit the /etc/modules.conf or /etc/rc.d/rc.xxx. Unfortunately, I can't find where this is done on my Slack system (I'm still learning my way around vs. Red Hat).
 
Old 12-18-2003, 01:19 PM   #9
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Ok, that makes sense with the drivers. I'll go ahead and play with it some more and try to get the drivers in the right file. I have both files that you mentioned so I'll check them both out.
What about those settings in the wireless.opts file? Can you guide me a little more on that? Should I delete the sample entries, and if so, which should I configure for my own, or doesn't it matter? I'm still reading so maybe I'll find some answers along the way.
Thanks again!
 
Old 12-18-2003, 01:28 PM   #10
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
I cleaned up the wireless.opts so that I was less likely to make an error. The only things in there other than the header summary comments are the generic list of parameters with my changes to the relevant ones as shown in the linked thread. ESSID, mode, rate & key are all I use.
 
Old 12-18-2003, 01:48 PM   #11
-=Sabin=-
Member
 
Registered: Jul 2003
Location: Anchorage, Alaska
Distribution: Suse 9.0
Posts: 33

Original Poster
Rep: Reputation: 15
Lightbulb Update

I changed my ETH1 file so the ESSID='any' and it still works. So now if I go to a different WiFi network all I have to do is change the WAP key. Kind of a pain, but aleast it works. My ETH1 file is below:

BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='hotplug'
UNIQUE=''
WIRELESS_ESSID='any'
WIRELESS_KEY='xxxxxxxxxx'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
 
Old 12-18-2003, 03:02 PM   #12
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
and without a key, how would i configure that? My router shows a long string that is the key...if I just copy that string into the 'key' field will I have encryption setup? I could try that easily but first I just want to get the wireless going. encryption is secondary at the moment.
thanks for the post - I'll give it a try!
 
Old 12-18-2003, 03:36 PM   #13
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
According to the docs and the way mine is working, the syntax for the WEP key in th wireless.opts file is:
KEY="1234:5678:abcd:ef01: ..."
There should be 26 hexadecimal digits for a 128 bit key and they must match those in the router.

To manually enter a different key:
iwconfig eth0 key 012345abcd... (no colons)
or no key if using a public hotspot:
iwconfig eth0 key off

If you need to change settings frequently, and are using KDE, try KWiFiManager.
http://kwifimanager.sourceforge.net/
 
Old 12-18-2003, 03:40 PM   #14
-=Sabin=-
Member
 
Registered: Jul 2003
Location: Anchorage, Alaska
Distribution: Suse 9.0
Posts: 33

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Vincent_Vega
and without a key, how would i configure that? My router shows a long string that is the key...if I just copy that string into the 'key' field will I have encryption setup? I could try that easily but first I just want to get the wireless going. encryption is secondary at the moment.
thanks for the post - I'll give it a try!
I would give it a try. You do need to tell Linux the key it should use or it will not work. Does your card light-up at boot or do the lights stay off? If it lights up then you are half way there. If not then your system can not see the card. Make sure the card lights up first..
 
Old 12-18-2003, 06:23 PM   #15
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
I'll try that for the key. I saw in one file that key="off" was an option but I'm not sure.
The lights are on but no blinking. If I try iwconfig it says there is nothing there. At boot it says "unsupported card in slot 0" or something like that.
How do I edit my /etc/modules.conf file to include the drivers at boot-up? I can do the insmod... but that's temporary. I'm trying the orinoco driver.
Any ideas?
Thanks for your time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to setup a Microsoft wireless pcmcia card MN-720 jj4146 Linux - Wireless Networking 4 12-16-2005 04:00 PM
Microsoft MN-720 wireless card to work on SUSE Linux 9.1 Professional maxtothemax1004 Linux - Wireless Networking 1 09-16-2005 01:08 PM
iwconfig thinks my 802.11g card is 802.11b Relativity Linux - Wireless Networking 1 04-04-2005 10:17 PM
Need 802.11g (54 Mbps) Wireless card for SuSE 9.1 MasterPatricko Linux - Wireless Networking 0 09-04-2004 05:16 AM
Microsoft mn-710 usb 2.0 802.11g fredhead Linux - Wireless Networking 1 05-11-2004 10:53 PM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration