LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 06-05-2009, 04:05 PM   #1
bbmak
Member
 
Registered: May 2004
Posts: 177

Rep: Reputation: 30
How do you enable channel 13 for Atheros card?


I am using debian + fluxbox.
I want to know are there anyway to enable channel 13 for the card?
 
Old 06-06-2009, 06:34 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
AFAIK there are only 11 channels for wireless networking.

http://www.moonblinkwifi.com/2point4freq.cfm
 
Old 06-06-2009, 07:14 PM   #3
bbmak
Member
 
Registered: May 2004
Posts: 177

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by stress_junkie View Post
AFAIK there are only 11 channels for wireless networking.

http://www.moonblinkwifi.com/2point4freq.cfm
what if you are not in US???? U r in Japan but not able to use channel 12-14?
I am using WG511T, which supports up to channel 14

Last edited by bbmak; 06-06-2009 at 07:16 PM.
 
Old 06-06-2009, 09:30 PM   #4
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Quote:
Originally Posted by bbmak View Post
what if you are not in US???? U r in Japan but not able to use channel 12-14?
I am using WG511T, which supports up to channel 14
You should have put that information in your original post.
 
Old 06-07-2009, 07:49 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
I think this is a driver issue. According to this, there may be some load-time parameters you need to pass to the module.
 
Old 09-07-2012, 02:32 PM   #6
Weapon S
Member
 
Registered: May 2011
Location: Netherlands
Distribution: Debian
Posts: 146
Blog Entries: 1

Rep: Reputation: 12
Unhappy Tried that

Debian Squeeze. ath5k driver. I tried the fix from the previous post. Tried creating a file named options, descriptive_name.conf and then options.conf. I restarted every time and it didn't work. Works fine under Windows or on channel 11.
Could there be a reason that option isn't being used? lsmod said cfg80211 was loaded... (and the file is being processed, because if I try to set mac80211_cfg, or something, Linux complains during boot about an unrecognized option.)
Would be great if somebody could link me to a step-by-step troubleshooting guide (that I can download for off-line use ).

Last edited by Weapon S; 09-08-2012 at 12:04 AM.
 
Old 09-10-2012, 02:20 PM   #7
Weapon S
Member
 
Registered: May 2011
Location: Netherlands
Distribution: Debian
Posts: 146
Blog Entries: 1

Rep: Reputation: 12
This fellow uses some patch to the ath5k driver.
http://133nux.blogspot.nl/2010/09/mi...-channels.html
Could anybody explain to me how to get and build the source of the ath5k driver, please?
Also there is the option to use ath_info to overwrite the EEPROM. I need to turn off my card. (How do I do that?) And I may need to set some GPIO. (Which one??!)
It will take me months to research this on my own. If you have any tip, please help.

Last edited by Weapon S; 09-11-2012 at 02:39 PM.
 
Old 09-16-2012, 02:20 AM   #8
Weapon S
Member
 
Registered: May 2011
Location: Netherlands
Distribution: Debian
Posts: 146
Blog Entries: 1

Rep: Reputation: 12
Cool FINALLY!!! (Less than month ;D )

I think the "patch" from the previous post actually needs you to recompile the kernel ( yeesh), and besides, it's actually making your driver not respect standards.
The other thing is much cleaner IMHO. First add the cfg80211 module parameter as per previous posts. Reboot (or reload module, if you know how). Now check whether that fixed your problem. One way to check is using iwlist (from the wireless-tools package?). Run something like iwlist wlan0 channel. (Your device could very well be something else than wlan0. iwlist Supports autocomplete with tab.) If it doesn't list your wanted channels, tough luck, and go on.
Download this source:
http://madwifi-project.org/browser/ath_info/trunk
(The .c and .h are the source, rest is documentation. I recommend the README.) Download Makefile if you want to use make, or simply use gcc ath_info.c -o ath_info to turn the source into an executable. (There actually also is an older version that gives more sane type numbers of your wireless hardware, but I recommend using the latest version for rewriting the EEPROM.)
Check here for a sane value you want to give the EEPROM. You might want to keep the page open.
http://wireless.kernel.org/en/users/Drivers/ath
Run lspci -v | less to find the hardware/memory address of your card. (q to quit less.) Mine was 00:d0.00 with memory d5800000. (The memory is hexadecimal. To make that explicit write 0xd5800000.)
Run ./ath_info 0xMEMORYADDRESS, e.g. ./ath_info 0xd5800000. I recommend piping to less again (with " | less"). This should give you something like this:
Code:
 -==Device Information==-
MAC Revision: 2417  (0xf0)
Device type:  3

/============== EEPROM Information =============\
| EEPROM Version:   5.3 | EEPROM Size:  16 kbit |
| EEMAP:              2 | Reg. Domain:     0x809C |
|================= Capabilities ================|
| 802.11a Support:  no  | Turbo-A disabled: yes |
| 802.11b Support:  no  | Turbo-G disabled: yes |
| 802.11g Support:  yes | 2GHz XR disabled: no  |
| RFKill  Support:  no  | 5GHz XR disabled: no  |
| 32kHz   Crystal:  no  |                       |
\===============================================/

/=========================================================\
|          Calibration data common for all modes          |
|=========================================================|
[etc. etc. etc.]
GPIO registers: CR 0x00000003, DO 0x00000001, DI 0x00000014
[etc. etc. etc]
(Also posted for hints of similar hardware. AR5007 2417.)
Notice the regdomain? 0x809C is hexadecimal 0x8000 + 156. That means China. If the regulatory domain actually is set to something permissive, you could have another problem. (I read something about "world roaming".) Decide whether to reprogram the EEPROM regdomain.
The next step I might have skipped myself, but I still recommend it. Close all wireless connections and daemons. Run rfkill block wlan. (aptitude install rfkill first if needed.)
The next step I did, but don't know (and I'm not checking now) whether this step is needed. Run:
setpci -s xx:xx.x command=0x41f cache_line_size=0x10
xx:xx.x should be replace with your wireless hardware address (remember?).
Now the fun part. Run ./ath_info -g 0:0 -v -f -g 1:0 -g 2:0 -g 3:0 -g 4:0 -w 0xMEMORYADDRESS regdomain 0x0. You might not have to set it to 0x0 first, but I did. Then run ./ath_info -g 0:0 -v -f -g 1:0 -g 2:0 -g 3:0 -g 4:0 -w 0xMEMORYADDRESS regdomain 0xH, where H is the hexadecimal region code you'd like to have. Run ./ath_info 0xMEMORYADDRESS to bask in the glory of a reprogrammed EEPROM regdomain ;D. Run rfkill unblock wlan, if necessary. Reboot. Should be working now

Last edited by Weapon S; 09-16-2012 at 02:33 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wifi card Atheros a+g Stabby McTwist Linux - Hardware 5 10-29-2006 11:20 PM
Wireless card Atheros matt3333 Slackware 1 07-03-2006 07:47 PM
Enable 4 Channel Audio? voxel Linux - Laptop and Netbook 0 09-04-2005 07:12 PM
Atheros WiFi Card RySk8er30 Mandriva 4 09-04-2005 01:07 AM
Channel 6 Not Working With TV Card kerbe6 Linux - Software 2 11-25-2004 03:01 AM


All times are GMT -5. The time now is 12:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration