LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 08-05-2004, 02:40 AM   #1
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Rep: Reputation: 30
how do I create the wlan0 device?


I am attempting to install a friend's netgear ma111 usb net card on his comp, but every single guide I have found uses this 'wlan0' device, which is no where to be found on my system. And because of this, I am unable to run the required 'iwconfig wlan0' command to test the card (device not found). This is what I have done so far:

1. installed the wlan-ng-0.2.1-pre21 drivers, compiled and installed fine, hotplug detects the card and I added to rc.modules 'modprobe prism2_usb'

2. tried to add to /etc/sysconfig/network-scripts a file called ifcfg-wlan0, but I found out that slackware does not use this directory for wireless scripts, iwconfig still doesnt work

3. added "alias wlan0 prism2_usb" to /etc/rc.d/rc.modules, still doesnt work

What is the correct way to create this wlan0 device on slackware? Is the prism2_usb module supposed to make it itself? Or even better, has anyone sucessfully install an ma111 on slackware 10?
 
Old 08-05-2004, 08:26 PM   #2
kmeehl
Member
 
Registered: Feb 2004
Posts: 30

Rep: Reputation: 15
Same Problem!

I am having the same problem. I've looked everywhere and only found more confusion. Can someone help us out!?

veritas, the first thing is that the alias goes in /etc/modules.conf, not /etc/rc.d/rc.modules

My setup is Slackware 9.1 running kernel 2.6.7

Here is what I've done:

Installed the drivers: wlan-ng-0.2.1-pre21
added modprobe prism2_usb to rc.modules
added alias wlan0 prism2_usb to /etc/modules.conf
ran wlanctl-ng wlan- lnxreq_ifstate ifstate=enable as per the instructions in the README
it returned wlanctl-ng: No such device


iwconfig doesn't even show wlan0 in the output:
lo no wireless extensions.

dummy0 no wireless extensions.

sit0 no wireless extensions.

etho no wireless extensions.


ifconfig only shows lo and nothing more

Can someone please just start from the top and tell us how to set up a prism2 on Slackware?

Thanks for any responses..

kM
 
Old 08-05-2004, 08:30 PM   #3
kmeehl
Member
 
Registered: Feb 2004
Posts: 30

Rep: Reputation: 15
One more thing.
I don't know what this wlan thing is that everyone talks about, but I don't have it. The closest thing I have is wland. I don't know how 'wlan' is supposed to be run (with what options, when) and if it is the same as wland.

Also, the documents that come with the driver say that iwconfig is useless with this driver, yet I see everyone talking about using it with prism2 cards.

More confusion....eh...

-kM
 
Old 08-06-2004, 01:51 PM   #4
veritas
Member
 
Registered: Aug 2003
Location: Dallas,TX
Distribution: Ubuntu Server, Slackware, Red Hat 6.1
Posts: 241

Original Poster
Rep: Reputation: 30
Quote:
Installed the drivers: wlan-ng-0.2.1-pre21
added modprobe prism2_usb to rc.modules
added alias wlan0 prism2_usb to /etc/modules.conf
ran wlanctl-ng wlan- lnxreq_ifstate ifstate=enable as per the instructions in the README
it returned wlanctl-ng: No such device
Exactly the steps I took (forgot the mention the alias step).

I just don't see how so many people are doing this without failure (according to the some other posts on LQ). There has to be some large step we're missing here. Please anyone.. there has to be SOMEONE out there that has installed this same usb wireless card on slackware.
 
Old 08-09-2004, 01:59 PM   #5
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Check: http://www.linuxquestions.org/questi...ighlight=wlan0

I'll quote two of the posts there:
Quote:
Originally posted by bmac83
I have a D-Link DWL-122 USB "pen-type" adapter, which is great for portability. It's a Prism-based device and everything worked out.

I installed the linux-wlan-ng package from Slackware's extra/ folder on the ftp server (make sure to match your kernel). After doing so, I put an alias in modules.conf for wlan0 to point to prism2_usb. I then plugged in the device and lsmod'ed it. Sure enough, the prism2 driver loaded correctly. Typing iwconfig at this point gave me "No wireless extensions", even for wlan0. I eventually found /etc/rc.d/rc.wlan (this appears automagically when you install linux-wlan-ng). I made it executable and ran (as root)

/etc/rc.d/rc.wlan start

And the device picked up as a wireless interface with extensions. You can iwconfig (for SSID/WEP/etc) and dhcpcd from there.

This was done with Slackware 10 and Pat's 2.6 kernel build. That's pretty good for out of the box working. Now to get hotplug to do this automatically...
Quote:
Originally posted by SiegeX
[B]With the 2.6 kernel you'll probably have to toss the kernel module into /etc/rc.d/rc.netdevice then add something like this to /etc/rc.d/rc.inet2

Code:
#Start up Wireless network
if [ -x /etc/rc.d/rc.wlan ]; then
  /etc/rc.d/rc.wlan start
fi
Then just make sure rc.wlan is chmod 750 and that should just about do it.

Last edited by gbonvehi; 08-09-2004 at 02:25 PM.
 
Old 08-09-2004, 04:04 PM   #6
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
i am using the d-link dwl-122 on a 2.6.6 kernel

followed the instructions in the wlan-ng readme:
Quote:
FOR USB USERS:

A) Make sure your kernel usb support is running
B) Plug in the Prism2.x USB device
C) Run 'modprobe prism2_usb prism2_doreset=1' to load the driver into memory.
D) Run 'wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable' to initialize the
driver+MAC functions.
E) Run 'wlanctl-ng wlan0 lnxreq_autojoin ssid=<your ssid> authtype=opensystem'
to enable the MAC in Infrastructure Station mode.
F) Run 'ifconfig wlan0 <your IP address>'
when i got it working i added this to my rc.local:
Quote:
modprobe prism2_usb prism2_doreset=1
wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
wlanctl-ng wlan0 lnxreq_autojoin ssid=mywlan authtype=opensystem
ifconfig wlan0 192.168.0.1 netmask 255.255.255.0 broadcast 192.168.0.255
route add default gw 192.168.0.1
dhcpcd wlan0
there are a couple things i still need to do like set encryption and make the rc.local script into a hotplug script instead, but i am happy just to have it working right now
 
Old 08-09-2004, 04:09 PM   #7
kodon
Member
 
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
Re: Same Problem!

Quote:
Originally posted by kmeehl
veritas, the first thing is that the alias goes in /etc/modules.conf, not /etc/rc.d/rc.modules

My setup is Slackware 9.1 running kernel 2.6.7

Here is what I've done:

Installed the drivers: wlan-ng-0.2.1-pre21
added modprobe prism2_usb to rc.modules
added alias wlan0 prism2_usb to /etc/modules.conf
ran [B]wlanctl-ng wlan- lnxreq_ifstate ifstate=enable
if you are running a 2.6 kernel, you need to add the alias line to /etc/modprobe.conf instead of /etc/modules.conf
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless network problems, ndiswrapper installed will not create wlan0 jackuss_169 Linux - Wireless Networking 6 08-14-2006 11:29 AM
wlan0: device not found anarchyprevails Linux - Wireless Networking 1 09-13-2005 03:48 PM
Cannot bring up wlan0 device JayBox Linux - Wireless Networking 6 05-31-2005 03:59 PM
Configuring a wlan0 device... GooPunch Linux - Wireless Networking 5 05-12-2004 07:35 PM
creating wlan0 device in slackware Henry Linux - Networking 44 10-18-2003 04:28 PM


All times are GMT -5. The time now is 11:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration