LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   hostapd problem with wpa (http://www.linuxquestions.org/questions/linux-wireless-networking-41/hostapd-problem-with-wpa-538915/)

mousi 03-19-2007 11:49 PM

hostapd problem with wpa
 
Hello, I have a PCI card with an Atheros chipset so I use the madwifi-ng-r2197 driver in ap mode. It works fine but is unsecured, so I tried to use hostapd. I use debian sarge with 2.6.8 kernel
Here is my hostapd.conf:

interface=ath0
bridge=br0
driver=madwifi
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
debug=0
dump_file=/tmp/hostapd.dump
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=my_net
macaddr_acl=1
accept_mac_file=/etc/hostapd/hostapd.accept
auth_algs=3
eapol_key_index_workaround=0
#eap_server=0
wpa=3
wpa_passphrase=pass
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP CCMP

The output of hostapd -dd hostapd.conf is:
Configuration file: hostapd.conf
Configure bridge br0 for EAPOL traffic.
madwifi_set_iface_flags: dev_up=0
Using interface ath0 with hwaddr 00:11:6b:61:7a:0a and ssid 'my_net'
madwifi_set_ieee8021x: enabled=1
madwifi_configure_wpa: group key cipher=1
madwifi_configure_wpa: pairwise key ciphers=0xa
madwifi_configure_wpa: key management algorithms=0x2
madwifi_configure_wpa: rsn capabilities=0x0
madwifi_configure_wpa: enable WPA= 0x3
madwifi_set_iface_flags: dev_up=1
madwifi_set_privacy: enabled=1
WPA: group state machine entering state GTK_INIT
GMK - hexdump(len=32): 24 ec 33 dd 8d 09 22 47 54 dd 02 3d d0 56 a9 55 8b 71 63
1f 6a 19 cc 01 c5 b8 aa f8 46 7c 4f 0d
GTK - hexdump(len=32): dc d7 46 6f a4 43 06 a8 b4 1d 1d 7e 8a 64 30 ff c9 31 d6
c2 37 f2 5e 16 6c b3 7d c6 bd a0 66 48
WPA: group state machine entering state SETKEYSDONE
madwifi_set_key: alg=TKIP addr=00:00:00:00:00:00 key_idx=1
ioctl[IEEE80211_IOCTL_SETKEY]: Argument list too long
Flushing old station entries
Deauthenticate all stations
l2_packet_receive - recv: Network is down
Wireless event: cmd=0x8c03 len=20
ath0: STA 00:16:cf:74:64:0f IEEE 802.11: associated
New STA
ioctl[unknown???]: Invalid argument
Failed to get WPA/RSN information element.

Can someone help me with this?

druida1492 05-12-2010 11:56 AM

hostapd
 
I have the same problem...could comebody help us?


All times are GMT -5. The time now is 02:22 PM.