LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-29-2004, 07:49 AM   #1
qbann
LQ Newbie
 
Registered: Mar 2004
Location: So Cal
Distribution: Laptop:Slackware 9.1 Desktop: Mandrake 9.2 Other: Knoppix STD .01
Posts: 9

Rep: Reputation: 0
Help : having problems with changing wireless card to monitor mode : AIRSNORT


Help : having problems with changing wireless card to monitor mode : AIRSNORT

first of all i have a ATHEROS AR5001X+ wireless card and i have all my drivers, with madwifi and everything. Next my distrubution of linux is Slackware 9.1

i have a problem with changing my wifi to monitor mode. How do you do it?
this is what i have tried.

iwconfig ath0 mode 1 = failed
iwconfig ath0 mode 2 = managed mode
iwconfig ath0 mode 3 = master mode

iwconfig ath0 mode monitor = failed
iwconfig ath0 mode managed = works
iwconfig ath0 mode master = works

iwpriv : i tried messing around with this but didnt work.

Finally, the program i need to put my wifi card in wireless mode is Airsnort which for device im using ath0 and for drivers im using other


thanks ....

Last edited by qbann; 03-29-2004 at 08:32 AM.
 
Old 03-29-2004, 08:27 AM   #2
qbann
LQ Newbie
 
Registered: Mar 2004
Location: So Cal
Distribution: Laptop:Slackware 9.1 Desktop: Mandrake 9.2 Other: Knoppix STD .01
Posts: 9

Original Poster
Rep: Reputation: 0
to see the stats

the wireless card stats are located here
http://www.atheros.com/pt/ar5001X+.html

by the way i could ad-hoc to work either

thanks
 
Old 03-29-2004, 07:32 PM   #3
qbann
LQ Newbie
 
Registered: Mar 2004
Location: So Cal
Distribution: Laptop:Slackware 9.1 Desktop: Mandrake 9.2 Other: Knoppix STD .01
Posts: 9

Original Poster
Rep: Reputation: 0
no one wants to help
 
Old 03-30-2004, 11:38 AM   #4
rjcamer
LQ Newbie
 
Registered: Mar 2004
Location: Los Angeles
Distribution: RedHat 9
Posts: 3

Rep: Reputation: 0
athernos and airsnort

Airsnort won't work with Atheros/madwifi (from what
I've read) --- a Prism card with Wlan_ng driver should work,
but I can't make that happen either (the wlan driver is
bugged out).

the sleepwalker
 
Old 03-30-2004, 07:13 PM   #5
qbann
LQ Newbie
 
Registered: Mar 2004
Location: So Cal
Distribution: Laptop:Slackware 9.1 Desktop: Mandrake 9.2 Other: Knoppix STD .01
Posts: 9

Original Poster
Rep: Reputation: 0
thx....well i have the card working now with airsnort but its not giving me a name do i need to patch my card with kismet ? help?
 
Old 04-01-2004, 06:24 PM   #6
qbann
LQ Newbie
 
Registered: Mar 2004
Location: So Cal
Distribution: Laptop:Slackware 9.1 Desktop: Mandrake 9.2 Other: Knoppix STD .01
Posts: 9

Original Poster
Rep: Reputation: 0
...
 
Old 04-07-2004, 04:49 PM   #7
qbann
LQ Newbie
 
Registered: Mar 2004
Location: So Cal
Distribution: Laptop:Slackware 9.1 Desktop: Mandrake 9.2 Other: Knoppix STD .01
Posts: 9

Original Poster
Rep: Reputation: 0
help plz
 
Old 10-29-2004, 12:05 PM   #8
theplop
LQ Newbie
 
Registered: Sep 2004
Location: Idaho
Distribution: Auditor, Slax 11, Sabayon Gentoo
Posts: 25

Rep: Reputation: 15
qbann
you either need to get new versions of madwifi, or fix the stuff you got

i have a atheros based card, Dlink DWL-G650 and i have used airsnort and got it to work


iwconfig ath0 mode monitor = Monitor mode
iwconfig ath0 mode monitor = Normal mode (put to this to use as normal, or to use kismet)

update your drivers and try it again, i ran that and now i'm in monitor mode....

Ok, a bit of a hint, i had to do some funny things to get airsnort to pick up my AP

First, you need the card to have a ssid assosiated with it, it doesn't have to be connected, just associated with something. Mine would not work if i didn't have a ssid associated with it.... no clue why....

so type: #iwconfig ath0 essid eggnog (or whatever ssid you want it)

start up airsnort
select ath0 as the network device
and "other" as driver type
select either scan or channel and hit start, it will start picking up packets.

ps. make sure you have a wep enabled ap in range
 
Old 10-29-2004, 01:57 PM   #9
theplop
LQ Newbie
 
Registered: Sep 2004
Location: Idaho
Distribution: Auditor, Slax 11, Sabayon Gentoo
Posts: 25

Rep: Reputation: 15
ok, i thought it would only scan channel 11... but i was wrong...

the program is just picky, sometimes you have to turn the card off or reset it

ifconfig ath0 down
ifconfig ath0 up

then:

iwconfig ath0 mode monitr

then try starting airsnort again.....
don't know why....anyways

Last edited by theplop; 10-29-2004 at 03:35 PM.
 
Old 11-11-2004, 04:59 PM   #10
ti009
LQ Newbie
 
Registered: Apr 2004
Posts: 1

Rep: Reputation: 0
Talking Atheros monitor mode

where can i get a copy of those drivers? i go to madwifi but couldn't find it
 
Old 11-11-2004, 06:23 PM   #11
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
http://madwifi.sourceforge.net/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless card for airsnort liquidjojo Linux - Wireless Networking 0 04-10-2005 06:36 PM
Need some help in monitor mode for a 3Com wireless card Asagath Linux - Wireless Networking 2 12-10-2004 05:34 PM
Can't set monitor mode for Dell TrueMobile 1150 wireless card allisatest Linux - Wireless Networking 3 05-13-2004 05:18 PM
Setting Orinoco wireless card to monitor mode RogerM Linux - Wireless Networking 2 09-16-2003 09:41 AM
wireless card airsnort X_masterz2000 Linux - Hardware 1 04-16-2003 09:27 PM


All times are GMT -5. The time now is 07:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration