LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 03-06-2008, 07:06 PM   #1
harlequinguy
LQ Newbie
 
Registered: Feb 2007
Location: Central California
Distribution: Linux Mint Debian
Posts: 11

Rep: Reputation: 0
Question GuardDog killed my Internet ?!


Yesterday I installed the Guard Dog and Firestarter
firewalls to try them. Both are now gone but it's
my guess they sealed some vital ports -- I now
have no internet feed??

The system is a Dell Inspiron 1420, running a Netgear
wireless connection via NDIS-Wrapper. As far as I
can see the connection should work: Network Manager
gives me green lights, prism2 is blocked, the terminal
says NDIS is running and it loads at start-up...But
when I open a browser it's blank.

If you guys have any ideas on how to re-connect I'd
appreciate the info -- Having to communicate with the
world using the Redmond virus is making me sick.

Thanks,

Michael.
using Kubuntu 7.10
[The Heron lands on 4/24!]
 
Old 03-07-2008, 07:34 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
What's the output (you need to be root) of iptables -L
Your Netgear modem probably already has a firewall (mine does, so I just use that)
 
Old 03-07-2008, 11:59 AM   #3
Mithrilhall
Member
 
Registered: Feb 2002
Location: Massachusetts
Distribution: Debian (Lenny)
Posts: 286

Rep: Reputation: 30
Code:
iptables -F
I believe this will flush iptables for you.
 
Old 03-07-2008, 12:27 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
Code:

iptables -F

I believe this will flush iptables for you.
Indeed, but it would be nice to know if iptables is the reason he has lost connectivity, before he messes with it
 
Old 03-07-2008, 01:39 PM   #5
Mithrilhall
Member
 
Registered: Feb 2002
Location: Massachusetts
Distribution: Debian (Lenny)
Posts: 286

Rep: Reputation: 30
True indeed.
 
Old 03-08-2008, 11:19 AM   #6
harlequinguy
LQ Newbie
 
Registered: Feb 2007
Location: Central California
Distribution: Linux Mint Debian
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks for the help, guys. Here's the readout:

#1. The output of "iptables -L" was...

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


#2. iptables -F will flush the iptables for you.
It did! And I appreciate it. But I'm still disconnected

~~~

On boot-up, the progress bar gets about half-way and the LED on the
MA111 USB adapter now starts flashing to indicate no signal. Kubuntu can
see the router, the ESSID and the network connection...it just won't
connect?!

NDISwrapper is loaded and running, "ndiswrapper -L" shows the driver is
loaded, and the conflicting driver [prism2_usb] is blacklisted. No router
settings have been changed and Network Manager has the correct ESSID and
password....yet I'm still forced to report this using the Redmond virus??

If you guys can give me a clue what the Fark's happened to my internet, I'd
be eternally grateful -- I'm tearing my hair out here!

Thanks,

Michael.

Last edited by harlequinguy; 03-08-2008 at 11:37 AM.
 
Old 03-08-2008, 11:48 AM   #7
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
[QUOTE]#1. The output of "iptables -L" was...[QUOTE]
That shows taht iptables is running, but there are no rules, so it is not doing anything.
Quote:
#3. /etc/resolv.conf file.
I'm using Kubuntu 7.10. It doesn't have this file.
I find that very strange. I think you should have that file, although in my 6.06.1 kubuntu, it is symlinked to /etc/resolvconf/run/resolv.conf

Meanwhile, please post the output of:
cat /etc/network/interfaces
ifconfig (you'll need to be root)
iwlist scan (you'll need to be root)
 
Old 03-08-2008, 12:25 PM   #8
harlequinguy
LQ Newbie
 
Registered: Feb 2007
Location: Central California
Distribution: Linux Mint Debian
Posts: 11

Original Poster
Rep: Reputation: 0
#1. /etc/resolv.conf file.
Still can't find this file?? I did "sudo editor" in a terminal
and it was a blank, new file. So was "/etc/resolvconf/run/resolv.conf"

#2 The result of "cat /etc/network/interfaces" was...

auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp

iface wlan1 inet dhcp
wireless-essid: ...was the correct entry
wireless-key s: ...was the correct entry

auto wlan1

<>~~~~~~~~~~~~~~~~~~~~~<>

#3 The output from ifconfig was:

eth0 Link encap:Ethernet HWaddr 00:01:03:1D:3B:BF
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:840 (840.0 b)
Interrupt:11 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2368 (2.3 KiB) TX bytes:2368 (2.3 KiB)

wlan1 Link encap:Ethernet HWaddr 00:09:5B:B2:54:E6
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

<>~~~~~~~~~~~~~~~~~~~~~<>

The output from "iwlist scan" was:

lo Interface doesn't support scanning.
eth0 Interface doesn't support scanning.
wlan1 Scan completed :
Cell 01 - Address: 00:09:5B:CF:042
ESSID: ...was the correct entry
Protocol:IEEE 802.11b
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:62/100 Signal level:-56 dBm Noise level:-96 dBm
Encryption keyn
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 27.5 Mb/s
9.5 Mb/s
Extra:bcn_int=100
Extra:atim=29432

~~~

If you can tell what all this means, I salute you!

My first target of suspicion would be
"iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0"

...according to the router's home page my PC's address
should be 192.168.0.2, and the netmask is 255.255.255.0"

Could updating these settings be the solution?


Michael.

Last edited by harlequinguy; 03-08-2008 at 12:36 PM.
 
Old 03-08-2008, 12:48 PM   #9
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
You are making things difficult for me as you are removing your ESSID & keys
I appreciate your need for security, but noone even knows where you live, and I doubt any LQ readers are within 100metres of you!
In any case, once we have this working, you can change your ESSID / keys.

/etc/resolv.conf
is empty because you are not getting a DNS server address from your modem / router. This should normally be the LAN address of your modem / router.
iwlist scan shows your wireless is seeing your modem/router. Good.
ifconfig shows your wireless interface is on wlan1 but it is not transmitting or receiving any data.
/etc/network/interfaces looks OK, except that I would have put the line "auto wlan1" before the line "iface wlan1 inet dhcp", but perhaps this does not matter.

Have you enabled the LAN dhcp server in your modem / router?
What is the LAN IP of your modem / router? (something like 10.0.0.1 or 192.168.0.1 usually)
Can you ping your modem / router (as root):
ping -c 2 IP.ADDY.OF.MODEM

In addition, what happens when you do (both as root)
ifdown wlan1
ifup wlan1

Any interesting messages?

Have you set up your modem/router only to allow connections from specific HW addresses or hostnames?
 
Old 03-08-2008, 12:55 PM   #10
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
My first target of suspicion would be
"iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0"

...according to the router's home page my PC's address
should be 192.168.0.2, and the netmask is 255.255.255.0"

Could updating these settings be the solution?
Please do not go back and edit your post whilst I am replying to it: This creates chaotic threads. Just add another post.

The loopback interface is normal. Do not change it, or your linux will break.

OK, I now know the LAN addy of your router. It should be 192.168.0.2 unless you have changed it (Go to its web administration page to check this and the other things I asked you about it- you'll need an ethernet cabled connection to do this. Plug in the cable, then
ifdown eth0
ifup eth0

to bring up your wired connection
)
then http://192.168.0.2 to see how the modem/router is set up.
 
Old 03-08-2008, 01:57 PM   #11
harlequinguy
LQ Newbie
 
Registered: Feb 2007
Location: Central California
Distribution: Linux Mint Debian
Posts: 11

Original Poster
Rep: Reputation: 0
1. If "/etc/resolv.conf" is empty because there's no DNS address, and
"iwlist scan" says I can see the router, would adding the DNS address
to resolv.conf cure this snafu? My access point is reported as "Not
associated" Would this 'associate' it and get Linux back to normal?

2. "Have you enabled the LAN dhcp server in your modem / router?"
Yup. Nothing on the router's been changed since Wednesday when
this problem started. The router works perfectly if I plug the
same USB stick into an XP box, but Linux refuses to connect.

3. "Can you ping your modem / router (as root)":
No, it reports "ping: unknown host http://192.168.0.1"

3. "What happens when you do..."
a) ifdown wlan1
"There is already a pid file /var/run/dhclient.wlan1.pid with pid 4491
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4

Listening on LPF/wlan1/00:09:5b:b2:54:e6
Sending on LPF/wlan1/00:09:5b:b2:54:e6
Sending on Socket/fallback"

<>------------------------------------<>

b) ifup wlan1
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan1 ; Invalid argument.
There is already a pid file /var/run/dhclient.wlan1.pid with pid 134993416

Listening on LPF/wlan1/00:09:5b:b2:54:e6
Sending on LPF/wlan1/00:09:5b:b2:54:e6
Sending on Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 4
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

4. Have you set up your router only to allow connections
from specific HW addresses or hostnames?
Nope. As I said, no settings have been changed since Linux
last worked, so as far as I can see it should still connect??

Over to you...

Michael
 
Old 03-08-2008, 02:19 PM   #12
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
1. If "/etc/resolv.conf" is empty because there's no DNS address, and "iwlist scan" says I can see the router, would adding the DNS address
to resolv.conf cure this snafu?
I very much doubt it.
Quote:
2. "Have you enabled the LAN dhcp server in your modem / router? Yup."
OK
Quote:
3. "Can you ping your modem / router (as root)":
No, it reports "ping: unknown host http://192.168.0.1"
I thought you said your modem / router was at 192.168.0.2
Please try again. ([Edit]: See my follow-up post, next [/Edit])

Quote:
b) ifup wlan1
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan1 ; Invalid argument.
Odd error here. This needs investigating I think.
Quote:
Sending on Socket/fallback
DHCPDISCOVER on wlan1 to 255.255.255.255 port 67 interval 4
[snip]
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Your modem / router is not listening, or not hearing, or not receiving the request for DHCP.
Quote:
Have you set up your router only to allow connections
from specific HW addresses or hostnames?
Nope.
That's not it then.

Last edited by tredegar; 03-08-2008 at 02:27 PM.
 
Old 03-08-2008, 02:25 PM   #13
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Follow-op:
I wrote
Quote:
Quote:
3. "Can you ping your modem / router (as root)":
No, it reports "ping: unknown host http://192.168.0.1"
I thought you said your modem / router was at 192.168.0.2
Please try again.
You need to ping 192.168.0.2, not ping http://192.168.0.1
 
Old 03-08-2008, 02:35 PM   #14
harlequinguy
LQ Newbie
 
Registered: Feb 2007
Location: Central California
Distribution: Linux Mint Debian
Posts: 11

Original Poster
Rep: Reputation: 0
No, the router's address is "168.0.1." So I pinged that. The
"168.0.2" address is the Linux box I'm trying to connect to it.
 
Old 03-08-2008, 02:43 PM   #15
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
Quote:
No, the router's address is "168.0.1." So I pinged that.
168.0.1. is not a valid IP address.
192.168.0.1 is a valid IP address, and that it, seems is the IP of your router. Can you ping it?

ping 192.168.0.1

NOT

ping http://192.168.0.1
 
  


Reply

Tags
guarddog, internet, ndiswrapper, router


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Edgy upgrade killed my internet... (iMac G4 PPC) goldenratiophi Ubuntu 2 10-26-2006 05:41 PM
Internet sharing, using GuardDog & GuideDog. gonus Linux - Networking 0 08-27-2004 08:55 PM
Help needed! I've killed my internet settings! elyk Slackware 2 08-15-2004 02:16 AM
No internet connection after uninstalling Guarddog macleodjd Linux - Security 6 03-01-2004 09:46 PM
guarddog blocks internet access periodically stelmed Slackware 0 02-06-2004 08:44 PM


All times are GMT -5. The time now is 02:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration