LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 01-28-2007, 06:52 AM   #1
santiagosilva
Member
 
Registered: Jan 2004
Posts: 214

Rep: Reputation: 30
Fedora Core 6 doesn't detect the wireless conection as a wireless conection...?


Hey all...

I'm using the fedora core 6 with the with the iwp2200 and all that.

the network setup says my eth0 is a wireless connection using the driver, i've put the firmware in /lib/firmare/ , everything is in order, on paper.

but when I go to add a wireless connection, it won't let me.
the devices arn't there.
but when I choose 'ethernet-connection' , it'll give me the option of "wireless driver"... but ofcourse it wont actually be a wireless connection.

does this make any sence?

I can't see what step(s) i've missed.

please help me!
thanks for your time
//Santiago
 
Old 01-28-2007, 07:32 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
So, it is an Ethernet device which happens to be wireless. What label it is known as eth0, wlan0 or any other name does not really matter as far as Linux is concerned. Does the driver load???? Can you connect with the device???

Try something as root like;

/sbin/iwlist eth0 scan

Do you see any wireless networks?? If yes then try;

/sbin/dhclient eth0
 
Old 01-28-2007, 07:38 AM   #3
santiagosilva
Member
 
Registered: Jan 2004
Posts: 214

Original Poster
Rep: Reputation: 30
sorry,
yes I use the eth0.
I can connect as in I'm using the internet with it right now.
In the network setup window it says it's wireless. even has the icon. but once I unplugg the cable, it dies.

and when I tried your command , I got:
eth0 Interface doesn't support scanning

thanks for your quick reply
//Santiago
 
Old 01-28-2007, 09:00 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Do not worry the iwlist command, since you have a cable then this is not a wireless device.

You may have both a wired connection (currently eth0) and a wireless connection. Check the output from the typed command to see if this is true; /sbin/lspci -v

If yes then post back the information about the wireless device, just the part about the device please. For example;

00:0b.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
Subsystem: AMBIT Microsystem Corp. TravelMate 2410
Flags: bus master, fast devsel, latency 64, IRQ 17
Memory at e2000000 (32-bit, non-prefetchable) [size=8K]
 
Old 01-29-2007, 04:44 PM   #5
santiagosilva
Member
 
Registered: Jan 2004
Posts: 214

Original Poster
Rep: Reputation: 30
Does this help?

when I was using Mandriva 2006, I could use it as a wireless. very unstable, but still worked using the instructions on the different web pages.


-------------------------------------------------------
06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)
Subsystem: Hewlett-Packard Company Unknown device 12f5
Flags: medium devsel, IRQ 18
Memory at b0106000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [dc] Power Management version 2


06:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Subsystem: Hewlett-Packard Company Unknown device 309d
Flags: bus master, medium devsel, latency 128, IRQ 18
I/O ports at 3000 [size=256]
Memory at b0109400 (32-bit, non-prefetchable) [size=256]
Capabilities: [50] Power Management version 2
===================================
hope this helps.

also, in the network configuration window, it says that eth1 is using the wireless driver.
it says eth0 IS a wireless connection, but uses "Real Tech Semiconductor..." something.

I don't know if this helps atal.

wierd...

thanks for your help
//Santiago
 
Old 01-29-2007, 05:26 PM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
This is a little strange, the Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ Ethernet interface should be a wired connection. Since you can use eth0 maybe something unexplained has happened. Take a look at both files, ifcfg-eth0 and ifcg-eth1 in the directory /etc/sysconfig/network-scripts and have a look at the etc/modprobe.conf file also.

The wireless device should be using the ipw2200 kernel module, check the /proc/modules and see if the driver is loaded; cat /proc/modules | grep ipw200

If not the as root try loading it; modprobe ipw2200

Also make sure the /etc/modprobe.conf files use the ipw2200 for eth1; alias eth1 ipw200

Also disable the kudzu service; chkconfig --level 345 kudzu off
This will stop the service from renaming/reconfiguring eth0 and eth1
 
Old 01-29-2007, 05:51 PM   #7
santiagosilva
Member
 
Registered: Jan 2004
Posts: 214

Original Poster
Rep: Reputation: 30
ok...

[root@localhost santiago]# more /etc/sysconfig/network-scripts/ifcfg-eth0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Wireless
DEVICE=eth0
HWADDR=00:0a:e4:d7:bc:8a
BOOTPROTO=dhcp
ONBOOT=yes
USERCTL=no
IPV6INIT=no
PEERDNS=yes
NETMASK=
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ESSID=samick
CHANNEL=1
MODE=Managed
RATE=Auto

============================
the eth1 one doesn't seem to exist

========================
[root@localhost santiago]# cat /proc/modules | grep ipw2200
ipw2200 149801 0 - Live 0xf8b7d000
ieee80211 36233 1 ipw2200, Live 0xf8b45000

==========================
 
Old 01-30-2007, 08:36 AM   #8
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Hmmmm..........

Check your /etc/modprobe.conf file for somethings like;

alias eth0 ipw2200
alias eth1 8139too (or 8139cp)

Also check which /etc/sysconfig/network-scripts/ifcfg-XXXX files you have, you may find one or more named something like ifcfg-dev123456 for example.

You might want to create an ifcfg-eth1 file which read something like;

TYPE=Ethernet
DEVICE=eth1
HWADDR=
BOOTPROTO=dhcp
ONBOOT=no
USERCTL=yes
IPV6INIT=no
PEERDNS=no

And make sure that your /etc/modprobe.conf file has the alias lines above. And do disable the kudzu service if you have not already done so.
 
Old 01-30-2007, 12:48 PM   #9
santiagosilva
Member
 
Registered: Jan 2004
Posts: 214

Original Poster
Rep: Reputation: 30
in the modprobe.conf I have :

alias eth0 8139too
alias eth1 ipw2200



could I just switch these?


and for ifcfg files, I have
ifcfg-eth0
ifcfg-lo


do I change anything in the ifcfg-eth0 ?
do I just create a ifcfg-eth1 file ?


thanks.

//S
 
Old 01-30-2007, 04:58 PM   #10
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
All you really need to do is edit the current ifcfg-eth0 file and change the DEVICE= line to be eth1 and save it as ifcfg-eth1. Create a new ifcg-eth0 file like the example I provided earlier and save in the /etc/sysconfig/network-scripts directory. When done restart the network services; service network restart

.
 
Old 01-31-2007, 12:57 PM   #11
santiagosilva
Member
 
Registered: Jan 2004
Posts: 214

Original Poster
Rep: Reputation: 30
I did all these steps, but it's still not working.

Is it possible I didn't copy the right files to the /etc/firmware/ folder?
meaning the right version/updated version .

thanks
//S
 
Old 01-31-2007, 01:32 PM   #12
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Get them all (start with version 2.2 and above) from here and try them out, just copy the extracted firmware files to the /lib/firmware directory;

http://ipw2200.sourceforge.net/firmware.php
 
Old 01-31-2007, 01:51 PM   #13
santiagosilva
Member
 
Registered: Jan 2004
Posts: 214

Original Poster
Rep: Reputation: 30
still doesn't help..

in the 'services' under 'status' it says :
Configured devices:
lo eth0 eth0.old eth1
Currently active devices:
lo eth0



does this help?

//S
 
Old 01-31-2007, 07:18 PM   #14
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Please review this thread, you have everything you need within it. Take your time read, think and reflect.

It is not that I am not willing to help, I have.

You have the information but for whatever reason 'we' are not communicating very well. You have two Ethernet devices, one wired (8139too) and one wireless (ipw2200). It does not matter by what name they are called (eth0, eth1, wlan0 or any other name) as long as the system and you know which is which.

If the wireless device is eth0 then it is eth0, make sure that the /etc/modprobe.conf file knows which driver to alias to eth0. Do the same with the wired Ethernet device, if it is known as eth1 and has the correct alias in /etc/modprobe.conf then it will work.

The ifcfg-eth0 file must have the line DEVICE=eth0 in it and the ifcfg-eth1 must have the line DEVICE=eth1 in it. You have examples of what the wireless ifcfg-ethX file should look like and what the wired ifcfg-ethX file should look like, apply the knowledge. X is any number from 0 to whatever.

Also see these links;
http://www.linuxquestions.org/hcl/sh...ct=482&cat=473
http://www.linuxquestions.org/hcl/sh...t=1630&cat=140

.

Last edited by Lenard; 01-31-2007 at 07:28 PM.
 
Old 01-31-2007, 08:21 PM   #15
santiagosilva
Member
 
Registered: Jan 2004
Posts: 214

Original Poster
Rep: Reputation: 30
Thank you for all your help, and sorry for any inconvenience.

I've done all the steps to the T.
The only other things I could think of :

a.) One line in one of the files are wrong.
b.) There's some system service that keeps changing something in the setup.

c.) In my network command center, I now get the error message :
ipw2200 device eth0 does not seem to be present, delaying initialization.

when I try to activate the eth0


could this mean that the module for ipw2200 isn't installed atal?

the files that you told me to edit have been done so exactly as you told me.

It seems like I'm getting closer and closer to the answere, but I know it's going to come down to something stupid that , either I forgot, or something that was misstyped...

have a good one.
/santiago

Last edited by santiagosilva; 02-01-2007 at 01:19 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems setting up a wireless conection (FC6) odiseo77 Linux - Wireless Networking 2 01-21-2007 06:24 PM
cant access internet through wireless conection Nadia86 Linux - Software 2 02-22-2006 10:19 AM
Slow wireless g conection sniff Linux - Wireless Networking 7 01-04-2005 10:50 AM
fedora core 2 doesn't detect my belkin wireless apater skymax Linux - Wireless Networking 5 10-22-2004 05:17 AM
Fedora Core 2 does not detect wireless card Udip2laM9r Linux - Wireless Networking 0 07-29-2004 02:01 PM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration