LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 11-17-2007, 05:40 PM   #1
Ada
LQ Newbie
 
Registered: Aug 2003
Posts: 13

Rep: Reputation: 0
FC8 networkmanager and WPA


Hello all. I've been struggling the past few days to resolve an issue I'm having. I have followed all the steps in ndiswrapper wiki and had no problems with my box recognizing the wireless adapter. I use network manager to connect to my router. I can connect perfect when my router is set to 'Open' (no security) and I'm able to gain an IP address. However, once I set WPA on the router and try connecting the same exact way through networkmanager, I see that it can't retrieve an IP now. The passphrase I type into networkmanager when it prompts me is correct.

I have wpa_supplicant installed but I have no idea if I have it configured correctly or if I even need to worry about that. I've hit a brick wall. ANy suggestions?

Here is some of the output code I get:

Code:
Nov 17 05:17:33 localhost NetworkManager: <info>  User request for activation of wlan0.
Nov 17 05:17:33 localhost NetworkManager: <info>  Activating device wlan0
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0/wireless): access point 'Auto TheHouse' has security, but secrets are required.
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Nov 17 05:17:33 localhost NetworkManager: Missing required value 'key-mgmt'.
Nov 17 05:17:33 localhost NetworkManager: Missing or invalid key management
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0/wireless): connection 'Auto TheHouse' has security, and secrets exist.  No new secrets needed.
Nov 17 05:17:33 localhost NetworkManager: <info>  Config: added 'ssid' value 'TheHouse'
Nov 17 05:17:33 localhost NetworkManager: <info>  Config: added 'key_mgmt' value 'WPA-PSK'
Nov 17 05:17:33 localhost NetworkManager: <info>  Config: added 'psk' value '<omitted>'
Nov 17 05:17:33 localhost NetworkManager: <info>  Config: added 'proto' value 'WPA RSN'
Nov 17 05:17:33 localhost NetworkManager: <info>  Config: added 'pairwise' value 'TKIP CCMP'
Nov 17 05:17:33 localhost NetworkManager: <info>  Config: added 'group' value 'WEP40 WEP104 TKIP CCMP'
Nov 17 05:17:33 localhost NetworkManager: <info>  Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Nov 17 05:17:33 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 0 -> 2
Nov 17 05:17:36 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 2 -> 3
Nov 17 05:17:37 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 3 -> 4
Nov 17 05:17:37 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 4 -> 5
Nov 17 05:17:37 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 5 -> 6
Nov 17 05:17:40 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 6 -> 0
Nov 17 05:17:40 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 0 -> 2
Nov 17 05:17:43 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 2 -> 3
Nov 17 05:17:45 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 3 -> 4
Nov 17 05:17:45 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 4 -> 5
Nov 17 05:17:45 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 5 -> 6
Nov 17 05:17:48 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 6 -> 0
Nov 17 05:17:48 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 0 -> 2
Nov 17 05:17:51 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 2 -> 3
Nov 17 05:17:52 localhost NetworkManager: <info>  Activation (wlan0/wireless): disconnected during association, asking for new key.
Nov 17 05:17:52 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 3 -> 0
Nov 17 05:17:53 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 0 -> 4
Nov 17 05:17:53 localhost NetworkManager: <info>  (wlan0) Supplicant interface state change: 4 -> 0
Nov 17 05:17:58 localhost NetworkManager: <WARN>  get_secrets_cb(): Couldn't get connection secrets: applet.c.2997 (get_secrets_dialog_response_cb): canceled.
Nov 17 05:17:58 localhost NetworkManager: <info>  Activation (wlan0) failed for access point (TheHouse)
Nov 17 05:17:58 localhost NetworkManager: <info>  Marking connection 'Auto TheHouse' invalid.
 
Old 11-17-2007, 07:05 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
What is in /etc/wpa-supplicant/wpa_supplicant.conf file

Brian
 
Old 11-19-2007, 02:57 AM   #3
Ada
LQ Newbie
 
Registered: Aug 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Brian1 View Post
What is in /etc/wpa-supplicant/wpa_supplicant.conf file

Brian

Welp, I got my networkmanager working now with WPA. It is now connected to my router. But here is my wpa_supplicant.conf. Now iirc, it wont work without the
Code:
#psk="mypassphrase"
. Once I added that in, it worked. Dunno if it was just a coincidence.


Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
network={
        ssid="TheHouse"
        scan_ssid=0
        proto=WPA
        key_mgmt=WPA-PSK
        #psk="mypassphrase"
        psk="df9832sd9238nx2n2we87w8s8f7wesghh84lkwerklkj3eg940348909fgdlj3498dlkj0"
        pairwise=TKIP
        group=TKIP
}
Now.. to find a way to iwconfig wlan0 at startup and have network manager always remember my passphrase connecting to my router.

*edited to fill in psk with bunk numbers/letters*

Last edited by Ada; 11-19-2007 at 02:58 AM.
 
Old 11-19-2007, 05:28 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I myself don't like NetworkManager. I would do it like this. I don't know how to make NetworkManager to use it. But I have a thought and add this line to the following to the end of /etc/sysconfig/network-scripts/ifup-wireless.
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -dd

Reboot and give NetowrkManager a try this way.

================================================================

If it does not help the only other way I know is manually adding the following to certain files and disable NetworkManager.

Disable NetworkManager, run these two commands as root.
/sbin/service NetworkManager stop
/sbin/chkconfig --level 345 NetworkManager off

Load the ndiswrapper module in /etc/modprobe.conf. Add this line to it.
alias wlan0 ndiswrapper

Next you should have /etc/sysconfig/network-scripts/ifcfg-wlan0 configured for nic. I assume setup as DHCP and ONBOOT=YES. If unsure what should be ther post the contents.

If there is a ifcfg-eth0 then make sure it has ONBOOT=NO

Now add this line to the end if /etc/sysconfig/network-scripts/ifup-wireless
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -dd

Brian
 
Old 11-21-2007, 01:24 AM   #5
Ada
LQ Newbie
 
Registered: Aug 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Well, I got to test a few things out. The first step did not work for me because this linux box doesn't recognize that I have a wlan0 until I actually go into the terminal and initialize it by doing a:

Code:
iwconfig wlan0
Is there any way for me to have that speck of code run after a reboot or startup?
 
Old 11-21-2007, 09:38 PM   #6
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
If run the same commands just to get it going then add them to the end of /etc/rc.local. It is one of the last things to be run at bootup.

Brian
 
Old 11-22-2007, 12:36 PM   #7
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
I jump the gun here. You did not mention the nic that is invloved and the chipset it is using. Plus the module it uses. I define the wpa_supplicant with the use of Ndiswrapper module. If you have no wlan0 then you may not be using ndiswrapper. This info we need to know to help select the correct -D option for this interface.

Brian
 
Old 11-23-2007, 03:18 AM   #8
Ada
LQ Newbie
 
Registered: Aug 2003
Posts: 13

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Brian1 View Post
I jump the gun here. You did not mention the nic that is invloved and the chipset it is using. Plus the module it uses. I define the wpa_supplicant with the use of Ndiswrapper module. If you have no wlan0 then you may not be using ndiswrapper. This info we need to know to help select the correct -D option for this interface.

Brian
Well, I think I'm making some progress. I'm convinced now that networkmanager isn't very good on FC8, so I'm going your route. I've uninstalled NM and am now currently connected to my router using only ndiswrapper (Buffalo Wireless-N USB adapter), wpa_supplicant, dhclient.

My current process to get there is as follows:

ifconfig wlan0 up
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
dhclient wlan0

This weekend I'll most likely have time to mess with the code below the equal sign horizontal rule. I'll keep you posted.
 
Old 01-13-2008, 06:08 PM   #9
henry_shadowjet
Member
 
Registered: Oct 2006
Posts: 55

Rep: Reputation: 15
Hi everyone.

For some reason, I have almost the same problem. Only the difference is mine originally worked. After 1 batch of updates that I installed, next time I reboot the laptop, the wireelss is just not working anymore.

I usually used NetworkManager and it used to work like a charm, but as I said above, it just stops working.

Before I started using NetworkManager, I have been just using the system-config-network and configured the passphrase from there (since mine's just Hex) and I can connect through. But this time I get "failed. Please check cable?" or something similar.

Any help would be much appreciated
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
scripts (kommander and command line) to start wireless devices with wpa/wpa2/wpa-aes Fluxx Linux - Wireless Networking 4 06-28-2010 03:51 AM
usb network adapter with ndiswrapper can't connect to wpa with wpa-supplicant AceofSpades19 Linux - Wireless Networking 8 03-30-2008 06:13 PM
FC8 + ndiswrapper disco192 Fedora 1 11-09-2007 09:18 AM
[ipw2200 & WPA] Need help to connect to WPA enabled router. Hyakutake Slackware 2 03-02-2007 10:58 AM
How do i set up WPA PSK with wpa supplicant and linuxant? Eleavings Linux - Wireless Networking 4 12-27-2004 12:24 PM


All times are GMT -5. The time now is 04:03 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration