LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 01-27-2013, 09:29 AM   #1
1991sudarshan
Member
 
Registered: Apr 2011
Location: Chennai,India
Distribution: Kubuntu
Posts: 49

Rep: Reputation: 0
Ethernet Port not detected after Mother Board Replacement


I have a dual boot of Kubuntu 10.04 and Windows XP.Recently, I got by mother board replaced to ASROCK G41M-VS3 R2.0 . Previously I used ASUS P5KPL-AM/PS with RealTecc LAN card. In this ASROCK mother board I have Atheros AR8151 ethernet port. The issues is that Kubuntu doesn't detect and connect to the Ethernet. While going through some forums I came to know that I have to install the drivers for the Atheros Ethernet and I have to install kernel-headers . Could someone guide me.

Thank you.
 
Old 01-27-2013, 09:35 AM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,489

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
You should first install the kernel-headers and the kernel source packages.

That done, check for the drivers in your system. Best to check for your driver on
www.linuxwireless.org/en/users/Drivers

When you get the source, open it and read the README, INSTALL, or any other doc that tells you what to do. Then do it.
 
Old 01-27-2013, 09:39 AM   #3
1991sudarshan
Member
 
Registered: Apr 2011
Location: Chennai,India
Distribution: Kubuntu
Posts: 49

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by business_kid View Post
You should first install the kernel-headers and the kernel source packages.

That done, check for the drivers in your system. Best to check for your driver on
www.linuxwireless.org/en/users/Drivers

When you get the source, open it and read the README, INSTALL, or any other doc that tells you what to do. Then do it.
Actually I posted thread in this sub forum by mistake. I have wired ethernet. The thing is I am using the internet through my Netbook and I don't know to install the kernel-headers and kernel source package without internet.
 
Old 01-28-2013, 05:04 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,489

Rep: Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567Reputation: 567
AAAHH!

Netbook. I would go to another PC copy them onto a usb key /phone storage / camera storage
You will want: kernel-headers-<highest-number-on-offer> and linux-<highest-number-on-offer> I don't know where you get kubuntu debs, bit I'm sure you'll find it.
 
Old 01-28-2013, 08:48 AM   #5
1991sudarshan
Member
 
Registered: Apr 2011
Location: Chennai,India
Distribution: Kubuntu
Posts: 49

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by business_kid View Post
AAAHH!

Netbook. I would go to another PC copy them onto a usb key /phone storage / camera storage
You will want: kernel-headers-<highest-number-on-offer> and linux-<highest-number-on-offer> I don't know where you get kubuntu debs, bit I'm sure you'll find it.
Yes I found those packages. Thank you so much.

I ran this in the terminal

sudo apt-get install linux-headers-$(uname -r)

since there is no internet connection the apt-get showed errors along with the url of the linux header packages. I downloaded them in my netbook and installed them in my desktop and then I followed the steps given in this blog
http://tuxthink.blogspot.in/2010/08/...roller-on.html

Code:
$sudo apt-get install linux-headers-$(uname -r)
The Atheros drivers for ubuntu 10.04 and 10.10

ubuntu 10.04 :

http://media.cdn.ubuntu-de.org/forum....0.1.14.tar.gz

ubuntu 10.10

http://media.cdn.ubuntu-de.org/forum...4_10.10.tar.gz

Code:
tar -xzvf AR81Family-Linux-v1.0.1.9.tar.gz

sudo su

cd scr 

make install

modprobe atl1e

exit

Last edited by 1991sudarshan; 01-28-2013 at 08:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Cannot start ubuntu (or other distros) after mother board replacement fotofill1969 Linux - Hardware 8 03-03-2012 08:53 AM
on-board ethernet card not detected Rohan_mk1 Linux - Hardware 1 12-24-2006 08:31 AM
OnBoard Ethernet Not Detected (K7 Mother Board) tribeone Linux - Networking 18 11-27-2006 06:20 PM
Unable to get the on board ethernet card to be detected jspsandhu Linux - Hardware 3 06-07-2006 07:29 PM
MSI RS480m2/RX480m2 mother board - no sound card detected lv2golf Linux - General 8 03-20-2006 11:47 AM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration