LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 02-15-2008, 08:59 PM   #1
Lost In Here
LQ Newbie
 
Registered: Feb 2008
Posts: 13

Rep: Reputation: 0
Ethernet and wifi are broken!!


I'm using RHEL5

After wrestling with the driver, I eventually made my bcm4318 card work on unsecured networks. However, RHEL's network configuration utility did not allow me to access my secure wireless connection. (Yes, I did attempt to configure the SSID, encryption key, ect...)

I decided to try different programs to manage networking.

I installed wifi-radar (from source) but never managed to connect with any network.

Unfortunately, now neither my ethernet nor my wifi work.

The network gui shows that my ethernet is connected and active but my programs cannot access the internet. My pings get no response. Firefox cannot connect and the add/remove programs utility reports an error.

I attempted to uninstall wifi-radar by deleting the files in the makefile and it no longer runs, but I don't know if I got it all.

Can anyone help?

Last edited by Lost In Here; 02-15-2008 at 09:00 PM.
 
Old 02-15-2008, 09:58 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Could and should have tried running make unistall from the wifi-radar source directory.

You can also try removing the alias ethx <some driver> and alias wlan0 ndiswrapper line entries from /etc/modprobe.conf file. Also try removing the ifcfg-ethX and ifcfg-wlan0 files from /etc/sysconfig/networking-scripts directory.

In the /etc/modprobe.d/ directory edit the blacklist file and add;

#wireless
blacklist bcm43xx

When done reboot the system, the wired Ethernet interface should be reconfigured hopefully by kudzu.

Bring your system current by typing yum update when done reboot

For the wireless broadcom interface install the rpmforge-release package as directed here;

http://dag.wieers.com/rpm/FAQ.php#B

When done type yum install dkms dkms-ndiswrapper

See the instructions on how to install the Windows XP drive for use with ndiswrapper;

http://ndiswrapper.sourceforge.net/j...,installation/
(starting at the "Install Windows driver" section)

Add the line alias wlan0 ndiswrapper to the /etc/modprobe.conf file if needed. Create a file named ifcfg-wlan0 to the /etc/sysconfig/network-scripts directory, sample below;
Code:
TYPE=Wireless
DEVICE=wlan0
HWADDR=
BOOTPROTO=dhcp
DHCP_HOSTNAME=
IPADDR=
NETMASK=255.255.255.0
DOMAIN=
ONBOOT=no
USERCTL=yes
IPV6INIT=no
PEERDNS=yes
ESSID=
CHANNEL=
MODE=
RATE=
KEY=
When done restart the network service service network restart

Both network devices cannot be on the same subnet at the same time so one or the other has to be shutdown, this is why the ONBOOT line is set to 'no' in the example above. To try the wireless interface type something like;

ifdown eth0
ifup wlan0

Last edited by Lenard; 02-15-2008 at 10:00 PM.
 
Old 02-16-2008, 01:11 AM   #3
Lost In Here
LQ Newbie
 
Registered: Feb 2008
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for replying.

Make uninstall failed, that's why I resorted to a manual uninstall.

I already have ndiswrapper/xp driver, that's how I got the unsecured wireless working.

Turns out 2 restarts and fixing the DNS entries solved my Ethernet problems.

I still cannot get the secured network to work. iwlist shows it but I cannot connect. There is no key entry in my ifcfg-eth1 and every time I save my settings it is deleted so it must be stored somewhere else.

My software (except for vlc player) is up to date.

Any ideas why my wireless can't use secured networks?

Last edited by Lost In Here; 02-16-2008 at 01:13 AM.
 
Old 02-16-2008, 09:32 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
The keys may be in the file /etc/sysconfig/network-scripts/keys-wlan0 file. The format for 128-bit WEP is;

#This is a 128-bit HEX key;
key=1234-5678-ABCD-EF01-DDEE-78CF-21
#This is a 128-bit string key;
key=s:MyPassword123

The case is important in any case "a" does not equal "A" for example.

I should tell you that all the encryptions have been broken and it only takes a matter of a few minutes to gain access. Keeping the unauthorized wireless off the router can accomplished simply be using MAC filters on the wireless router. This will keep out 80-90% of unauthorized access by adding 64/128-bit WEP encryption will increase this to around 95-98%.
 
Old 02-16-2008, 11:48 AM   #5
Lost In Here
LQ Newbie
 
Registered: Feb 2008
Posts: 13

Original Poster
Rep: Reputation: 0
I found my key. It was in /etc/sysconfig/network-scripts/keys-eth1. (I know, I should have seen that right away)

KEY=D1C2C4D4E5

When I try other forms like

D1C2-C4D4-E5
or
D1-C2-C4-D4-E5

from the gui I get an error. If I put it directly into the file there is no error but it still won't connect.

It's 64-bit and I only use it to keep my non-tech savvy neighbors from leeching my bandwidth. I know if someone cared enough about my network they could sniff the key and my mac address.

Last edited by Lost In Here; 02-16-2008 at 11:50 AM.
 
Old 02-16-2008, 01:37 PM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Is this 64-bit key WEP? Is it HEX or plain text?? If plain text the the 's:' is required in front and please change is key on both ends. MAC address filtering only on the router works to keep most non-tech savvy people off the wireless router.

If you can get a non-encrypted connection than just use the the MAC filtering for now.
Check your /var/log/messages file for your wireless MAC ID;

Code:
Feb 11 21:09:30 Aspire5100 kernel: ndiswrapper: using IRQ 22
Feb 11 21:09:31 Aspire5100 kernel: wlan0: ethernet device 00:14:XX:XX:XX:XX using NDIS driver: bcmwl5, version: 0x364400a, NDIS version: 0x501, vendor: 'NDIS Network Adapter', 14E4:4318.5.conf
Feb 11 21:09:31 Aspire5100 kernel: wlan0: encryption modes supported: WEP; TKIP with WPA, WPA2, WPA2PSK; AES/CCMP with WPA, WPA2, WPA2PSK
 
Old 02-16-2008, 04:56 PM   #7
Lost In Here
LQ Newbie
 
Registered: Feb 2008
Posts: 13

Original Poster
Rep: Reputation: 0
It is a WEP hex key.

I should not change the security scheme because I am not the only user on the network.

Also, if I keep using linux, I will probably have to use an encrypted wireless router eventually so I would like to get it working. I have noticed that once I try to use a WEP key, my wireless won't connect at all, no matter how I change the settings, until I restart, but iwlist still shows all the available networks.

Any other ideas?

Last edited by Lost In Here; 02-16-2008 at 04:58 PM.
 
Old 02-16-2008, 06:29 PM   #8
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Nope, you just have to match up your keys at both ends of the wireless connection. The key casing is important, HEX is usually all upper case lettering while plain text (pass phrase) is usually mixed case.

It does not hurt to try the plain text method: KEY=s1C2C4D4E5
 
Old 02-16-2008, 07:30 PM   #9
Lost In Here
LQ Newbie
 
Registered: Feb 2008
Posts: 13

Original Poster
Rep: Reputation: 0
I tried every combination of it with s: and without. I tried non-capitalized and capitalized. I tried it with and without dashes and every combination of these and it still won't work.

I am sure I have the right key as I set it after I determined my card could connect to the network when it was unsecured.

This is driving me insane.

Last edited by Lost In Here; 02-22-2008 at 07:21 PM.
 
Old 02-16-2008, 09:38 PM   #10
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
OK, one last thing to try then I'm out of ideas.............

If the wireless router is set to Open or Shared try setting it to both if possible.
 
Old 02-16-2008, 10:36 PM   #11
Lost In Here
LQ Newbie
 
Registered: Feb 2008
Posts: 13

Original Poster
Rep: Reputation: 0
These wireless problems (drivers, management programs, wep ect) have been nagging me for weeks. I think this may be the last one.

Thank you Lenard, you guru of networking, I really appreciate helping me find this workaround.

(Apparently something in my system has a problem with open)
 
Old 02-16-2008, 10:42 PM   #12
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Glad to hear you got the issue resolved, you are welcome enjoy!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wifi - ethernet conflict? (2 cards) PhysicsMgr Linux - Wireless Networking 7 12-04-2006 11:09 AM
Is it possible to bridge ethernet and wifi? daishin Linux - Wireless Networking 1 10-06-2006 03:53 PM
Realtek Integrated Ethernet Broken cspos Debian 1 12-18-2005 09:44 AM
wifi vs ethernet DAChristen29 Ubuntu 9 07-28-2005 10:15 PM
fixed 3C905 broken ethernet Mandrake 10 Mugatu LinuxQuestions.org Member Success Stories 4 08-17-2004 01:15 AM


All times are GMT -5. The time now is 12:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration