LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 02-24-2013, 10:23 AM   #1
player107
LQ Newbie
 
Registered: Jan 2012
Posts: 3

Rep: Reputation: Disabled
eth0 and wlan0 vs wlan0 problem


Hello
I experience a strange thing on a linux V2.6.38 card. I installed and configured a wifi dongle wlan0 (WPA) and also connect the card via eth0.
If I ping using eth0 alone the gateway it works.
If I ping the gateway with either eth0 or wlan0 both connected it works
If I ping the gateway with wlan0 alone (from the boot) it DOESN'T work
If I ping the gate way wlan0, both connected and then I unplug wildly eth0 it also works.

How is this possible ?
Why the wlan0 doesn't work at boot and then works when eth0 is once plugged ?
In the same way, why wlan0 is then not also pingable from the outside ?

Thank you for your answers
below my interface file :

auto eth0
#iface eth0 inet dhcp
iface eth0 inet static
address 192.168.0.242
netmask 255.255.255.0
gateway 192.168.0.1
dns-nameservers 212.27.40.240 212.27.40.241

auto wlan0
iface wlan0 inet static
gateway 192.168.0.1
dns-nameservers 212.27.40.240 212.27.40.241
network 192.168.0.0
broadcast 192.168.0.255
netmask 255.255.255.0
wpa-driver wext
wpa-ssid Erium
wpa-ap-scan 1
wpa-scan-ssid 1
wpa-proto WPA RSN
wpa-pairwise TKIP CCMP
wpa-group TKIP CCMP
wpa-key-mgmt WPA-PSK
wpa-psk my.crypted.wpa-psk
 
Old 02-25-2013, 08:33 AM   #2
netnix99
Member
 
Registered: Jun 2011
Distribution: redhat, CentOS, OpenBSD
Posts: 232

Rep: Reputation: 70
It's only working with eth0 plugged in. You have wlan0 set up to static, rather than DHCP, and it does not have an IP Address assigned to it.
 
Old 02-25-2013, 08:40 AM   #3
player107
LQ Newbie
 
Registered: Jan 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
Ok thank you for your reply : your right : I forget to copy the adress but it was set.
I discovered that it works with wlan0 only when I "ifconfig eth0 down".
So it now works but I don't know why and I would like to understand.
 
Old 02-25-2013, 09:54 AM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,529

Rep: Reputation: 238Reputation: 238Reputation: 238
Probably a routing issue.

# route -n
$ netstat -r

Or some newer way of doing things I have yet to learn. You can only have one default. Or at least that's how it used to work. If you don't set the device on the route add statement it will likely default to eth0 if both exist and both eth0 and wlan0 are up.

# route add default gw 192.168.0.1 dev wlan0

Or something like that.

Last edited by Shadow_7; 02-25-2013 at 09:55 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
? how can i bridge wlan0 to eth0, Master_CAPS Linux - Newbie 1 03-24-2012 08:03 PM
No networks at all (eth0, wlan0) arsci Linux - Networking 1 09-11-2010 02:48 AM
Network problem with DNS, eth0 and wlan0 st00 Debian 1 07-25-2007 08:30 PM
Remapping wlan0 to eth0 Berhanie Linux - Networking 1 02-17-2005 07:59 AM
Broadcom wireless with ndiswrapper: ifconfig wlan0 works; ifup wlan0 fails orangechicken Linux - Wireless Networking 2 04-17-2004 05:39 PM


All times are GMT -5. The time now is 12:34 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration