LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-06-2004, 09:14 PM   #1
jarrywhu
LQ Newbie
 
Registered: Sep 2004
Location: Wuhan China
Distribution: RTL 9.0
Posts: 15

Rep: Reputation: 0
error when ifup Netgear MA111!please give some advice


I have successfully installed "linux-wlan-ng-0.2.1-pre20" into my pc,and I did everything according to the "how to".but when I ifup wlan0,it showed some errors as follows,the system seemed to recognise the adapter,but it can't connect to the internet.please help me!
[root@localhost root]# ifup wlan0
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Operation not supported.
Error for wireless request "Set ESSID" (8B1A) :
SET failed on device wlan0 ; Operation not supported.
[root@localhost root]# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2117 errors:0 dropped:0 overruns:0 frame:0
TX packets:2117 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:145281 (141.8 Kb) TX bytes:145281 (141.8 Kb)

wlan0 Link encap:Ethernet HWaddr 00:09:5B:42:5F:E3
inet addr:192.168.1.7 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:60 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

[root@localhost root]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11-DS ESSID:"RTL8180-GW" Nickname:"RTL8180-GW"
Mode:Auto Frequency:2.467GHz Access Point: 00:00:00:00:00:00
Bit Rate:2Mb/s Tx-Power:2346 dBm
Retry min limit:8 RTS thr: off Fragment thr: off
Encryption key: off
Link Quality:0/92 Signal level:-69 dBm Noise level:-90 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

and I saw in /var/log/messages,there showed a message as follows:

Oct 6 20:34:12 localhost kernel: p80211knetdev_hard_start_xmit: Tx attempt prior to association, frame dropped.

Last edited by jarrywhu; 10-06-2004 at 09:15 PM.
 
Old 10-16-2004, 06:15 AM   #2
jarrywhu
LQ Newbie
 
Registered: Sep 2004
Location: Wuhan China
Distribution: RTL 9.0
Posts: 15

Original Poster
Rep: Reputation: 0
anyone help me please?
 
Old 07-21-2005, 03:53 PM   #3
deeepfire
LQ Newbie
 
Registered: Jul 2005
Posts: 1

Rep: Reputation: 0
Unhappy

I had fedora core 3 and I am using MA111 adapter. It was happily working when I followed the method explained in http://www.uksysadmin.com/uk/content/view/13/26/

The problem is that I have now upgraded to core 4 and am in a big mess. It gives the exact same error as shown in your message. my kernel is kernel-2.6.11-1.1369_FC4 . I have checked my router and it shows that both the adapter and router are communicating but somehow I can't connect to internet. I dont know where the problem is! Any ideas or suggestions? Is it a bug?

I have gone to this mesg http://www.mepis.org/node/4632 and I think the problem got corrected in his case because he upgraded his dhcp-client. Incidently there is an upgrade for the same posted at http://download.fedora.redhat.com/pu...pdates/4/i386/

But I am yet to check that for myself because I have not installed the updates for dhcp yet.

I hope someone will provide a better explanation or solution to this weird problem!

-deeep
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
netgear MA111 sovine002007 Linux - Software 1 11-14-2005 01:53 PM
Netgear ma111 on suse 9.1 zerogood Linux - Hardware 6 02-05-2005 01:49 PM
Netgear MA111 violetb Linux - Wireless Networking 6 12-07-2004 05:50 PM
New Netgear MA111V2 - same as MA111? homelinux Linux - Wireless Networking 0 08-25-2004 08:36 PM
Netgear MA111 Vill3 Linux - Wireless Networking 0 01-09-2004 01:10 AM


All times are GMT -5. The time now is 12:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration