LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 02-13-2006, 05:45 PM   #1
metabaron
LQ Newbie
 
Registered: Feb 2006
Posts: 11

Rep: Reputation: 0
Error setting monitor mode(ipw2200-1.0.9+/kernel 2.6.14+)


Hi
I'm trying to setup wpa AND monitor mode on a 2200BG card with a compiled 2.6.14.7 or 2.6.15.4 kernel.
There is no problem when setting WPA with wpa_supplicant but i have the following error when trying monitor mode:

Code:
# iwconfig eth2 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device eth2 ; Invalid argument.
I can have both running with the linux-2.6.11-13mdk kernel package. I have also tried compiled kernels 2.6.11.12, 2.6.12.6 and 2.6.13.5 with no problem , but i'd like at least a 2.6.14 kernel.
Seems that from kernel 2.6.13 to 2.6.14, there is a new option : CONFIG_IPW2100_MONITOR that "Enables promiscuous/monitor mode support for the ipw2100 driver", but cant find the same for ipw2200 driver. Seems that there is an error in kernel configuration, as ipw2200 is not included in "Wireless LAN drivers (non-hamradio) & Wireless Extensions" where it should be ...

Any help please? Or could an1 at least confirm that it's possible to have both with a 2.6.14+ kernel so i'll keep trying. Or as it seems to be a kernel config problem, maybe I should ask there.

Hardware: Amilo M1425/2200BG
Distro: mandrake linux 10.2
kernel: 2.6.14.7 or 2.6.15.4 compiled with ipw2200/ieee80211 as modules
Drivers tested:
firmware-ipw2200-fw-2.4
ieee80211-1.1.9/ieee80211-1.1.11
ipw2200-1.0.9/ipw2200-1.0.10
wireless_tools.28.pre13
wpa_supplicant-0.4.8

[Edit]
OK, known problem, see http://seclists.org/lists/linux-kern.../Jan/1665.html
(add CONFIG_IPW2200_MONITOR=y to kernel's .config)
[Edit]

Last edited by metabaron; 02-14-2006 at 02:02 AM.
 
Old 02-17-2006, 11:30 PM   #2
-=Graz=-
Member
 
Registered: Jan 2006
Location: Australia
Distribution: Fedora, Slackware, RHEL, AIX, HP-UX
Posts: 356

Rep: Reputation: 31
Hey dude,

When upgrading to kernel 2.6.15 i encountered the same problem as you.
I have since resolved by:

Compile 2.6.15 or .14 kernel again
my 2.6.15 kernel config includes IPW2200 and IPW2100 in the .config It also includes the generic IEEE802.11 stack.
Firstly, DO NOT include the IPW2200 driver that came with your kernel when you compile. LEave it out completely. Just 'enable' wireless network support and you also include the IEEE802 stack. The driver that comes with the kernel does not seem to support rfmon properly in all enviroments - i think it has to do with installing the correct firmware for the version included

after compiling the kernel (with NO ipw2200 support)
* You may need to remove any old versions of ipw2200 first.
* Install ipw2200 driver (#make / #make install)
* Install the firmware version that suits the driver you installed.

Now try iwconfig eth1 mode monitor again.

kernel 2.6.15 (ipw2200 not used)
IPW2200-1.0.8 Driver
IPW2200-fw-2.4 Firmware version
Generic 802.11 stack (included with kernel)

FOr me this works fine in monitor..

Last edited by -=Graz=-; 02-17-2006 at 11:32 PM.
 
Old 07-08-2007, 08:18 PM   #3
mcbosher
LQ Newbie
 
Registered: Jan 2007
Posts: 2

Rep: Reputation: 0
please can you tell me how to come out of monitor mode?

I cant get my wireless to connect to anything as its still in monitor mode and i think it boots that way too...

many thanks for any help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ipw2200 monitor mode Singee15 Linux - Networking 9 08-28-2005 02:21 PM
setting up ipw2200 wireless driver in FC4 ardellin Linux - Wireless Networking 2 07-31-2005 11:36 PM
Display Mode Not Supported Error After Plugging In New Monitor Reu Linux - Hardware 6 07-22-2004 09:28 AM
Airsnort Error "could not set monitor mode" evil357 Linux - Wireless Networking 4 04-24-2004 03:21 PM
Setting Orinoco wireless card to monitor mode RogerM Linux - Wireless Networking 2 09-16-2003 09:41 AM


All times are GMT -5. The time now is 02:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration