LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 01-29-2006, 02:34 PM   #1
army180
LQ Newbie
 
Registered: Jan 2006
Posts: 4

Rep: Reputation: 0
Error for wireless request "Set Mode" on Linksys WPC11 v 3


I was wondering if anybody could help me out with this problem?
I'm using a Linksys PCMCIA card model # WPC11 V 3 in a Dell Inspiron 8200. I'm using the Auditor version 200605-02-no-ipw2100.
When I type in iwconfig in the shell-Konsole I get:

lo no wireless extensions

eth0 IEEE 802.11-DS ESSID: ..... Nickname: "Prism I"
etc:

when I type in iwconfig eth0 mode monitor I get this:

Error for wireless request "Set Mode" (8B06)
set failed on device eth0 ; Invalid argument.

Was wondering if anybody could help me out with this problem?

I tried using these command's to put it into monitor mode still dosen't work.

Please let me know what I'm doing wrong or if you need more information from me.

Prism cards, using HostAP drivers:

root@pc# iwconfig wlano mode monitor

root@pc# iwconfig wlan0 channel XX <--------insert your channel here

root@pc# ifconfig wlan0 up

[edit]=======================================
Prism cards, using wlanng drivers:

Note: Auditor has an auto script for wlanng - just do monitor.wlan wlan0 XX <-------insert channel here

Or if you want the manual method:

root@pc# wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable

root@pc# wlanctl-ng wlan0 lnxreq_wlansniff enable=true channel=XX prismheader=false wlanheader=false stripfcs=true keepwepflags=true

root@pc# ifconfig wlan0 up

Last edited by army180; 01-29-2006 at 04:22 PM.
 
Old 09-04-2006, 06:24 PM   #2
bob7
LQ Newbie
 
Registered: Aug 2005
Posts: 12

Rep: Reputation: 0
Bump. I'm having virtually the same issue. Are there no other ways to force the card into monitor mode?
 
Old 09-04-2006, 06:32 PM   #3
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
I've used the patched 0.13e and the 0.15RC2 orinoco_cs drivers with that card in monitor mode, but not the hostap drivers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error for wireless request "Set Bit Rate" (8B20) king_scott_2 Linux - Wireless Networking 3 06-26-2006 05:27 PM
Error for wireless request "Set Encode" (8B2A) for ath0 Suse 9.0 debasisdan Linux - Wireless Networking 2 04-19-2006 01:28 AM
Error starting Unreal Tourn. 2004 Demo: "Couldn't set video mode..." Baix Linux - Software 2 06-29-2004 10:23 PM
"Could not set monitor mode" in AirSnort on LinkSys WPC11 v2 WolfBLN Linux - Wireless Networking 0 04-30-2004 05:14 AM
Airsnort Error "could not set monitor mode" evil357 Linux - Wireless Networking 4 04-24-2004 03:21 PM


All times are GMT -5. The time now is 10:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration