LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Error for wireless request "Set Mode" on Linksys WPC11 v 3 (http://www.linuxquestions.org/questions/linux-wireless-networking-41/error-for-wireless-request-set-mode-on-linksys-wpc11-v-3-a-409378/)

army180 01-29-2006 02:34 PM

Error for wireless request "Set Mode" on Linksys WPC11 v 3
 
I was wondering if anybody could help me out with this problem?
I'm using a Linksys PCMCIA card model # WPC11 V 3 in a Dell Inspiron 8200. I'm using the Auditor version 200605-02-no-ipw2100.
When I type in iwconfig in the shell-Konsole I get:

lo no wireless extensions

eth0 IEEE 802.11-DS ESSID: ..... Nickname: "Prism I"
etc:

when I type in iwconfig eth0 mode monitor I get this:

Error for wireless request "Set Mode" (8B06)
set failed on device eth0 ; Invalid argument.

Was wondering if anybody could help me out with this problem?

I tried using these command's to put it into monitor mode still dosen't work.

Please let me know what I'm doing wrong or if you need more information from me.

Prism cards, using HostAP drivers:

root@pc# iwconfig wlano mode monitor

root@pc# iwconfig wlan0 channel XX <--------insert your channel here

root@pc# ifconfig wlan0 up

[edit]=======================================
Prism cards, using wlanng drivers:

Note: Auditor has an auto script for wlanng - just do monitor.wlan wlan0 XX <-------insert channel here

Or if you want the manual method:

root@pc# wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable

root@pc# wlanctl-ng wlan0 lnxreq_wlansniff enable=true channel=XX prismheader=false wlanheader=false stripfcs=true keepwepflags=true

root@pc# ifconfig wlan0 up

bob7 09-04-2006 06:24 PM

Bump. I'm having virtually the same issue. Are there no other ways to force the card into monitor mode?

2Gnu 09-04-2006 06:32 PM

I've used the patched 0.13e and the 0.15RC2 orinoco_cs drivers with that card in monitor mode, but not the hostap drivers.


All times are GMT -5. The time now is 08:14 AM.