LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-21-2011, 07:52 PM   #16
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167

Doh! I'm sorry, I was looking for the Broadcom drivers as frankbell posted when your chip is the Realtek! Double Doh! So sorry. ;-)

Okay, it looks like the chip is recognized and the modules are loaded. The card even appears to be scanning properly. Let's try associating with the AP and see what happens.

Code:
# iwconfig wlan0 essid your_network_name key your_wireless_hex_key
# dhclient wlan0
Good luck. ;-)
 
1 members found this post helpful.
Old 03-21-2011, 10:24 PM   #17
01010011
LQ Newbie
 
Registered: May 2008
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Peacedog View Post
Doh! I'm sorry, I was looking for the Broadcom drivers as frankbell posted when your chip is the Realtek! Double Doh! So sorry. ;-)

Okay, it looks like the chip is recognized and the modules are loaded. The card even appears to be scanning properly. Let's try associating with the AP and see what happens.

Code:
# iwconfig wlan0 essid your_network_name key your_wireless_hex_key
# dhclient wlan0
No worries m8.

I was not sure what to enter for "your_wireless_hex_key" so I entered my WPA Shared Key like this:

Code:
# iwconfig wlan0 essid your_network_name key My_WPA_Shared_Key
but I got the following error message:

Quote:
Error for wireless request "Set Encode" (8B2A): invalid argument "My_WPA_Shared_Key"
Where or how do I get this wireless hex key?

Edit 1

I was reading on the Man iwconfig that I have to enter the key in hex digits as XXXX-XXXX-XXXX-XXXX and that passphrase is currently not supported

Edit 2
I'm also reading in the manual that I can enter the key as an ASCII string using the s: prefix.

Edit 3

I tried using the s: prefix, like this:

Code:
# iwconfig wlan0 essid your_network_name key s:My_WPA_Shared_Key
but I got this error message:

Quote:
Error for wireless request "Set Encode" (8V2A) : SET failed on device wlan0 ; Invalid argument

Last edited by 01010011; 03-21-2011 at 11:20 PM. Reason: Please read Edit 3
 
Old 03-22-2011, 05:46 PM   #18
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
"My_WPA_Shared_Key" is intended to be the hex key generated for the pass phrase by the router you're trying to connect to. If you choose to use the actual pass phrase, you can try the s: option. If you don't know what the key or pass phrase is you should ask the router Admin for it.

Good luck. ;-)
 
1 members found this post helpful.
Old 03-22-2011, 10:08 PM   #19
01010011
LQ Newbie
 
Registered: May 2008
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Peacedog View Post
"My_WPA_Shared_Key" is intended to be the hex key generated for the pass phrase by the router you're trying to connect to. If you choose to use the actual pass phrase, you can try the s: option. If you don't know what the key or pass phrase is you should ask the router Admin for it.
I already know what the pass phrase is, and the security mode for our router is WPA, not WEP. According to the router's documentation:

Quote:
WEP:
Default Transmit Key: The key you would like to use for transmitting WEP keys.
WEP Key Bit: You may select from 64-Bit or 128-Bit encryption.
Passphrase: You may enter a passphrase consisting of any keyboard character to be used to generate a hex WEP key. Passphrase option is only supported when you are only using Linksys devices on your network.
Key 1-4: You may enter a WEP key manually. You must use only hex characters (0-9 and A-F). 64-Bit WEP requires 10 hex characters. 128-Bit WEP requires the use of 26 hex characters.
I saw no such info for hex key for WPA. If we change the security mode to WEP to get this hex WEP key, isn't that less secure than WPA? I tried the s: option like this:

Code:
# iwconfig wlan0 essid your_network_name key s:My_WPA_Shared_Key
but I got this error:

Quote:
Error for wireless request "Set Encode" (8V2A) : SET failed on device wlan0 ; Invalid argument
I'm not sure what to do
 
Old 03-23-2011, 05:41 PM   #20
01010011
LQ Newbie
 
Registered: May 2008
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Peacedog View Post
Hi 01010011, welcome to LQ. It would be an odd coincidence that the card has stopped working, but it does happen. Have you tried toggling the wifi switch?

On the Linux side, just issuing dhclient isn't likely to work unless you've already associated the card with the access point. Did you start networking? I believe Backtrack has networking turned off by default.

Code:
# /etc/init.d/networking start
To associate with an access point you can use the cli tools iwconfig or WICD from the gui.

Good luck. ;-)
Hi Peacedog, I got it to work.

After reading your reply above again I decided to try your second recommendation (WICD). Here are the steps I took:

I ran
Code:
wicd start
wicd-curses
then pressed the right arrow key for Config, and in the Configuring preferences, I ignored the first two options (Use Static IPs, Use Static DNS). I choose the third option (Use DHCP Hostname), changed the DHCP Hostname (which was "bt") and selected "Automatically connect to this network". I entered the router's passphrase (Preshared Key) and F10 to save!

Thanks man!

Last edited by 01010011; 03-23-2011 at 05:42 PM.
 
Old 03-23-2011, 07:21 PM   #21
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Glad you got it sorted.

Good luck. ;-)
 
1 members found this post helpful.
Old 04-13-2011, 12:57 PM   #22
SG86-
Member
 
Registered: Mar 2011
Posts: 40

Rep: Reputation: 2
what did you change your DHCP Hostname to??
 
1 members found this post helpful.
Old 04-13-2011, 06:37 PM   #23
01010011
LQ Newbie
 
Registered: May 2008
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by SG86- View Post
what did you change your DHCP Hostname to??
I changed it to a name I made up, like "xxx" because when I logged into the router, my computer's name was displayed as "bt". However when I changed the name to xxx, the name in the router did not change immediately, it took a few days to change, if I remember correctly. However, after it changed, the new name stayed only for a few days and changed back to "bt". I am not sure why.

Anyway, my internet connection works fine, and Im currently playing around with Metasploit with Armitage, and Ettercap on a another personal network.

Last edited by 01010011; 04-13-2011 at 06:38 PM.
 
  


Reply

Tags
backtrack4, dhclient, dhcp, wirelessnetworking


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to start DHCP server divyashree Linux - Server 5 05-25-2013 09:07 AM
Debian VM unable to get IP address from DHCP knottygal Debian 4 11-29-2010 04:21 AM
Unable to consistently get DHCP kureckam Linux - Networking 1 06-21-2009 05:49 AM
Unable to start DHCP server krytenuk1971 Linux - Networking 2 06-25-2006 03:44 PM
unable to get out of my subnet w/o dhcp wendallsan Linux - Networking 8 10-13-2003 02:52 PM


All times are GMT -5. The time now is 03:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration