LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-28-2007, 09:55 AM   #1
CharlieBucket
LQ Newbie
 
Registered: Sep 2007
Location: Oslo
Distribution: Ubuntu
Posts: 16

Rep: Reputation: 0
enable power management ipw3495 on ThinkPad T60 Ubuntu 7.10


Hi,
I have a ThinkPad T60, with Ubuntu 7.10.

The fan is running close to permanently.

It is suggested that by enabling the ipw3945 power management,
it only runs about 1/3 of the time.
(See http://www.thinkwiki.org/wiki/Instal...igured_by_hand)

I tried to enable the power management with
'iwpriv eth1 set_power 7' which seemed to have
some positive effect.(See ipw3945 README for details:
http://ipw3945.sourceforge.net/README.ipw3945)

But how should I go about to make this setting permanent
(that is automatically set when the operating system is started)?

Any help is appreciated,
regards
CB
 
Old 09-29-2007, 03:00 PM   #2
funderburg
LQ Newbie
 
Registered: Sep 2007
Posts: 6

Rep: Reputation: 0
Easiest way for ubuntu is to just put that command into /etc/rc.local and make sure it's executable.
 
Old 09-30-2007, 08:55 AM   #3
CharlieBucket
LQ Newbie
 
Registered: Sep 2007
Location: Oslo
Distribution: Ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
PROBLEM SOLVED

Thank you, your suggestion works very well.

But ideally, shouldn't this option be set when the module
is loaded?

If so, how should this be done? (Can this be done with
modprobe?)

-CB
 
Old 10-01-2007, 05:03 AM   #4
funderburg
LQ Newbie
 
Registered: Sep 2007
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by CharlieBucket View Post
PROBLEM SOLVED

Thank you, your suggestion works very well.

But ideally, shouldn't this option be set when the module
is loaded?

If so, how should this be done? (Can this be done with
modprobe?)

-CB
It *should* be a module option, but when I looked I was unable to see it. Have a look at the output of "modinfo ipw3945". If there was a module parameter to set it you'd expect it to be there.
 
  


Reply

Tags
fan, management, noise, power, t60, thinkpad, ubuntu, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware on ThinkPad T60 nsp Slackware - Installation 10 07-24-2007 09:01 AM
Installing ThinkFinger on ThinkPad T60 alkos333 Slackware 8 06-17-2007 12:07 PM
Power Management- Ubuntu RevenantSeraph Linux - General 2 03-15-2007 04:16 PM
HOWTO enable power management sibnath Fedora 1 05-01-2006 11:58 AM
Power Management- IBM Thinkpad T20 systemparadox Linux - Laptop and Netbook 7 02-16-2006 03:47 PM


All times are GMT -5. The time now is 09:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration