LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-24-2007, 03:51 PM   #1
socialcred
LQ Newbie
 
Registered: Apr 2007
Distribution: Ubuntu, Back|Track2
Posts: 3

Rep: Reputation: 0
Question Disabling automatic association w/ open WAPs on boot (Backtrack2)?


I am using backtrack2 with a hard drive installation on a dell latitude 610 laptop with the Intel wireless adapter (which loads as a pcimcia device). The wireless card (eth1) automatically connects to any open wireless access point it detects during booting. How do I disable this feature. I only want to connect to WAPs I specify... I thought changing the rc.wireless.conf file may be the solution, but have had no success...

(I would not mind connecting using only the kde tools)
Any help will be greatly appreciated!
 
Old 04-24-2007, 04:10 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
You will need to edit rc.wireless.conf and remove the ESSID="any" line for your card (it will either be using the generic configuration, or the configuration matching your card's MAC).
 
Old 04-24-2007, 05:33 PM   #3
socialcred
LQ Newbie
 
Registered: Apr 2007
Distribution: Ubuntu, Back|Track2
Posts: 3

Original Poster
Rep: Reputation: 0
Unhappy

Quote:
Originally Posted by MS3FGX
You will need to edit rc.wireless.conf and remove the ESSID="any" line for your card (it will either be using the generic configuration, or the configuration matching your card's MAC).
Thanks for your super fast response..

I removed the line, without solving the problem. Are their other configuration files that may be causing the automatic association (like the wlan.conf or wireless.opts or the various startup scripts)?

Another issue is that with iwconfig I see the connection, but cannot turn off the radio with iwconfig eth0 power off. The command runs without result...

Last edited by socialcred; 04-24-2007 at 09:42 PM.
 
Old 04-25-2007, 01:35 AM   #4
socialcred
LQ Newbie
 
Registered: Apr 2007
Distribution: Ubuntu, Back|Track2
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by socialcred
Thanks for your super fast response..

I removed the line, without solving the problem. Are their other configuration files that may be causing the automatic association (like the wlan.conf or wireless.opts or the various startup scripts)?

Another issue is that with iwconfig I see the connection, but cannot turn off the radio with iwconfig eth0 power off. The command runs without result...

Could the problem be the setup of the /etc/pcmcia/wireless.opts and /etc/pcmcia/wireless script or the /etc/pcmcia/network script? They both seem to be setup to associate with any ssid...
 
  


Reply

Tags
automatic, backtrack2, essid, wirelessnetworking, wlan


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Open source association challenges fines against DRM circumvention LXer Syndicated Linux News 0 03-21-2007 08:16 AM
dd never returns in BackTrack2 manolakis Linux - Newbie 17 03-01-2007 07:53 AM
BackTrack2 Ecstasy Linux - Software 0 11-14-2006 06:12 AM
Open Office File Association quo_vadis Linux - Newbie 1 04-20-2004 08:39 AM
Utilizing multiple WAPs ferreter Linux - Laptop and Netbook 4 03-06-2004 03:07 PM


All times are GMT -5. The time now is 01:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration