LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-11-2004, 08:11 PM   #1
danraider
Member
 
Registered: Feb 2004
Distribution: Slackware 12 - dropline Gnome
Posts: 43

Rep: Reputation: 15
dhcpcd, ra0: no IPv6 routers present


Hi
I'm trying to connect to the university network with my wireless, the dhcp server here is giving me some problems. getting ip and everything for the ethernet adapter is no probs, only the wireless is messing...

if I do a
>dhcpcd ra0
nothing happens, and in dmesg I gat a "ra0: no IPv6 routers present"

'modprobe -c | grep eth' (or ra or anything else) won't actually give me anything which I know might be a problem... it however dows load the modules on boot, and in my rc.local I've got a 'ifconfig i-face up' which fixes the ethernet and will start up the wireless to the point where I'm connected to the wireless AP but I don't get an ip or route or anything...

I have tried the more obvious ones such as adding a route manually
>route add -host 225.225.225.225 dev ra0
it accepts the route but it won't help...

if I would just give it a static ip it will connect to the internet properly no probs but I will have the admin here chase me down with a blowtorch...

Question really is I suppose, how can I ask for a normal ip instead if this ipv6?

If anyone have any clues, please!

Cheers - Dan

................................
So, the inevitable question, what am I running???
IBM ThinkPad R40, Slackware 9.1 kernel 2.6.2
eth0: broadcom bcm5700
ra0 : minitar wireless card, with their own linux driver
 
Old 03-17-2005, 01:41 PM   #2
cbfraser
LQ Newbie
 
Registered: Mar 2005
Posts: 1

Rep: Reputation: 0
My solution for this problem has been to simply disable ipv6 within my kernel. There are probably more elegant than ways to do it than simply disabling it in <tt>make menuconfig</tt>, for example by making the ipv6.ko module and ensuring it is never loaded. Probably the router doesn't know ipv6 and the wireless setup is not degrading gracefully to ipv4 only networking.

Hope this helps someone,
 
Old 09-08-2006, 02:53 PM   #3
wadechandler
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
Thumbs up

I am replying even though this question was asked before in hopes this will help someone else in the future.

The trick is to get ip to be using the -4 parameter or -family inet. ifup should be using ip under the scenes, so do a man ip to find out more information. I found this the hard way by digging into the guts of it all as I could find no great solution. I can now have IP6 ethernet connections and force the wireless card to use only IP4, and I do not have to uninstall IP6 or disable it. In SuSE this is accomplished by first setting up the device in Yast. Then go to /etc/sysconfig/network and locate your devices ifcfg file. In the file add this line (or append to it if it is already there):
IP_OPTIONS=' -4 '
or
IP_OPTIONS=' -family inet '

Anyways, I hope this helps someone else having this same issue. I am also using a broadcom card with the NDIS driver.

Wade

Last edited by wadechandler; 09-08-2006 at 02:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no IPv6 routers present (IPW2200 1.0.h6) viniosity Linux - Laptop and Netbook 2 09-18-2005 05:36 PM
"No IPV6 routers present" Oholiab Linux - Wireless Networking 8 04-08-2005 03:45 PM
IPv4 IPv6 And routers cranium2004 Linux - Networking 2 02-02-2005 10:12 AM
no IPv6 routers present lynrees Debian 0 05-13-2004 04:18 AM
No IPv6 routers present - SuSE 8.2 valkraider Linux - Laptop and Netbook 1 09-20-2003 04:44 PM


All times are GMT -5. The time now is 02:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration