LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 03-24-2007, 12:53 AM   #1
chz013
LQ Newbie
 
Registered: Mar 2007
Posts: 12

Rep: Reputation: 0
Unhappy DESPERATE - ipw2200 doesnt work!!!


Hi

I downloaded ipw2200-1.2.0, ieee80211-1.2.16
and stored them in /home/root and followed instructions from those sourceforge websites and they just don't work.

[root@einstein src]# uname -a
Linux einstein 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:54:20 EDT 2006 i686 i686 i386 GNU/Linux

part 1 issue -
I did

[root@einstein ipw2200-1.2.0]# ls
CHANGES dvals idvals ipw2200.h load restart verify_wifi_hw
compat.c FILES INSTALL ipwstats.c Makefile status
compat.h filters in-tree ISSUES README.ipw2200 tmp
config GIT_SHA1 ipw2200.c LICENSE remove-old unload
[root@einstein ipw2200-1.2.0]# make

ERROR: ieee80211.h not found in '/lib/modules/2.6.18-1.2798.fc6/include'.

You need to install the ieee80211 subsystem from http://ieee80211.sf.net
and point this build to the location where you installed those sources, eg.:

% make IEEE80211_INC=/usr/src/ieee80211/

will look for ieee80211.h in /usr/src/ieee80211/net/

make: *** [check_inc] Error 1



so I downloaded ieee80211-1.2.16

In ieee80211-1.2.16 subdir
I typed
[root@einstein ieee80211-1.2.16]# ls
CHANGES ieee80211_crypt_ccmp.c ieee80211_rx.c LICENSE
compat.h ieee80211_crypt_tkip.c ieee80211_tx.c Makefile
GIT_SHA1 ieee80211_crypt_wep.c ieee80211_wx.c net
idvals ieee80211_geo.c INSTALL remove-old
ieee80211_crypt.c ieee80211_module.c in-tree
[root@einstein ieee80211-1.2.16]# make
Checking in /lib/modules/2.6.18-1.2798.fc6 for ieee80211 components...
find: /lib/modules/2.6.18-1.2798.fc6/build/: No such file or directory
egrep: /lib/modules/2.6.18-1.2798.fc6/build//.config: No such file or directory
egrep: /lib/modules/2.6.18-1.2798.fc6/build//include/linux/autoconf.h: No such file or directory
find: /lib/modules/2.6.18-1.2798.fc6/build/: No such file or directory
make -C /lib/modules/2.6.18-1.2798.fc6/build M=/home/root/ieee80211-1.2.16 modules
make: *** /lib/modules/2.6.18-1.2798.fc6/build: No such file or directory. Stop.
make: *** [modules] Error 2
[root@einstein ieee80211-1.2.16]#


So I changed to another dir

[root@einstein 2.6.18-1.2798.fc6]# pwd
/lib/modules/2.6.18-1.2798.fc6
[root@einstein 2.6.18-1.2798.fc6]# ls -lrt
total 1248
drwxr-xr-x 2 root root 4096 Oct 16 14:45 weak-updates
drwxr-xr-x 2 root root 4096 Oct 16 14:45 updates
drwxr-xr-x 2 root root 4096 Oct 16 14:45 extra
lrwxrwxrwx 1 root root 47 Mar 23 16:23 build -> ../../../usr/src/kernels/2.6.18-1.2798.fc6-i586
drwxr-xr-x 9 root root 4096 Mar 23 16:23 kernel
lrwxrwxrwx 1 root root 5 Mar 23 16:23 source -> build
-rw-r--r-- 1 root root 303364 Mar 23 16:23 modules.usbmap
-rw-r--r-- 1 root root 109160 Mar 23 16:23 modules.symbols
-rw-r--r-- 1 root root 841 Mar 23 16:23 modules.seriomap
-rw-r--r-- 1 root root 193383 Mar 23 16:23 modules.pcimap
-rw-r--r-- 1 root root 74 Mar 23 16:23 modules.ofmap
-rw-r--r-- 1 root root 12159 Mar 23 16:23 modules.isapnpmap
-rw-r--r-- 1 root root 375 Mar 23 16:23 modules.inputmap
-rw-r--r-- 1 root root 813 Mar 23 16:23 modules.ieee1394map
-rw-r--r-- 1 root root 263352 Mar 23 16:23 modules.dep
-rw-r--r-- 1 root root 69 Mar 23 16:23 modules.ccwmap
-rw-r--r-- 1 root root 255105 Mar 23 16:23 modules.alias
[root@einstein 2.6.18-1.2798.fc6]#




[root@einstein redhat]# which ndiswrapper
/usr/bin/which: no ndiswrapper in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin)




I'm a newbie. I appreciate any help from anyone here
to get this to work.

Thank you
 
Old 03-24-2007, 07:34 AM   #2
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Why don't you try the driver already included in fedora?
And put the firmwares on the right place?
 
Old 03-24-2007, 08:41 AM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I'm going to make a suggestion you may not like, but I think it will be worthwhile in the end. You need to do a reinstall of Fedora. nx5000 is right, Fedora comes with the ipw2200 driver and all you need to install is the firmware. However, by messing with the ieee80211 stuff, you've probably borked your ability to get wireless to function. This isn't your fault, the instructions on the ipw2200 site are out of date and DESPERATELY need to be changed. They are from a time when the ieee80211 system in the kernel wasn't up to the task, but it is now so you don't need to worry about it.
 
Old 03-24-2007, 08:49 AM   #4
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Code:
# make
You see this little #

Just because you compiled as root, you probably have fuxored your working fedora.
A normal user wouldn't have made any mess, because he has not the right to.

Compilation is supposed to be done in two steps:
$make
#make install <-- this one moves the file out of the compilation directory to your fedora system directories.

These 2 steps are here only for the reason of rights management. Do it like this.

Simple check for the fedora core shipped driver (I guess? you have already made it)
Code:
#modprobe ipw2200
#tail /var/log/messages
Depending on the result, it can be quicker to reinstall the kernel or wait the next one from fedora...


edit:
Hangdog42, do you have any recent links (less than 1 year) on kernel dev or whatever showing the progress of wireless in Linux? I asked in General in the hope that you would see it but no

Last edited by nx5000; 03-24-2007 at 08:51 AM.
 
Old 03-24-2007, 08:59 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
This also is maybe not what you wanted to hear....

There are already quite a few threads on the 2200, and it is a bit hard to find definitive answers---my reading supports the conclusion that the instructions are sorely lacking.

For what it's worth, I tried several things before discovering that Ubuntu 6.10 worked out of the box--absolutely no issues. On my to do list--figure what they did differently.

There is hope.....
 
Old 03-24-2007, 09:01 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Hangdog42, do you have any recent links (less than 1 year) on kernel dev or whatever showing the progress of wireless in Linux? I asked in General in the hope that you would see it but no
Sorry, I must have missed that thread. I'm usually up for pontificating on the state of wireless in Linux....

The only thing I've seen recently is this article (which I saw in the LXer feed) that suggests the kernel will move to the Devicescape stack in the 2.6.22 release. I've seen other places that the Devicescape stack is supposed to make life a lot easier, and when combined with the offer by the kernel team to write drivers, might kick off a lot of progress. I've got my fingers crossed, but I'm also kind of skeptical. This is wireless in Linux after all.
 
Old 03-24-2007, 09:26 AM   #7
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Quote:
Originally Posted by Hangdog42
Sorry, I must have missed that thread. I'm usually up for pontificating on the state of wireless in Linux....

The only thing I've seen recently is this article (which I saw in the LXer feed) that suggests the kernel will move to the Devicescape stack in the 2.6.22 release. I've seen other places that the Devicescape stack is supposed to make life a lot easier, and when combined with the offer by the kernel team to write drivers, might kick off a lot of progress.
Thanks!

Quote:
I've got my fingers crossed, but I'm also kind of skeptical. This is wireless in Linux after all.
-1
Quote:
Originally Posted by pixellany
There is hope.....
+1


A few things here:
http://www.google.com/search?q=wirel...er+devicescape

but nothing here:
http://lxr.linux.no/source/Documenta...l-schedule.txt
..

Last edited by nx5000; 03-24-2007 at 09:29 AM.
 
Old 03-24-2007, 09:31 AM   #8
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Quote:
Originally Posted by nx5000
Code:
# make
You see this little #

Just because you compiled as root, you probably have fuxored your working fedora.
A normal user wouldn't have made any mess, because he has not the right to.

Compilation is supposed to be done in two steps:
$make
#make install <-- this one moves the file out of the compilation directory to your fedora system directories.
What?!

While it's generally considered to be best practice to only assume root permissions when absolutely needed such as installing the binaries, compiling code root will cause no issues. The only way any of this would have caused a problem is if an incompatible package was installed. Looking at the output, I didn't see that anything was successfully compiled, let alone installed.

To the OP,

Your errors indicate missing packages needed for compiling - either source or headers. Stick with pre-compiled RPMs if you can. Not only is it a more convenient method, it make the uninstall process easier should something go wrong.

Otherwise, you got the right answer - the driver is included in your distribution. Find the firmware needed on the ipw2200 driver site and copy it (as root) to the directory specified in the instructions. Modprobe the driver and you should be off & running.
 
Old 03-24-2007, 09:37 AM   #9
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 53
Code:
compiling code root will cause no issues.
I agree in theory that with a known package that has been heavily tested there shouldn't be a problem.
But security doesn't rely on assumptions.
The least you do as root, the better. We are talking of a makefile here and in a makefile, there is not only compilation, there can be any command! You need root only for installing so there is no need to compile as root. It's up to you to check the install rule in the makefile. I generally do this:
$make
Simulate install:
#make -n install
Do it:
#make install

But everybody has the choice! I just do it safely... YMMV
 
Old 03-24-2007, 01:53 PM   #10
chz013
LQ Newbie
 
Registered: Mar 2007
Posts: 12

Original Poster
Rep: Reputation: 0
Hi folks
I took your advice and reload Fedora Core 6 from scratch.
I then downloaded what I believe to be ipw2200 firmware from the internet.

[root@localhost ipw2200-fw-3.0]# ls -lrt
total 596
-rw-r--r-- 1 1000 users 12007 Mar 7 2006 LICENSE.ipw2200-fw
-rw-r--r-- 1 1000 users 187836 Mar 7 2006 ipw2200-sniffer.fw
-rw-r--r-- 1 1000 users 185660 Mar 7 2006 ipw2200-ibss.fw
-rw-r--r-- 1 1000 users 191142 Mar 7 2006 ipw2200-bss.fw
[root@localhost ipw2200-fw-3.0]# pwd
/root/ipw2200-fw-3.0
[root@localhost ipw2200-fw-3.0]#
[root@localhost ipw2200-fw-3.0]# modprobe ipw2200
[root@localhost ipw2200-fw-3.0]# tail /var/log/messages
Mar 24 12:42:11 localhost kernel: ide: failed opcode was: unknown
Mar 24 12:42:11 localhost kernel: ATAPI device hdc:
Mar 24 12:42:11 localhost kernel: Error: Illegal request -- (Sense key=0x05)
Mar 24 12:42:11 localhost kernel: Illegal mode for this track or incompatible medium -- (asc=0x64, ascq=0x00)
Mar 24 12:42:11 localhost kernel: The failed "Read 10" packet command was:
Mar 24 12:42:11 localhost kernel: "28 00 00 00 f6 cc 00 00 02 00 00 00 00 00 00 00 "
Mar 24 12:42:11 localhost kernel: end_request: I/O error, dev hdc, sector 252720
Mar 24 12:42:11 localhost kernel: Buffer I/O error on device hdc, logical block 31590
Mar 24 12:42:57 localhost kernel: SELinux: initialized (dev hdc, type iso9660), uses genfs_contexts
Mar 24 12:42:57 localhost hald: mounted /dev/hdc on behalf of uid 0
[root@localhost ipw2200-fw-3.0]#

What do I do next to get this to work ?
I need some hand-holding. Help me.

Update -
The Add/Remove Program icon now works.
I believe the ipw2200 firmware rpm is installed.
When I try to activate it as eth1 using Network Configuration GUI, it complains with error

Can't activate network device eth1!
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth1 ; No such device.

Determining IP information for eth1... failed.


What did I do wrong now ?

Last edited by chz013; 03-24-2007 at 02:24 PM.
 
Old 03-24-2007, 04:29 PM   #11
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Downloading the firmware isn't enough. You have to put it in the right spot. I'm sure the instructions for the driver tell you where that is for Fedora.
 
Old 03-27-2007, 03:43 PM   #12
herbietheferret
Member
 
Registered: Feb 2007
Location: Cambridge, UK
Distribution: Slackware
Posts: 42

Rep: Reputation: 15
unpack the firmware in /lib/firmware. it may put a directory in there, what i do is copy the files in there and then paste them into the actual /firmware directory.
reboot and see if it picks up eth1.
mark
 
  


Reply

Tags
ipw2200


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IPW2200 in Debian doesnt even load Fice Linux - Networking 2 06-09-2006 01:20 AM
Why doesnt my USB mouse doesnt work? barkha Linux - Hardware 2 08-16-2005 12:31 PM
ipw2200 losing connection all the time (urgently desperate) Nightfrost Linux - Wireless Networking 14 05-17-2005 05:16 AM
IPW2200 on any Linux doesn't work? GerbilSoft Linux - Wireless Networking 4 01-16-2005 06:49 PM
Problem: red hat 9 server doesnt turn on anymore.. Im desperate!! carolPrt Linux - General 1 04-22-2004 03:40 PM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration