LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2012, 11:48 AM   #1
t0n1
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Rep: Reputation: 0
Debian testing, RT5390 / RT2800PCI


Hi guys,

after a long time, only reading here, I now have my first problem to tell you.

I've got a HP notebook with wireless chip RT5390 in it. It should be runing with the rt2800pci module.
Now I am at this status: The driver and the chip is available, i get an ipv6-address but NO "normal" ipv4 address.
a "ping [anysite]" brings me "unknown host".
I don't know why...
Tested with an ubuntu live-cd it works out of the box perfectly.

Can anybody help me please?

Best regards
Toni
 
Old 04-28-2012, 05:02 AM   #2
descendant_command
Member
 
Registered: Mar 2012
Posts: 761

Rep: Reputation: 159Reputation: 159
Installed the non-free firmware?
http://wiki.debian.org/rt2800pci

Last edited by descendant_command; 04-28-2012 at 05:03 AM.
 
Old 04-28-2012, 05:37 AM   #3
t0n1
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Yes, it's installed.
Perhaps important infos: It's a 32-bit system, kernel-version is 3.2.0.

I don't know what I'm doing wrong...
 
Old 04-28-2012, 05:51 AM   #4
descendant_command
Member
 
Registered: Mar 2012
Posts: 761

Rep: Reputation: 159Reputation: 159
Quote:
Originally Posted by t0n1 View Post
i get an ipv6-address but NO "normal" ipv4 address.
a "ping [anysite]" brings me "unknown host".
I don't know why...
Are you using DHCP?
A connection manager?
See this - http://wiki.debian.org/WiFi/HowToUse
 
Old 04-28-2012, 05:54 AM   #5
t0n1
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
I use dhcp, no manager, just /etc/network/interfaces and wpa_supplicant.
The settings are the same as in my other laptop, from which I'm writing at this moment. The settings has to be right...

interfaces
Code:
auto lo
iface lo inet loopback
iface eth0 inet dhcp

pre-up ifconfig wlan0 up
pre-up ifconfig wlan0 down

iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface berlin inet dhcp
iface nb inet dhcp
iface mandy inet dhcp

auto wlan0
wpa_supplicant
Code:
ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
ap_scan=1


network={
        ssid="FOCUS"
	id_str="berlin"
	scan_ssid=1
#	proto=RSN
#	key_mgmt=WPA-PSK
#	pairwise=CCMP
#	group=CCMP
        psk="???"
	}


network={
        ssid="WWLAN"
	id_str="nb"
	scan_ssid=1
#	proto=RSN
#	key_mgmt=WPA-PSK
#	pairwise=TKIP CCMP
#	group=TKIP
        psk="???"
	}

network={
        ssid="wlan-123"
	id_str="mandy"
	scan_ssid=1
#	proto=RSN
#	key_mgmt=WPA-PSK
#	pairwise=TKIP CCMP
#	group=TKIP
        psk="???"
	}

Last edited by t0n1; 04-28-2012 at 05:58 AM.
 
Old 04-28-2012, 05:07 PM   #6
descendant_command
Member
 
Registered: Mar 2012
Posts: 761

Rep: Reputation: 159Reputation: 159
Quote:
Code:
iface wlan0 inet manual
No dhcp & no interface setting details?
 
Old 04-28-2012, 05:40 PM   #7
t0n1
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Hm, I don't know, it works on my other laptop in this exact setting. I only copied both files.
I wrote that files a long time ago and they just worked. So I thought, they should work on the other pc as well...

edit: wait a second... dhcp settings are in the file:
Code:
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface berlin inet dhcp

Last edited by t0n1; 04-28-2012 at 05:42 PM.
 
Old 04-28-2012, 06:01 PM   #8
descendant_command
Member
 
Registered: Mar 2012
Posts: 761

Rep: Reputation: 159Reputation: 159
Yes, but you have 'auto wlan0' which brings up the 'wlan0' interface, not the 'berlin' interface.
 
Old 04-28-2012, 06:03 PM   #9
t0n1
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
berlin is a network mentioned in wpa_supplicant.
I wonder, why its named "iface", as wlan0 does...

But why does this setting work on the other pcs?
Really, it works fine on two laptops since years...

Thank you for your help
 
Old 04-28-2012, 06:19 PM   #10
descendant_command
Member
 
Registered: Mar 2012
Posts: 761

Rep: Reputation: 159Reputation: 159
I would try simply changing 'manual' to 'dhcp' in the 'iface wlan0' line.

And if you are not using the other interfaces, you could remove them to avoid further confusion.
 
Old 04-28-2012, 06:24 PM   #11
t0n1
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Hah, it works!
Thank you VERY much, made my day
 
Old 04-28-2012, 06:37 PM   #12
descendant_command
Member
 
Registered: Mar 2012
Posts: 761

Rep: Reputation: 159Reputation: 159
No problem.

Also this:
Code:
pre-up ifconfig wlan0 up
pre-up ifconfig wlan0 down
seems redundant.

I assumed you had built those files for your specific needs, but seems not...
 
Old 04-28-2012, 06:48 PM   #13
t0n1
LQ Newbie
 
Registered: Sep 2008
Posts: 7

Original Poster
Rep: Reputation: 0
I copied them from.. wherever How I said, it's a while ago...
But they worked for me until now... But thanks for your advise, I will change it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
backtrack5 R1 VM and Ralink RT5390 bmike1 Linux - Wireless Networking 3 01-08-2012 10:39 PM
[SOLVED] [Ubuntu 10.04/Ralink RT5390] How to install? littlebigman Linux - Laptop and Netbook 9 05-29-2011 03:41 AM
LXer: Kernel Log: New stable kernels, 2.6.33 with DRBD and RT2800PCI LXer Syndicated Linux News 0 12-12-2009 05:50 AM
debian testing vs debian stable with testing repositories? wanas Debian 5 02-28-2009 10:23 PM
Setup as getting debian testing files from ftp - will it stay with testing BrianHenderson Debian 2 09-02-2004 06:06 PM


All times are GMT -5. The time now is 03:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration