LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 08-04-2008, 12:36 AM   #1
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Rep: Reputation: 30
Debian Lenny AMD64 Intel IWL4965 WiFi


Hello. Today I installed the 64 bit version of Debian Lenny. Note that the problem I have does not occur on the 32 bit version.

I installed firmware-iwlwifi from apt-get and did modprobe iwl4965. This worked on i386. However, I cannot connect to my router now unless i suspend the computer and then resume it, at which point the wifi card magically turns on. Fn+F2 does not turn it on/off as it should.

The problem does not end there. I can browse the web, but local IPs do not load. I cannot ping the router itself at 192.168.0.1, but I can ping Google's IP and DNS name.

Dmesg yields the following after the suspend/resume/connect process has occurred:

Code:
[   46.488179] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   47.224722] wlan0: Initial auth_alg=0
[   47.224729] wlan0: authenticate with AP 00:1e:58:00:0f:92
[   47.227368] wlan0: Initial auth_alg=0
[   47.227372] wlan0: authenticate with AP 00:1e:58:00:0f:92
[   47.227384] wlan0: RX authentication from 00:1e:58:00:0f:92 (alg=0 transaction=2 status=0)
[   47.227386] wlan0: authenticated
[   47.227389] wlan0: associate with AP 00:1e:58:00:0f:92
[   47.227401] wlan0: authentication frame received from 00:1e:58:00:0f:92, but not in authenticate state - ignored
[   47.228346] wlan0: authentication frame received from 00:1e:58:00:0f:92, but not in authenticate state - ignored
[   47.229910] wlan0: RX AssocResp from 00:1e:58:00:0f:92 (capab=0x431 status=0 aid=1)
[   47.229915] wlan0: associated
[   47.229920] wlan0: switched to short barker preamble (BSSID=00:1e:58:00:0f:92)
[   47.229960] wlan0 (WE) : Wireless Event too big (320)
[   47.229980] wlan0: WMM queue=2 aci=0 acm=0 aifs=3 cWmin=15 cWmax=63 burst=0
[   47.229985] wlan0: WMM queue=3 aci=1 acm=0 aifs=7 cWmin=15 cWmax=1023 burst=0
[   47.229989] wlan0: WMM queue=1 aci=2 acm=0 aifs=1 cWmin=7 cWmax=15 burst=30
[   47.229992] wlan0: WMM queue=0 aci=3 acm=0 aifs=1 cWmin=3 cWmax=7 burst=15
[   47.230376] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   51.235291] wlan0: no IPv6 routers present
iwconfig:
Code:
iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"Lanz"
          Mode:Managed  Frequency:2.442 GHz  Access Point: 00:1E:58:00:0F:92
          Bit Rate=48 Mb/s   Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:7175-616B-65
          Link Quality=100/100  Signal level=-35 dBm  Noise level=-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
ifconfig -a:
Code:
eth0      Link encap:Ethernet  HWaddr 00:1b:fc:b3:0c:6c
          inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:203 errors:0 dropped:0 overruns:0 frame:0
          TX packets:203 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:14103 (13.7 KiB)  TX bytes:14103 (13.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:13:e8:29:cc:f3
          inet addr:192.168.0.146  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::213:e8ff:fe29:ccf3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1568 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1923 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:755325 (737.6 KiB)  TX bytes:308566 (301.3 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-13-E8-29-CC-F3-00-00-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
lspci -nn relevant line:
Code:
05:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection [8086:4229] (rev 61)
And echo "0" > /sys/bus/pci/drivers/iwl4965/*/rf_kill kills the active (albeit screwed up) wifi connection.

Please help.
 
Old 08-04-2008, 09:49 AM   #2
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
Okay, so I set the router to have no WEP security. Now I am able to ping local address (192.168.0.1 - router). However, I still have to press Fn+F1 (put it to sleep) and wake it up in order for the wireless to turn on. Please help.
 
Old 08-04-2008, 11:33 AM   #3
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
The problem seems to be this:
Code:
iwl4965: Radio disabled by HW RF Kill switch
Anyone know how to make the radio work? The function key to turn it on just doesn't respond at all. I have to suspend/resume to get rid of the kill switch error.
 
Old 08-05-2008, 10:38 AM   #4
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
I am not making any progress, please give me a hand.
 
Old 08-06-2008, 07:48 PM   #5
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
I upgraded to kernel 2.6.26 today and the problem persists. Someone must know something?
 
Old 08-12-2008, 02:12 PM   #6
WolfCub
Member
 
Registered: Nov 2003
Location: Canada
Distribution: Debian
Posts: 175

Original Poster
Rep: Reputation: 30
The problem magically fixed itself, I did nothing. Thanks for all the help.
 
Old 01-29-2009, 01:03 AM   #7
jnorvell
LQ Newbie
 
Registered: Jul 2005
Location: Claremont, CA
Distribution: Gentoo
Posts: 9

Rep: Reputation: 0
not magic...

There's a little slider switch on the front of the laptop that turn wifi off and on (the HW RF kill switch). Accidentally turning this off has caused me a little bit of useless troubleshooting time as well.

Sorry nobody tried to help you in a timely way!
 
Old 02-13-2009, 03:21 PM   #8
BlackNinjaVirus
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0
Code:
iwl4965: Radio disabled by HW RF Kill switch
I am having the same issue.

Debian Lenny AMD64
Lenovo Y710
 
Old 02-24-2009, 06:59 PM   #9
crowds
LQ Newbie
 
Registered: Oct 2008
Posts: 1

Rep: Reputation: 0
Not sure if this is the case for you, but I was having this problem because I didn't realize I had a sliding button underneath my computer that turns the wireless on and off.
 
Old 02-25-2009, 07:03 AM   #10
BlackNinjaVirus
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0
No, the sliding switch is O.K.
However, on the i386 version, I can load BIOS defaults and install Lenny, and the wireless works.

The wireless works on Debian 4.0r3, in which I still had the DVD and I remember it working when I first bought the Lenovo Y710. The only problem back then (around October/November 2008) was the video ATI HD2600. There had been horizontal static because I believe that it could not place the pixels on the wide screen correctly.

However, the wireless was fine in all distros, Ubuntu 8.04.0, and Debian 4.0r3 which tells me that when the kernel changed - it somehow disconnected/broke the wireless firmware.

*** Works with AMD64 now, after BIOS defaults. ***
I think this is due to the fact that Linux is not a Plug & Play OS, so it reads the BIOS info directly to load devices.
If BIOS is not fresh, the install will be stale.

Last edited by BlackNinjaVirus; 03-02-2009 at 08:53 AM. Reason: Updated arch test.
 
  


Reply

Tags
amd64, debian, lenny, lenovo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 945GM Lag issues on Debian Lenny Rehumanize Linux - Hardware 4 08-23-2008 04:47 PM
Debian Lenny AMD64 netinstall not detecting ethernet correctly the trooper Debian 6 07-28-2008 01:13 PM
Installing 32bit programs on amd64 (lenny) war1025 Debian 2 03-29-2008 02:28 PM
debian amd64 etch and Intel EFI kpachopoulos Debian 1 09-28-2007 09:11 AM
lenny +ipw3945 +amd64 not working cybrjackle Debian 5 08-05-2007 09:36 AM


All times are GMT -5. The time now is 08:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration