LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 08-25-2007, 04:34 AM   #1
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Rep: Reputation: 15
Question Configure Wifi On Dell Inspiron 6000


hello, i've just installed Red Had Enterprise on me lappy.
I have spent all last night to try and configure a wifi connection.

Cant seem to get it going

me net card: Intel Pro Wireless 2200 BG
OS: red hat enterprise.

When I go in Net Configuration,
I can see the wifi card installed as eth1

However when I select new connection and select wireless conn, as i go further when it says select ethernet adapter, i cant find me net adapter in that list.

Just can't go any further!
SOS, pls can someone help me to sort this out.
 
Old 08-25-2007, 05:22 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Well you need the firmware files installed for the wireless device download and install from:

http://dag.wieers.com/rpm/packages/ipw2200-firmware/

rpm -ivh ipw2200-firmware-3.0-3.nodist.rf.noarch.rpm

Then one can check (and maybe add) a line entry in the /etc/modprobe.conf file (RHEL 4/5) for the wireless device, which read something like; alias eth1 ipw2200

Check or create a file named ifcfg-eth1 in the /etc/sysconfig/network-scripts which reads something like;

TYPE=Wireless
DEVICE=eth1
HWADDR=
BOOTPROTO=dhcp
DOMAIN=
ONBOOT=yes
ONHOTPLUG=no
USERCTL=yes
IPV6INIT=no
PEERDNS=no
IPADDR=
GATEWAY=
NETMASK=255.255.255.0
ESSID=
CHANNEL=
MODE=
RATE=

Check if the module is loaded; cat /proc/modules | grep ipw

If all looks OK then restart the laptop.
 
Old 08-25-2007, 05:34 AM   #3
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
Thumbs down Comes up with the following error

I've done exactly what you asked me to do.

When I try to activate me Wireless device it comes up with the following message.
=========================================================================
Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device eth1 ; Operation not supported.

Determining IP information for eth1... failed; no link present. Check cable?
=========================================================================


also for more infom me 'ifcfg-eth1' file looks like this...
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
IPV6INIT=no
ONBOOT=yes
USERCTL=yes
PEERDNS=yes
ONHOTPLUG=no
GATEWAY=
TYPE=Wireless
DEVICE=eth1
HWADDR=
BOOTPROTO=dhcp
NETMASK=255.255.255.0
DHCP_HOSTNAME=
IPADDR=
DOMAIN=
ESSID=£ucifer
CHANNEL=11
MODE=Managed
RATE=Auto


AND

cat /proc/modules Comes up with the following for ipw

ipw2200 67277 0 - Live 0xe00d7000


No clue, where to go from here!?

Last edited by bigjig; 08-25-2007 at 07:53 AM. Reason: updating info
 
Old 08-25-2007, 08:11 AM   #4
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
?

any clues guys?
 
Old 08-25-2007, 12:46 PM   #5
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Compare your /etc/sysconfig/network-scripts/ifcfg-eth1 to your wireless routers configuration and to the example one I posted.

You might want to add the internal IP address of the router to the GATEWAY line entry, you do want to edit three of the last four lines to be like the posted example ifcfg-eth1 file (this is basically what I have in my wireless config file BTW);

$ cat /etc/sysconfig/network-scripts/ifcfg-wlan0
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Wireless
DEVICE=wlan0
HWADDR=
BOOTPROTO=none
IPADDR=192.168.1.12
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
DOMAIN=
ONBOOT=yes
ONHOTPLUG=no
USERCTL=yes
IPV6INIT=no
PEERDNS=no
ESSID=
CHANNEL=3
MODE=
RATE=

I do use a static IP address instead of an assigned dhcp address is the only real difference.
 
Old 08-26-2007, 02:53 AM   #6
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
You are genius mate, cheers. This time it did not flash up any errors when I tried to activate it.
In fact, in the Net Configuration window, the eth1 device is showing as 'active'

Me ifcfg-eth1 file looks like this:

[root@localhost network-scripts]# cat ifcfg-eth1
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Wireless
DEVICE=eth1
HWADDR=00:13:ce:24:87:1c
BOOTPROTO=none
IPADDR=192.168.1.10
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
DOMAIN=
ONBOOT=yes
ONHOTPLUG=no
USERCTL=yes
IPV6INIT=no
PEERDNS=no
ESSID=£ucifer
CHANNEL=11
MODE=
RATE=

However when I go to me browser, it won't take me to the webpage.
www.bbc.co.uk cannot be found, Please check the name and try again.

I tried going to http://192.168.1.1, it says The connection was refused when attempting to contact 192.168.1.1
Now me router is on a MAC filter on, but it should'nt matter, only thing i can think is the WEP key, its in HEX, 128bit....and I've entered that in Wireless Settings tab in Network config.

Also the wifi LED on the laptop wonr come on, am not sure if that means anything or is it just a windows function.
Looking fwd to your reply.
 
Old 08-26-2007, 05:41 AM   #7
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Using your router as the source of information create/edit the /etc/resolv.conf file to match the DNS information;

nameserver XXX.XXX.XXX.XXX
nameserver XXX.XXX.XXX.XXX

Quote:
Now me router is on a MAC filter on, but it should'nt matter, only thing i can think is the WEP key, its in HEX, 128bit....and I've entered that in Wireless Settings tab in Network config.
The MAC filter does matter add the wireless device's MAC address to the router. The WEP key can and should be added to either the /etc/sysconfig/network-scripts/ifcfg-eth1 file or be in a keys-eth1 file in the same location, the format in ether case is (choose one);

KEY=<some HEX value here>
KEY=s:<some typed passphrase here>

Quote:
Also the wifi LED on the laptop wonr come on, am not sure if that means anything or is it just a windows function.
In some cases the LED only works when data is present on the wireless interface in others it means the wireless device is not enabled or active.

.
 
Old 08-26-2007, 07:50 AM   #8
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
[root@localhost network-scripts]# cat keys-eth1
KEY=s:06a9ab8c7e3ad8a6fXXXXXXc6c

(The MAC address of the wireless device is already added to the router as I have a dual boot system and can browse fine in windows.)

[root@localhost network-scripts]# cat ifcfg-eth1
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Wireless
DEVICE=eth1
HWADDR=00:13:ce:24:87:1c
BOOTPROTO=none
IPADDR=192.168.1.10
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
DOMAIN=
ONBOOT=yes
ONHOTPLUG=no
USERCTL=yes
IPV6INIT=no
PEERDNS=no
ESSID=£ucifer
CHANNEL=11
MODE=
RATE=
DHCP_HOSTNAME=


[root@localhost etc]# cat resolv.conf
; generated by /sbin/dhclient-script
nameserver 194.168.4.100
nameserver 194.168.8.100

(If that means anything to you!)
[root@localhost network-scripts]# iwconfig

lo no wireless extensions.
eth0 no wireless extensions.

eth1 unassociated ESSID:"£ucifer" Nickname:"localhost.localdomain"
Mode:Managed Frequency=2.462GHz Access Point: 00:00:00:00:00:00
Bit Rate=0kb/s Tx-Power=20 dBm
RTS thrff Fragment thrff
Encryption key:06A9-AB8C-7E3A-D8A6-FXXX-995C-6C Security modepen
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.


When I am in windows the wifi LED stays on and in BIOS there is a hotkey fn+f2 to turn it on/off.
However by default it is turned on.

Problem still persists. I cant seem to think now, hope you can.

[root@localhost network-scripts]# ping www.bbc.co.uk
ping: unknown host www.bbc.co.uk

[root@localhost network-scripts]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.10 icmp_seq=1 Destination Host Unreachable
From 192.168.1.10 icmp_seq=2 Destination Host Unreachable
From 192.168.1.10 icmp_seq=3 Destination Host Unreachable
From 192.168.1.10 icmp_seq=5 Destination Host Unreachable
--- 192.168.1.1 ping statistics ---
97 packets transmitted, 0 received, +72 errors, 100% packet loss, time 96009ms
, pipe 4
 
Old 08-26-2007, 08:01 AM   #9
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
------Also I did some research and the iwconfig dont seem right!
eth1 shows unassociated instead of the device name
dont know what the nickname means!

Access Point is showing a 00:00 address (no idea what/how this should be!)

Somthing dont look right there. Thanks again for all the support, need some more. Cheers.
 
Old 08-26-2007, 10:34 AM   #10
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Hmmmm...................... according to what you posted;

KEY=s:06a9ab8c7e3ad8a6fXXXXXXc6c is not quite right, it should be;
KEY=s:06A9AB8C7E3AD8A6FXXX995C6C

This looks like something other then a HEX or ascii(plain text) key for WEP to me, perhaps WPA so this should not be in ether the KEYS-eth1 file or in the ifcfg-eth1 file. If the wireless router is configured for something other then WEP for security like WPA or WPA-PSK the you need to look at the wpa_supplicant man page. You can also find a number of howto's at this site, just search for wpa.

You really should change your key since the entire world now knows what it is BTW.
 
Old 08-26-2007, 11:45 AM   #11
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
Lightbulb

lol, i manually edited a few characters in the key....anyway.

the key is alright! and thanx, i'll change the key once i configure me wifi.
Its definately configured for WEP.

iwlist scan ---gives me

Cell 02 - Address: 00:18:F8:4C:51:A9
ESSID:"Lucifer"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption keyn
Bit Rate:54Mb/s
Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 24 36 48 54
Signal level=-26 dBm
Extra: Last beacon: 2ms ago



can u think of anything else??
 
Old 08-26-2007, 12:22 PM   #12
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Looks like you have a connection (Address: 00:18:F8:4C:51:A9), try pinging the wireless router; ping 192.168.1.1
(you only need to see three or four attempts, press the Ctrl+C key combo ti stop)

If that works then see if you can view the wireless routes configuration page, if yes then continue on and try something like; ping www.google.com

$ ping www.google.com
PING www.l.google.com (64.233.167.99) 56(84) bytes of data.
64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=1 ttl=246 time=18.8 ms
64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=2 ttl=246 time=18.5 ms
64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=3 ttl=246 time=18.7 ms
64 bytes from py-in-f99.google.com (64.233.167.99): icmp_seq=4 ttl=246 time=19.1 ms
 
Old 08-26-2007, 01:02 PM   #13
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
Angry

[root@localhost ~]# iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:0C:F6:03:84:92
ESSID:"Sitecom"
Protocol:IEEE 802.11b
Mode:Master
Channel:1
Encryption key:on
Bit Rate:11Mb/s
Extra: Rates (Mb/s): 1 2 5.5 11
Signal level=-66 dBm
Extra: Last beacon: 15ms ago
Cell 02 - Address: 00:18:F8:4C:51:A9
ESSID:"Lucifer"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:on
Bit Rate:54Mb/s
Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 24 36 48 54
Signal level=-26 dBm
Extra: Last beacon: 9ms ago

sit0 Interface doesn't support scanning.
------------------------------------------------------------------------
(It scans 2 networks in range!)
(Just wont connect to any, dont seem to think why.)
------------------------------------------------------------------------

[root@localhost ~]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.10 icmp_seq=1 Destination Host Unreachable
From 192.168.1.10 icmp_seq=2 Destination Host Unreachable
From 192.168.1.10 icmp_seq=3 Destination Host Unreachable
From 192.168.1.10 icmp_seq=5 Destination Host Unreachable
From 192.168.1.10 icmp_seq=6 Destination Host Unreachable
From 192.168.1.10 icmp_seq=7 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
9 packets transmitted, 0 received, +6 errors, 100% packet loss, time 8000ms
, pipe 4

------------------------------------------------------------------------
[root@localhost ~]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"Lucifer" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462GHz Access Point: 00:18:F8:4C:51:A9
Bit Rate=54Mb/s Tx-Power=20 dBm
RTS thr:off Fragment thr:off
Encryption key:3036-6139-6162-3863-3765-3361-64 Security mode:open
Power Management:off
Link Quality=100/100 Signal level=-26 dBm Noise level=-84 dBm
Rx invalid nwid:0 Rx invalid crypt:33 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:24 Missed beacon:0

sit0 no wireless extensions.


(iwcongig says Security mode-open, shouldnt it be WEP? i am not even sure if/how we can change it!)
This has taken me weekend away from me...
What else can it be, why wont it connect to the router?
 
Old 08-26-2007, 05:29 PM   #14
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Turn off encryption and see if you get it working.
 
Old 08-26-2007, 06:50 PM   #15
bigjig
Member
 
Registered: Aug 2007
Location: Nottingham, UK
Distribution: openSUSE 10.3
Posts: 38

Original Poster
Rep: Reputation: 15
Smile

It works man! I like your brains.
Cheers dude, you must know I appreciate this beyond comprehension. :))

So it was the security bit....the only thing i could think of is the keys-eth1 file....but why would it not than ping to 192.168.1.1

Have you got WEP security on your network?
So its just about implementing the security bit....Have the MAC filter on so will avoid the skanks from stealing me bandwidth. I will try an do some research to implement WEP now. Thanks again!


[root@localhost network-scripts]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"Lucifer" Nickname:"localhost.localdomain"
Mode:Managed Frequency:2.462GHz Access Point: 00:18:F8:4C:51:A9
Bit Rate=54Mb/s Tx-Power=20 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=100/100 Signal level=-41 dBm Noise level=-84 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:1

sit0 no wireless extensions.

[root@localhost network-scripts]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=0 ttl=64 time=5.30 ms
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=2.74 ms

--- 192.168.1.1 ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 7009ms
rtt min/avg/max/mdev = 1.940/2.939/5.305/0.964 ms, pipe 2
[root@localhost network-scripts]# ping www.bbc.co.uk
PING www.bbc.net.uk (212.58.251.201) 56(84) bytes of data.
64 bytes from www1.telhc.bbc.co.uk (212.58.251.201): icmp_seq=0 ttl=244 time=26. 3 ms
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure Wifi On Dell Inspiron 6000 bigjig Linux - Wireless Networking 1 08-27-2007 08:06 AM
FC 5 on Dell Inspiron 6000 Menace Inc Fedora 16 05-20-2006 07:54 AM
Dell Inspiron 6000 Aeiri Linux - Hardware 30 04-22-2006 10:42 AM
Dell Inspiron 6000 monitor matat Linux - Newbie 3 03-20-2006 03:20 PM
Ubuntu on Dell Inspiron 6000 Ayabara Linux - Laptop and Netbook 1 01-18-2006 10:35 PM


All times are GMT -5. The time now is 09:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration