Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 03-20-2004, 04:26 PM   #1
Registered: Mar 2004
Posts: 6

Rep: Reputation: 0
Centrino Mobile problem: Unable to connect to access points with device

Hey there everyone, I'm new to this so please bear with me.

I'm a linux newbie and I'm starting off with the new Mandrake 10
distribution, kernel 2.6.3.

I have a Dell Inspiron 8600 with the (oh so problematic it seems)
Intel Centrino Mobile Internal Wireless Device for 802.11b.
I have everything up and running except for the horror that is
Intel Wireless. I used the forums as well as some third party help
to get ndiswrapper-0.6 setup and loaded the default driver.
Everything seems to work ok, mode, essid, and the device is
recognized, but I cannot connect to any access points.

The adapter address always appears as the default FF:FF:FF...
you get the idea. I tried to manually enter the access point just
to see if it would connect that way, but unfortunately no it hasn't.
I'm just curious if anyone else ran into this problem with Centrino
and the ndiswrapper or if I'm just not doing something right.

Any help would be appreciated, or suggestions. If you need any
other information I can do my best to give it to you. Thanks to
anyone who reads this and/or gives me some help. It's appreciated.
Old 03-23-2004, 03:21 AM   #2
Registered: Dec 2003
Location: San Jose
Distribution: Redhat WS 3
Posts: 410

Rep: Reputation: 30
post your output of
netstat -rn
Old 03-23-2004, 06:59 PM   #3
Registered: Mar 2004
Posts: 6

Original Poster
Rep: Reputation: 0
eth0 Link encap:Ethernet HWaddr [edited]
inet addr: Bcast: Mask:
inet6 addr: fe80::20d:56ff:feae:fef9/64 Scope:Link
RX packets:349 errors:0 dropped:0 overruns:0 frame:0
TX packets:544 errors:0 dropped:0 overruns:0 carrier:7
collisions:0 txqueuelen:1000
RX bytes:159242 (155.5 Kb) TX bytes:65595 (64.0 Kb)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:224 errors:0 dropped:0 overruns:0 frame:0
TX packets:224 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:16636 (16.2 Kb) TX bytes:16636 (16.2 Kb)

wlan0 Link encap:Ethernet HWaddr [edit]
inet6 addr: fe80::204:23ff:fea1:26ef/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:992 (992.0 b)
Interrupt:11 Memory:faffc000-faffcfff

lo no wireless extensions.
eth0 no wireless extensions.
sit0 no wireless extensions.
wlan0 IEEE 802.11b ESSID:""
Mode:Managed Frequency:2.412GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:11Mb/s
RTS thr:1600 B Fragment thr:2344 B
Encryption key:off
Power Management:off
Link Quality:0/100 Signal level:-98 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

when I run "ifconfig wlan0 up" this also appears below my wlan0
Link encap:Ethernet HWaddr 00:04:23:A1:26:EF
inet addr: Bcast: Mask:
Interrupt:11 Memory:faffc000-faffcfff

There is the output... with just a small edit. But anyway, my ESSID isn't showing
up now either, even after I use:
iwconfig wlan0 key ########
iwconfig wlan0 essid ESSID
although previously it appeared in the config

Hope this helps you out then... and thanks for taking a look at my post.

Last edited by child_of_dust; 03-23-2004 at 07:04 PM.
Old 03-23-2004, 07:47 PM   #4
Registered: Dec 2003
Location: San Jose
Distribution: Redhat WS 3
Posts: 410

Rep: Reputation: 30
Make sure that you do not have more than one interface on the same network. eth0 and wlan0 can not be both on 192.168.1 network. Routing will be confused and you will not be able to send/receive packets.

use /etc/sysconfig/network-scripts/ifcfg-wlan0
to set your networking and wireless options for wlan0.

Make sure to set your GATEWAY (IP address of machine that is your gateway/router machine on the same network). You will just set your gateway for your default interface whether it be eth0 or wlan0.

You also need to make sure that that for both interfaces the NETMASK is set to
and BROADCAST is set to the first 3 digits of the network address with the 4th digit being 255.

iwconfig syntax for setting the KEY is funky, what usually works for me is
"restricted [1] XXXXXXXXXX" where XXXXXXXXXX is the hex value of the the key.
Old 03-25-2004, 11:16 AM   #5
Registered: Mar 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Hey thanks!

I just got it all working today... not having any problems now.
I appreciate the help.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
samba client Access denied unable to connect Systest7 Linux - Networking 11 12-12-2010 08:45 PM
Asus WL-330g access point vs other access points dimgr Linux - Wireless Networking 3 09-20-2006 05:29 AM
Can't Connect To Access Point On SuSe 9.2 Personal With Intel Centrino 2200BG dac0braman SUSE / openSUSE 11 02-16-2005 07:26 PM
Connect to public access points mwademan Linux - Wireless Networking 0 03-02-2004 11:51 AM
Centrino Mobile processor Jane Delawney Linux - Laptop and Netbook 2 06-12-2003 01:31 AM

All times are GMT -5. The time now is 03:09 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration