LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-12-2008, 06:31 PM   #1
extendedping
Member
 
Registered: Feb 2004
Posts: 210

Rep: Reputation: 30
Centos 5.1 wireless with intel abg 3945 stopped working :(


well I tried ubuntu and it did not work at all. I am dual booting my laptop (hp pavillion dv2050us) now with centos 5.2. well to my suprise after installing the dkms-ipw3945 package via yum from rpmforge and starting networkmanager and networkmanagerdispatcher (whatever that is) as per a google search I was able to connect to my wireless. well I got happy feet and rebooted several times into both windows and centos to make sure both worked. then tonight I turned the laptop back on after having if off a day. the windows wireless works no issue but the centos 5.2 says "passphrase required by wireless network. so I put this in (which worked yesterday) and it just times out and then the same box pops up again. hmmm there has been no kernel update since yesterday and my linksys has not changed. yesterday putting in my passphrase worked no issue. and since windows wireless works I know my wireless is not dead (plus networkmanager shows like 10 networks in my range).

so what can I do to bring linux back into my life? I was so happy for a day because I tried linux several times on my laptop since getting it 2 years ago and every time (fedora centos and ubuntu) it was a nightmare that eventually I gave up on. I cant see how something that was working yesterday can just stop working today

thanks in advance for your help. btw I am useing wpa personal on the router and have that in the box asking for my passphrase or encryption key as well. help me turn my into a
 
Old 09-12-2008, 07:29 PM   #2
extendedping
Member
 
Registered: Feb 2004
Posts: 210

Original Poster
Rep: Reputation: 30
oh I should mention that I have also disabled all wireless security on the linksys and now am trying to connect to the non protected network. I see the network when I click on the networmanager icon on my upper right toolbar but it just times out
 
Old 09-13-2008, 08:33 PM   #3
extendedping
Member
 
Registered: Feb 2004
Posts: 210

Original Poster
Rep: Reputation: 30
any ideas for me?
 
Old 09-14-2008, 08:15 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I think what you're going to have to do is spend some quality time with your log files and see if there are any clues as to what is going wrong. At this point, it could be a lot of things, so we need some clues.
 
Old 09-14-2008, 12:38 PM   #5
extendedping
Member
 
Registered: Feb 2004
Posts: 210

Original Poster
Rep: Reputation: 30
ok I am not sure where to start...well I tail -f'd my /var/log/messages while trying to connect and here is what I got...

Sep 14 13:28:20 clap NetworkManager: <information> User Switch: /org/freedesktop/NetworkManager/Devices/eth1 / clams
Sep 14 13:28:20 clap NetworkManager: <information> Deactivating device eth1.
Sep 14 13:28:20 clap dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth1 for sub-path eth1.dbus.get.reason
Sep 14 13:28:20 clap NetworkManager: <information> Device eth1 activation scheduled...
Sep 14 13:28:20 clap NetworkManager: <information> Activation (eth1) started...
Sep 14 13:28:20 clap NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) scheduled...
Sep 14 13:28:20 clap NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) started...
Sep 14 13:28:20 clap NetworkManager: <information> Activation (eth1) Stage 2 of 5 (Device Configure) scheduled...
Sep 14 13:28:20 clap NetworkManager: <information> Activation (eth1) Stage 1 of 5 (Device Prepare) complete.
Sep 14 13:28:20 clap NetworkManager: <information> Activation (eth1) Stage 2 of 5 (Device Configure) starting...
Sep 14 13:28:20 clap NetworkManager: <information> Activation (eth1/wireless): access point 'clams' is unencrypted, no key needed.
Sep 14 13:28:20 clap avahi-daemon[6983]: Withdrawing address record for fe80::213:2ff:fe48:4f30 on eth1.
Sep 14 13:28:20 clap avahi-daemon[6983]: Leaving mDNS multicast group on interface eth1.IPv6 with address fe80::213:2ff:fe48:4f30.
Sep 14 13:28:20 clap avahi-daemon[6983]: iface.c: interface_mdns_mcast_join() called but no local address available.
Sep 14 13:28:20 clap avahi-daemon[6983]: Interface eth1.IPv6 no longer relevant for mDNS.
Sep 14 13:28:20 clap NetworkManager: <information> SUP: sending command 'INTERFACE_ADD eth1 wext /var/run/wpa_supplicant '
Sep 14 13:28:20 clap NetworkManager: <information> SUP: response was 'OK'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: sending command 'AP_SCAN 1'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: response was 'OK'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: sending command 'ADD_NETWORK'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: response was '0'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: sending command 'SET_NETWORK 0 ssid 636c616d73'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: response was 'OK'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: sending command 'SET_NETWORK 0 key_mgmt NONE'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: response was 'OK'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: sending command 'ENABLE_NETWORK 0'
Sep 14 13:28:20 clap NetworkManager: <information> SUP: response was 'OK'
Sep 14 13:28:20 clap NetworkManager: <information> Activation (eth1) Stage 2 of 5 (Device Configure) complete.
Sep 14 13:29:00 clap NetworkManager: <information> Activation (eth1/wireless): association took too long (>40s), failing activation.
Sep 14 13:29:00 clap NetworkManager: <information> Activation (eth1) failure scheduled...
Sep 14 13:29:00 clap NetworkManager: <information> Activation (eth1) failed for access point (clams)
Sep 14 13:29:00 clap NetworkManager: <information> Activation (eth1) failed.
Sep 14 13:29:00 clap NetworkManager: <information> Deactivating device eth1.

again network manager sees all the networks.

from within the wireless settings tab of the network device configuration window

mode auto
ssid clams (yea silly I know)
channel 1 (same as on lynksys)
transmit rate auto

I have fiddled with the mode and used different transmit rates but it still does not connect. hmm if there are some other logs I should sent please let me know. thanks...
 
Old 09-14-2008, 05:04 PM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
If you're up for it, lets try a little experiment and cut NetworkManager out of the equation. The stuff you posted is interesting and suggests that NetworkManager might be having trouble rather than the wireless card. Since you're running without encryption, doing this from the console might be enlightening.

Open a console and make yourself root. Then set the SSID of your access point:

iwconfig eth1 YourSSID

Then check the output of iwconfig. If it has taken, you should see your SSID in the ESSID field and a MAC address in your Access Point field. If you have both of those, you've successfully associated and the next step is to request an IP address. I think CentOS uses ifup, so try:

ifup eth1

If that works, ifconfig should show you an IP address and you should be good to go. If not, hopefully some errors get tossed out that will help.
 
Old 09-14-2008, 08:27 PM   #7
extendedping
Member
 
Registered: Feb 2004
Posts: 210

Original Poster
Rep: Reputation: 30
thanks for the advice...I am scared to touch it now though. I upgraded the kernel to the centos-plus kernel by enabling the repo of the same name. well I can now connect. when the computer fires up network manager tries to connect and then fails. I then from the network applet active eth1 (the wireless) and click on the network manager icon and I can connect to the wireless. so its not ideal (and I have a bad feeling it will stop working too) but I am going to use the "aint broken don't fix it" maxim for a day or 2 (or till it craps) before trying your method.

thanks much I just want to not tinker for a few since its working.
 
Old 09-16-2008, 06:28 PM   #8
extendedping
Member
 
Registered: Feb 2004
Posts: 210

Original Poster
Rep: Reputation: 30
still working
 
Old 09-17-2008, 07:11 AM   #9
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Good. Lets hope it stays that way!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
intel wireless 3945 Lantius Ubuntu 13 04-09-2009 02:12 AM
Intel 3945 ABG Wireless card - Debian Etch - Error with modprobe ipw3945 Henri Linux - Wireless Networking 1 06-12-2007 10:19 PM
Installing Intel Pro/Wireless 3945 ABG driver nicehill Mandriva 11 05-22-2007 02:01 AM
intel 3945 abg always on in suse 10.1 delinne Linux - Hardware 2 10-02-2006 11:46 AM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration