LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Can't use wifi on channel 13? (http://www.linuxquestions.org/questions/linux-wireless-networking-41/cant-use-wifi-on-channel-13-a-774287/)

kitenski 12-08-2009 01:41 PM

Can't use wifi on channel 13?
 
I’m just dipping my toe into the Linux waters, by installing (dual boot) Jolicloud onto my HP 2140 netbook, everything is fine apart from wifi. I have my home wifi network on channel 13, and the netbook cannot see it.

If I change channels to 6 it works, but then I get loads of interference from neighbours, etc, so 13 is the channel I want to use

I had the same issue on Windows and had to hack the registry to make it think I was in GB as opposed to US as per my blog post here - http://www.digitalsoftblog.net/?p=93

I just wondered if anyoneknew a quick way to do something similar to enable ‘European’ channels on my netbook?

cheers,

Greg

Hangdog42 12-08-2009 04:24 PM

I think you need to modify your /etc/modprobe.d/options (or maybe /etc/modprobe.conf depending on your distro) file and include:

Code:

options cfg80211 ieee80211_regdom=EU
I've seen this mentioned in several fixes for Intel cards, but I suspect it should work with any card as I don't think that module is Intel specific. Of course if your running this in the US, you shouldn't do this as channels above 11 are illegal.

kitenski 12-09-2009 02:11 PM

Quote:

Originally Posted by Hangdog42 (Post 3784555)
I think you need to modify your /etc/modprobe.d/options (or maybe /etc/modprobe.conf depending on your distro) file and include:

Code:

options cfg80211 ieee80211_regdom=EU
I've seen this mentioned in several fixes for Intel cards, but I suspect it should work with any card as I don't think that module is Intel specific. Of course if your running this in the US, you shouldn't do this as channels above 11 are illegal.

Hi handgdog42, that sounds like the right thing to do, however I don't have either of those files :(

I have the modprobe.d directory, it contains the following conf files:

alsa-base.conf
blacklist.conf
libpisock9.cnf
blacklist-ath_pci.conf
blacklist-firewire.conf
blacklist-modem.conf
blacklist-watchdog.conf

The Wifi chip is broadcomm

cheers,

Greg

Hangdog42 12-10-2009 06:04 AM

You probably could just create an options file in /etc/modprobe.d and add that line to it. Once you restart, hopefully the higher channels will be enabled. If this is right, this method does work with the b43 driver.

kitenski 12-10-2009 03:14 PM

Quote:

Originally Posted by Hangdog42 (Post 3786536)
You probably could just create an options file in /etc/modprobe.d and add that line to it. Once you restart, hopefully the higher channels will be enabled. If this is right, this method does work with the b43 driver.

That didn't work I'm afraid, neither did calling the file options.conf (and restarting each time)

Cheers,

Greg

Hangdog42 12-10-2009 06:15 PM

OK, lets back up a bit. What driver are you actually using? You might also look for a Jolicloud forum or email list. From the description they give, Ubuntu fixes should work, but they talk a lot about optimizing for netbooks and I'm wondering if they've done some patching that would alter normal Linux behavior.


All times are GMT -5. The time now is 08:36 AM.