LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Cant connect to wireless modem on linux mint 9 (http://www.linuxquestions.org/questions/linux-wireless-networking-41/cant-connect-to-wireless-modem-on-linux-mint-9-a-917195/)

katesfb 12-05-2011 03:25 AM

Cant connect to wireless modem on linux mint 9
 
Hi,
Recently upgraded our wireless modem from a D-link unit to a Thomson unit and am now having a few issues connecting to it on the my main system (linux mint 9 on desktop computer). However the main computer is dual booted with linux mint LXDE 10 and that connects fine therefor the hardware cant be the issue. We also have various laptop computers, some windows based and some linux based and all connect fine which also indicates that the modem is not the problem either. I would have used mintwifi except that it is not installed by default on mint 9 and obviously i cant download it at the moment to try and see what is going wrong.

The computer can see the required network but just cant connect to it - could it be a securty settings issue as previous system used WEP and upgraded system uses WPA + WPA2 however all other systems connect no problem.

What files should i be looking at to see what is going wrong?

Outputs from inxi, iwconfig, dmesg and lsusb are below.

Any help is much appreciated.

Cheers.

On the system that wont connect (mint 9):
inxi -dDc 6
System: Host richard-desktop Kernel 2.6.32-21-generic i686 (32 bit) Distro Linux Mint 9 Isadora
CPU: Dual core Pentium E6600 (SMP) clocked at 3059.00 MHz
Graphics: Card Intel 4 Series Chipset Integrated Graphics Controller X.Org 1.7.6 Res: 1280x1024@0.0hz
GLX Renderer Software Rasterizer GLX Version 2.1 Mesa 7.7.1
Disks: HDD Total Size: 320.1GB (9.3% used) 1: /dev/sda ST9320423AS 320.1GB
Info: Processes 166 Uptime 2 min Memory 216.1/1960.5MB Client Shell inxi 1.3.2

iwconfig
lo no wireless extensions.

eth2 no wireless extensions.

wlan0 RTxx70 Wireless ESSID:"" Nickname:"RT3070STA"
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off
Link Quality=78/100 Signal level:-63 dBm Noise level:-87 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

ouput from end of Dmesg:
[ 318.682624] ===>rt_ioctl_giwscan. 8(8) BSS returned, data->length = 1242
[ 318.682872] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
[ 318.734947] DRS: unkown mode,default use 11N 2S AP
[ 318.734952] DRS: unkown mode (SupRateLen=8, ExtRateLen=4, MCSSet[0]=0x0, MCSSet[1]=0x0)
[ 333.736192] ===>rt_ioctl_giwscan. 8(8) BSS returned, data->length = 1242
[ 333.736390] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
[ 333.787449] DRS: unkown mode,default use 11N 2S AP
[ 333.787455] DRS: unkown mode (SupRateLen=8, ExtRateLen=4, MCSSet[0]=0x0, MCSSet[1]=0x0)
[ 348.788773] ===>rt_ioctl_giwscan. 6(6) BSS returned, data->length = 932
[ 348.789015] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
[ 348.840199] DRS: unkown mode,default use 11N 2S AP
[ 348.840204] DRS: unkown mode (SupRateLen=8, ExtRateLen=4, MCSSet[0]=0x0, MCSSet[1]=0x0)
[ 363.841579] ===>rt_ioctl_giwscan. 8(8) BSS returned, data->length = 1242
[ 363.841779] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
[ 363.892702] DRS: unkown mode,default use 11N 2S AP
[ 363.892708] DRS: unkown mode (SupRateLen=8, ExtRateLen=4, MCSSet[0]=0x0, MCSSet[1]=0x0)

On the system that does connect (mint lxde 10 on same computer):
Dmesg:
[ 18.432710] <==== rt28xx_init, Status=0
[ 18.434212] 0x1300 = 000a4200
[ 21.174807] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro,commit=0
[ 23.477226] ===>rt_ioctl_giwscan. 8(8) BSS returned, data->length = 1195
[ 26.848445] EXT4-fs (sda6): re-mounted. Opts: errors=remount-ro,commit=0
[ 29.328014] wlan0: no IPv6 routers present
[ 34.852551] ===>rt_ioctl_giwscan. 8(8) BSS returned, data->length = 1246
[ 34.852809] ==>rt_ioctl_siwfreq::SIOCSIWFREQ[cmd=0x8b04] (Channel=1)
[ 41.902037] ===>rt_ioctl_giwscan. 8(8) BSS returned, data->length = 1246

iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 Ralink STA ESSID:"Thomson23128C" Nickname:"RT2870STA"
Mode:Managed Frequency=2.412 GHz Access Point: 08:76:FF:23:12:8C
Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Link Quality=80/100 Signal level:-65 dBm Noise level:-63 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 003: ID 0a81:0101 Chesen Electronics Corp. Keyboard
Bus 005 Device 002: ID 04d9:0499 Holtek Semiconductor, Inc. Optical Mouse
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 04f9:01a8 Brother Industries, Ltd DCP-130C
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 148f:3072 Ralink Technology, Corp. RT3072 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

katesfb 12-05-2011 07:00 PM

Anybody?

Brains 12-05-2011 07:20 PM

wlan0 RTxx70 Wireless ESSID:"" Nickname:"RT3070STA"
wlan0 Ralink STA ESSID:"Thomson23128C" Nickname:"RT2870STA"

Looks like you are trying to connect to the neighbors router, or your old one.

katesfb 12-06-2011 04:27 PM

Hi,
And thanks for the reply. Yes is think that the system is still trying to connect to the old router configuration. This is what i am trying to connect to:

Code:

iwlist scan
lo        Interface doesn't support scanning.

eth2      Interface doesn't support scanning.

wlan0    Scan completed :
          Cell 01 - Address: 08:76:FF:23:12:8C
                    Protocol:802.11b/g/n
                    ESSID:"Thomson23128C"
                    Mode:Managed
                    Channel:6
                    Quality:83/100  Signal level:-57 dBm  Noise level:-63 dBm
                    Encryption key:on
                    Bit Rates:54 Mb/s
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

The above is the device that it should be trying to connect to. If i use iwconfig to configure the interface manually entering values for essid etc to match with the above it accepts them and then if i run iwconfig it gives the same results as iwlist scan does however i still cant connect and if i reboot the computer and run iwconfig it shows that the interface has been returned to how it was ie new configuration not retained as if something at boot time is overriding any setting changes i make.

Do you know the file that is accessed at boot time that sets the wireless configuration then maybe i can alter this or has something been written into the kernel that is causing the issues ie still trying to connect to the old router.

Any help is much apreciated.

Cheers.

Brains 12-06-2011 05:00 PM

The file to look at is /etc/network/interfaces

From command line I edit this file to include the three lines below, then as root or sudo issue command: dhclient wlan0 to connect (with mint, you may need to use sudo with that command). You can also just reboot and the connection should take place. Your /etc/network/interfaces file might also already have settings for wlan0 with the old router's essid and key, in which case you can probably just get away with changing them to new essid and key, the example below reflects your settings without the key since I don't know it, if the key is a hex key (a bunch of numbers) do not use the "s:", the "s:" is for a paraphrase type key which can be words and numbers combined etc.
Code:

auto wlan0 inet dhcp
wireless-essid Thomson23128C
wireless-key s:Yata1yata

This works also, not sure if there is a difference:
Code:

iface wlan0 inet dhcp
wireless-essid Thomson23128C
wireless-key s:Yata1yata

This is assuming your router assigns IP addresses dynamically via dhcp
EDIT: Sorry, had inet and wlan0 in wrong order.

Brains 12-06-2011 05:47 PM

This is how the Debian (Ubuntu based on Debian, Mint based on Ubuntu) wiki shows the entry should look like.


All times are GMT -5. The time now is 03:21 AM.