LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-14-2006, 12:46 AM   #1
vikramkone
LQ Newbie
 
Registered: Nov 2006
Posts: 6

Rep: Reputation: 0
Cant connect to WEP enabled wireless network in FC6


Hi..
I recently installed FC6 on my laptop which has intel pro wireless 2200BG wireless card..
First i wasnt able to connect to any wireless network....but later when i unzipped the firmware files into /lib/firmware dir i was able to install the drivers.
Then using network manager when i tried to connect to my home network whose name is "AndhraGuyZ" which has a WEP enabled security with code 9999900000..it says that no cable present?? check cable(
Why is this happeneing..
the network manager in gnome is in master mode and the next tab below it is in auto mode..
i tried changing the mode to auto, master and managed and the tab below it too..bu nothing worked..let me know how to do this?
So can anyone tell me how to connect to a wep enabled secured wireless network from gnome in FC6

Awaiting reply

BTW..iwconfig gives the following o/p

lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSID:"andhraguyz" Nickname:"localhost.localdomain"
Mode:Managed Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:12 Missed beacon:0

sit0 no wireless extensions.
 
Old 11-14-2006, 09:39 PM   #2
WNBowman
LQ Newbie
 
Registered: Nov 2005
Distribution: FC5, FC6
Posts: 1

Rep: Reputation: 0
vikramkone,
I was having similar issues with an HP branded orinoco (Lucent) PC Card. I finally put together a script I can run after bootup that will configure the wireless card with the necessary WEP parameters the router is looking for.

ifdown eth1
iwconfig eth1 key=9999900000
iwconfig eth1 channel=11
iwconfig eth1 commit
ifup eth1

I saved this as /etc/wireless, then did chmod +x wireless so it would execute as a script. Now all I have to do is type /etc/wireless to get it to connect. You may need to verify your WEP key with the setting in the router. If you are using 104 bit encryption, your hex key will need to be 26 characters long.

Neal
 
Old 11-16-2006, 04:02 PM   #3
Ragnarok Warrior
Member
 
Registered: Nov 2005
Location: Bangor, ME
Distribution: Linux Mint, Puppy Linux, DSL
Posts: 34

Rep: Reputation: 15
Only because I'm having the exact same problem am I reading this script, but first, can anyone point me to a forum explaining how to create and run scripts?
 
Old 12-26-2006, 06:21 AM   #4
rajeev1982
LQ Newbie
 
Registered: Apr 2006
Location: India
Distribution: Fedora Core 5
Posts: 13

Rep: Reputation: 0
Wink creating and running shell scripts

thats so simple. create a text file with vi (or with editor you like) like this

------------------------------------------------------------------
#!/bin/ksh

# file: myls.ksh (.ksh is optional, you can give just myls also)

# write down some unix commands. e.g ls -l
ls -l

-------------------------------------------------------------------

save this file as myls.ksh and give the execute permissions using the following command

$ chmod u+x myls.ksh

execute the script

$ ./myls.ksh

that it!! you are done. to write more complex shell scripts you need to read some tutorial ;-)
 
Old 01-30-2007, 01:40 PM   #5
pourya
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
try the following maybe it helps:
ifconfig eth1 down
iwconfig eth1 essid AndhraGuyZ key 9999900000
ifconfig eth1 up
dhcpcd eth1

if you dont have dhcpcd you need to install it... The FC package manager should have it.
cheers..
 
Old 01-30-2007, 01:43 PM   #6
pourya
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
try the following maybe it helps:
ifconfig eth1 down
iwconfig eth1 essid AndhraGuyZ key 9999900000
ifconfig eth1 up
dhcpcd eth1
if FC doesnt have dhcpcd installed by default you need to install it using the package manager.
cheers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using iwconfig to connect to a wireless network. No WEP radicalrain Linux - Wireless Networking 2 05-03-2008 10:09 PM
FC6 sucks....unable to connect to wireless network vikramkone Linux - Laptop and Netbook 2 11-20-2006 01:40 PM
Can connect to unsecure network, but not WEP enabled one. markbeverley Linux - Wireless Networking 2 11-06-2006 02:39 PM
Can't Connect To WEP Wireless Network MailleMan Linux - Wireless Networking 5 05-23-2006 05:06 AM
wireless card (wpc11) won't work when WEP is enabled once here Linux - Wireless Networking 7 11-29-2003 10:04 PM


All times are GMT -5. The time now is 04:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration