LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   cant automatically connect to my wifi network (http://www.linuxquestions.org/questions/linux-wireless-networking-41/cant-automatically-connect-to-my-wifi-network-611730/)

capn_hector 01-07-2008 08:03 AM

cant automatically connect to my wifi network
 
ok i was running a dual boot windows and slackware 11 running kernel 2.6.20 (old i know but i have not had a need to upgrade) well my windows broke and my wife finaly said she would use linux so now i need to get the network up and running at boot. before i just got it up with iwconfig and dhcpcd. i have rc.inet1.conf and rc.wireless.conf edited for my network and here there are

Quote:

Originally Posted by rc.inet1.conf
IFNAME[4]="ath0"
USE_DHCP[4]="yes"
WLAN_ESSID[4]=MY_ESSID
WLAN_MODE[4]=Managed
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="1"
WLAN_KEY[4]="my-wep-key"

Quote:

Originally Posted by rc.wireless.conf
# Multiband Atheros based 802.11a/b/g universal NIC cards
00:90:96:*)
INFO="Multiband Atheros based 802.11a/b/g universal NIC"
# ESSID (extended network name) : My Network, any
ESSID="MY_ESSID"
MODE="Managed"
FREQ=""
CHANNEL="1"
RATE="auto"
KEY="my-wep-key"

if i missed a setting let me know or if there conflicting with each other but after boot ifconfig gives me only lo and ifconfig ath0 gives me the normal down state of the adapter and both rc.inet1 and rc.wireless are chmod 666 in /etc/rc.d so they should be running at boot.

and its an athros card which works fine if i manualy set every thing after boot but my wife is not savy enough nor do i want to give her root access where she might do an "rm -R *" from / if she gets pissed at me.

capn_hector 01-07-2008 10:16 AM

tried both with the other commented out inet1.conf commented out and only wireless.conf and the other way around still not working.


All times are GMT -5. The time now is 12:46 AM.