LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 07-11-2004, 11:14 AM   #16
dinojerm
Member
 
Registered: Apr 2004
Location: NJ,US
Distribution: Debian Sid
Posts: 33

Rep: Reputation: 15

Hmmm.... When I first modprobe ndiswrapper, it does automatically display a network name and MAC addrfess. Since since the ssid was just "linksys", I assumed that it was the default for the drivers.
Then, with Windows, I used NetStumbler and found that that "linksys" network did exist and had the MAC that was listed by iwconfig (It is probably owned by a neighbor). Its signal strength was low, and was rarely accesible (otherwise I would just use their network). It wasn't encrypted (mine is).
I think I will try to disable encryption and see if that helps.
 
Old 07-11-2004, 11:39 AM   #17
stuart
Member
 
Registered: Jun 2004
Location: aussie in germany
Distribution: mandrake 10 powerpack
Posts: 104

Rep: Reputation: 15
dinojerm im seeing exactly the same thing as you using mandrake 10, i have the card set to start on bootup ( i did that via system>>configuration>>configure your computer>>network and internet>>manage connections then i choose my wlan0 card goto options and set to start on boot) however when i set it to that, it would always pick up my neighbours AP as well and connect. The way i stopped that is by going to that same configuration panel and settings manually under wireless settings the ESSID to my ESSID "WLAN" now it boots up fine and starts the network on boot and connects to my AP.

However when i turn it off start on boot and try to set my ESSID manually by using "iwconfig wlan0 essid WLAN" it still wont set it there, the only way i can get it to load up again is to "modprobe -r ndiswrapper" then start it again. However it doesnt get an IP address when i do this manually, and when i try to run dhcpcd it just hangs the terminal, i cant seem to get an IP address for my card any other way but to have it load on bootup.

So i can get it to work that way without encyption also. I had problems with encryption enabled, i couldnt get it to connect but im just ironing that issue out now.

I dunno if this will be helpfull at all but i just thoguth id let you know my experience.
 
Old 07-11-2004, 12:09 PM   #18
leapingfrog
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Hey Guys..

I (finally) solved my problems by recompiling my kernel to the latest (2.6.7) and then installing the ipw2100 drivers (http://ipw2100.sf.net) instead of using the ndiswrapper. It took quite a bit more work than the ndiswrapper, but it works.

For anyone wondering (anyone else with an Intel 2100 Wireless card on FC2), here is what I did:

1. Download/extract latest kernel source from http://kernel.org (updating the kernel fixed errors when I tried to 'make' the ipw2100 driver)

2. Recompile your kernel (I followed this tutorial for reference: http://fedoranews.org/contributors/vitor_domingos/ntfs/)

3. Reboot with new kernel

4. Download/extract latest ipw2100 drivers from http://ipw2100.sf.net

5. Refer to "Building Internal" in the INSTALL file to build the drivers directly into the kernel:
http://ipw2100.sourceforge.net/INSTALL

6. When configuring the kernel (make menuconfig), enable the ipw2100 driver and enable legacy firmware support (I couldn't seem to get hotplug firmware working). There is more information on this in the INSTALL file.

7. Recompile the kernel once again just as before

8. Reboot to the new kernel. On boot-up, my system detected the 'new hardware' and I was able to configure it for DHCP.

9. Now you can go ahead and configure your network card once you get back into linux ... (I did this through System Tools > Network Device Control) on the main menu.

10. After configuring, try to pull up an IP using ifup eth1 (or similar) in the terminal as root. And that should be it!

Hopefully these instructions help anyone else out there. Again, this is just what I found worked for me... I'm a complete linux n00b, so maybe there is an easier way...

The SSID problem seems pretty common so hopefully this thread is proving useful to quite a few people!

Last edited by leapingfrog; 07-11-2004 at 12:13 PM.
 
Old 07-11-2004, 01:20 PM   #19
dinojerm
Member
 
Registered: Apr 2004
Location: NJ,US
Distribution: Debian Sid
Posts: 33

Rep: Reputation: 15
When I disabled encryption, I was able to connect (though I set the SSID in /etc/rc.d/rc.local so it would do it every time it booted).
Then, once the SSID was set, I reenabled encryption on the router and with iwconfig.
This worked to get the network setup, but I don't want to have to do this every time I restart.
 
Old 07-11-2004, 02:17 PM   #20
stuart
Member
 
Registered: Jun 2004
Location: aussie in germany
Distribution: mandrake 10 powerpack
Posts: 104

Rep: Reputation: 15
Thats exactly where im at now dinojerm, i can get my network to start on bootup if i have WEP disabled, then i can enable WEP on the AP and then go and put the key in with iwconfig for the card, but yeah i dont want to do this every time either.


Does anyone know where the config file is for the network settings? I'm guessing that when i do a iwconfig it gets that info from somewhere??
 
Old 07-11-2004, 04:00 PM   #21
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Does anyone know where the config file is for the network settings? I'm guessing that when i do a iwconfig it gets that info from somewhere??
I don't know if this helps, but I just have a series of modprobe and iwconfig commands in my /etc/rc.d/rc.local file. As for iwconfig, it is getting the information from your card information directory of /proc/net. Since /proc changes all the time, this isn't a stable place to try and store configs.

If it helps, this is the relevant section of my rc.local:
Code:
#Load the module
   echo "Loading NDISWRAPPER"
   /sbin/modprobe ndiswrapper

   # Set up the WiFi card

   echo "Configuring wlan0"
   /sbin/iwconfigwlan0 essid MyESSID
   /sbin/iwconfig wlan0 mode Managed
   /sbin/iwconfig wlan0 key myWEPKey

   # Get IP address from dhcp

   /sbin/dhcpcd -t 10 -d wlan0
 
Old 07-11-2004, 05:03 PM   #22
stuart
Member
 
Registered: Jun 2004
Location: aussie in germany
Distribution: mandrake 10 powerpack
Posts: 104

Rep: Reputation: 15
Yep that is what SHOULD work, and i should be able to do that from the command prompt but it just wants to be stubborn. I tried with the linuxant drivers and my card detects fine, all commands work fine and there is no issues anymore, the problem appears to lie with ndiswrapper, as im using the exact same windows drivers with the linuxant program as well. It's a shame as linuxant only allows me to use it for 30 days then wants me to buy a license for $20 US, im gonna go look tomorrow at a shop and see how much a new wireless card is gonna cost me, and decide if i want to buy a 20$ license for my card or a new card.


http://www.linuxant.com/driverloader...3d4697b0f06e06

for those who might be interested, you have to sign up for a trial account even but its 30 days and a good way to test your card. I'm giving up on ndiswrapper for now as ive spent the entire day trying to get it to work and am unable to get it to work with wep and i wont run without it enabled so for now.
 
Old 07-12-2004, 12:36 AM   #23
dinojerm
Member
 
Registered: Apr 2004
Location: NJ,US
Distribution: Debian Sid
Posts: 33

Rep: Reputation: 15
Stuart: I've also decided to use the Linuxant driver loader instead of ndiswrapper. It seems to be working fine.
 
Old 07-12-2004, 11:20 AM   #24
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
There is a message in the ndiswrapper forums on sourceforge that suggests switching your mode to Auto if you are having trouble setting your ESSID in ndiswrapper 0.8. The author claims (without any additional info) that setting the ESSID doesn't work in Managed mode, only in Auto and (apparently) has only used a Broadcom chipset, but it might be worth a go.

The post is here

<edit>
After a bit more rummaging around the Sourceforge forums, this appears to be the reccommended solution (well, if you have a Broadcom chipset that is) and using Auto shouldn't cause trouble with a Managed mode AP. If anyone has success with this approach, please post.

</edit>

Last edited by Hangdog42; 07-12-2004 at 11:28 AM.
 
Old 07-12-2004, 09:09 PM   #25
stuart
Member
 
Registered: Jun 2004
Location: aussie in germany
Distribution: mandrake 10 powerpack
Posts: 104

Rep: Reputation: 15
Thanks for the info, but i have decided to bite the bullet and just purchase a license for linuxant driver loader(i really don't like the idea of paying to get a piece of hardware working but everything else is free so bleh..). I really need this to work properly as i'm trying to change from windows 100% and this was really the last step and i needed my wireless to behave properly so i can reconfig it easily for different networks and with the linuxant driver it works perfectly for this.

but still thanks for looking for the info
 
Old 08-03-2004, 04:57 AM   #26
bladewing
LQ Newbie
 
Registered: Aug 2004
Posts: 6

Rep: Reputation: 0
I've been setting up a WMP54G (rev2.7) throughout most of the evening. I can't illustrate how frustrating it's been to run into necessary configuration tools that weren't part of the "default" install for Mandrake 10. Throughout the course of tonight I've upgraded the kernel to 2.7 and installed I don't know how many additional modules in order to pull this off. With ndiswrapper in place, I'm rather impressed with the work of these developers. :^) I see the last post here pretty well covers the generic approach, but I noticed there's a definite order to the progression of configurations.

In order to set the essid (actually, it was picked up) I had to make sure that the proper channel was being used (double-check your frequencies) and set up the key before it would be recognized. After those two were in place, it gathered the essid automatically, though it didn't take an IP until told by dhclient.

-----

On a related note, I have things set up well enough that I can configure them on a reboot, but I haven't been able to get it automated. I still have to set the key, change the channel, and retrieve an IP. Mandrake's Control Panel tells won't let me configure an internet connection (tells me I don't have a connection set up and should run the Internet Connection from the Control Panel... duh), and the nic setup under the same area doesn't include the driver in its list (since I'm utilizing ndiswrapper) so whatever additional edits the GUI would normally make have not been done. Anyone have an idea what files I need to look in to set this up for loading correctly at boot?
 
Old 08-03-2004, 05:27 AM   #27
stuart
Member
 
Registered: Jun 2004
Location: aussie in germany
Distribution: mandrake 10 powerpack
Posts: 104

Rep: Reputation: 15
/etc/rc.local

Login as root and edit that file.

I just go right to the bottom and then add the commands that you have to issue manually to have them run on bootup


example

iwconfig wlan0 essid ¨myid here¨
iwconfig wlan0 key ¨my key here¨
dhclient wlan0


etc, thats what i did anyways, worked a treat

hope this helps
 
Old 08-10-2004, 05:28 PM   #28
VincentB
Member
 
Registered: Jun 2003
Location: Brussels, Belgium
Distribution: Ubuntu 6.10
Posts: 139

Rep: Reputation: 15
All,
I also have fixed this problem. I run mandrake 10 on my PC with a wireless card which contains a Broadcom chipset: Broadcom Corporation|BCM94306 802.11g NIC [NETWORK_OTHER]

I have first removed ndiswrapper 0.8 on my PC and have installed the last version 0.9
I have downloaded the driver from the Compaq site BCMWL5A. I am not sure if this is really part of the solution, but it works for me.
I have also to setup the wlan0 parameter in a certain order:

351 iwconfig mode auto
352 iwconfig wlan0 essid myessid channel 11
354 iwconfig wlan0 mode auto
356 iwconfig wlan0 key my_key

The key has to be set in the last step. Otherwise, it seems to be impossible to set it.
And finally, it works ...

[root@localhost vincent]# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"my_ap"
Mode:Auto Frequency:2.462GHz Access Point: 00:0C:41E:0C:E7
Bit Rate:54Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key: my_key Security mode:restricted
Power Managementff
Link Quality:99/100 Signal level:-57 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:78 Invalid misc:264 Missed beacon:0

Do not hesitate to ask for more informations ...

Vincent
 
Old 11-30-2004, 04:34 PM   #29
muchristian
LQ Newbie
 
Registered: Nov 2004
Location: Charlotte NC
Distribution: Debian (unstable)
Posts: 15

Rep: Reputation: 0
My solution to the broadcom essid problem was just to change the drivers out. The card is identified by lspci as: 0000:02:00.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03).(pcmcia 54g card) it is branded as a belkin F5D7010. when i used the drivers from the cd, with the ndiswrapper i could only change the ssid when i had the mode set to auto (iwconfig wlan0 mode auto.... then iwconfig wlan0 essid myessid). However this did not seem to work with my router very well and since i don't broadcast my essid this was also a problem. I have the drivers for a belkin F5D7000 pci card as I also have a wireless on a desktop. So used the drivers from that card (ndiswrapper -i ndiswrapper -i bcmwl5.inf), and from what i can tell, all the features work, including changing mode, channel, and essid. Hope that helps someone.

NDISWRAPPER_VERSION=0.12

 
Old 12-30-2004, 03:52 PM   #30
liberte
LQ Newbie
 
Registered: Dec 2004
Distribution: SuSe
Posts: 1

Rep: Reputation: 0
Smile

Hi All,

I have seen this before and had it recently with a Linksys WPC54G using ndiswrappers. The card was configured as wlan0 and had channel set as auto. It had worked at one stage but after that was picking the wrong frequency. Once I set the channel to match the AP it all worked fine.

Hope that helps.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant change ESSID with iwconfig svenbox Linux - Hardware 1 04-27-2005 06:54 AM
iwconfig - can't set essid simon_w Linux - Wireless Networking 5 04-13-2005 10:23 PM
iwconfig shows essid, unable to connect rjcrews Linux - Wireless Networking 8 12-21-2004 05:59 PM
essid not being set with iwconfig jonathan_t Linux - Wireless Networking 17 10-19-2004 07:14 AM
Problems setting ESSID on WPC11 with iwconfig DustOffTryAgain Linux - Networking 1 07-22-2003 11:09 PM


All times are GMT -5. The time now is 01:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration