View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 09-25-2007, 11:59 PM   #1
LQ Newbie
Registered: Jun 2007
Distribution: LFS 6.2 and Debian Lenny
Posts: 6

Rep: Reputation: 0
Cannot connect wirelessly to router

Hey, I'm running Debian on two computers and on both of them, I cannot wirelessly connect to my home network. When I scan for networks with iwlist, the quality on all the linux computers is 0/100, and I cannot connect to the network with iwconfig. However, when I put a Windows laptop in the same location as the linux computers, the Windows laptop connects without problem.

I am using WEP, and disabling did nothing to remedy my problem.
Old 09-26-2007, 10:29 AM   #2
Registered: Oct 2004
Location: Missouri, USA
Distribution: Slackware 12.2, Xubuntu 9.10
Posts: 371

Rep: Reputation: 31
Can you post what you see from the "ifconfig" and "iwconfig" commands?

What wireless cards/hardware are you using?
Old 09-26-2007, 07:09 PM   #3
LQ Newbie
Registered: Jun 2007
Distribution: LFS 6.2 and Debian Lenny
Posts: 6

Original Poster
Rep: Reputation: 0
eth2 Link encap:Ethernet HWaddr 00:0F:66:1D0:C8
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:209 Memory:f7efe000-f7f00000

eth2 IEEE 802.11g ESSIDff/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:16 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:8949-9031-24 Security mode:restricted
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

When I give the command iwconfig eth2 essid "kjhdfsfsd" key 787394281, I can't connect. Even disabling WEP, I still cannot connect. Furthermore, when using kwifi, the connect button is disabled when scanning for networks (not that I really trust GUIs anyway).

[Edit:] The card is a Linksys WMP54G and the router is a 2wire 2701HG-B

Last edited by -Ay-; 09-26-2007 at 07:11 PM.
Old 10-01-2007, 12:35 AM   #4
LQ Newbie
Registered: Mar 2004
Posts: 14

Rep: Reputation: 0
Also can you post the results of a scan ?

>iwlist scan

I'm wondering if you are having a similar problem I'm having. Your wireless card indicates it is g-only setup

eth2 IEEE 802.11g ESSID: off/any

most of the tutorials show the card as

eth2 IEEE 802.11b/g ESSID: off/any

when they are set to accept both.

You might ensure that your router is set to support b & g protocols--may not be set by default. You should be able to look at the configuration page for the router to determine.

Old 10-01-2007, 12:43 AM   #5
Registered: Sep 2004
Location: Carlisle, MA
Distribution: Debian 8
Posts: 419

Rep: Reputation: 30
first thing i noticed is you werent specifying a channel to iwconfig

make sure the device is up when you scan also.

Last edited by AAnarchYY; 10-01-2007 at 12:44 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not connect wirelessly wlaw Linux - Wireless Networking 2 05-24-2007 08:49 PM
Can not connect wirelessly bob3dan Ubuntu 1 03-14-2007 12:43 PM
How do I connect wirelessly to my router? Vince013 Linux - Networking 3 08-13-2006 08:33 AM
How To Connect Wirelessly snowboard4fod Linux - Wireless Networking 1 10-18-2005 05:47 AM
Connect wirelessly through a wired computer? GT_Onizuka Linux - Wireless Networking 2 02-10-2005 06:10 PM

All times are GMT -5. The time now is 04:04 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration