LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-14-2005, 04:55 PM   #1
raindogs
LQ Newbie
 
Registered: Oct 2004
Posts: 9

Rep: Reputation: 0
cannot connect to secure wireless network with Fedora 3


I'm using Fedora 3 on a Thinkpad 600x with an Aironet 4800 Wireless card. I can connect to a wireless network when it's totally open and insecure, but as soon as I need to deal with any sort of WEP security or even an SSID, I can't get an IP address. I'm currently trying to connect to a network that is password-protected and has the SSID "house", but the same problems persist. I have tested out the network on another machine and everything works fine, so I'm sure that the network is up and I have the right password. I've pasted all of the relevant info below and would really appreciate any suggestions.

Thanks,
Alex
***************************************************************************
settings in Fedora's network wirless configuration tool:

mode: Managed
network name (SSID): specified, house
channel: 1
transmit rate: 11Mb/s
key: <correct key> (yes, I'm sure it's right and I'm sure it's not hex)

***************************************************************************
output of iwconifg:
sit0 no wireless extensions.

eth0 IEEE 802.11-DS ESSID:"house"
Mode:Managed Frequency:2.442 GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate=11 Mb/s Tx-Power=20 dBm Sensitivity=0/65535
Retry limit:16 RTS thrff Fragment thrff
Encryption key:****-****-****-****-****-****-** Security modepen
Power Managementff
Link Quality=0/100 Signal level=-106 dBm Noise level=-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

wifi0 IEEE 802.11-DS ESSID:"house"
Mode:Managed Frequency:2.442 GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate=11 Mb/s Tx-Power=20 dBm Sensitivity=0/65535
Retry limit:16 RTS thrff Fragment thrff
Encryption key:****-****-****-****-****-****-** Security modepen
Power Managementff
Link Quality=0/100 Signal level=-106 dBm Noise level=-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

***************************************************************************
output after running �ifup eth0�:

Determining IP information for eth0...PING 192.168.99.1 (192.168.99.1) from 192.168.99.72 eth0: 56(84) bytes of data.

--- 192.168.99.1 ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2999ms
, pipe 4
failed.


output of `tail -30 /var/log/messages`

Sep 14 14:35:10 localhost dhclient: No DHCPOFFERS received.
Sep 14 14:35:10 localhost dhclient: Trying recorded lease 192.168.99.72
Sep 14 14:35:13 localhost kernel: airo: cmd= 2
Sep 14 14:35:13 localhost kernel: airo: status= 7f02
Sep 14 14:35:13 localhost kernel: airo: Rsp0= 0
Sep 14 14:35:13 localhost kernel: airo: Rsp1= ff10
Sep 14 14:35:13 localhost kernel: airo: Rsp2= 10
Sep 14 14:36:54 localhost kernel: Setting key 0
Sep 14 14:36:55 localhost kernel: airo: cmd= 1
Sep 14 14:36:55 localhost kernel: airo: status= 7f01
Sep 14 14:36:55 localhost kernel: airo: Rsp0= 85
Sep 14 14:36:55 localhost kernel: airo: Rsp1= ff10
Sep 14 14:36:55 localhost kernel: airo: Rsp2= 10
Sep 14 14:36:55 localhost dhclient: wifi0: unknown hardware address type 801
Sep 14 14:36:55 localhost dhclient: wifi0: unknown hardware address type 801
Sep 14 14:36:55 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Sep 14 14:37:03 localhost dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Sep 14 14:37:12 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
Sep 14 14:37:20 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
Sep 14 14:37:35 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
Sep 14 14:37:43 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
Sep 14 14:37:53 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 14
Sep 14 14:38:07 localhost dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
Sep 14 14:38:13 localhost dhclient: No DHCPOFFERS received.
Sep 14 14:38:13 localhost dhclient: Trying recorded lease 192.168.99.72
Sep 14 14:38:16 localhost kernel: airo: cmd= 2
Sep 14 14:38:16 localhost kernel: airo: status= 7f02
Sep 14 14:38:16 localhost kernel: airo: Rsp0= 0
Sep 14 14:38:16 localhost kernel: airo: Rsp1= ff10
Sep 14 14:38:16 localhost kernel: airo: Rsp2= 10
 
Old 09-14-2005, 05:11 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
If you are using an ascii key, you must prepend it with "s:".
 
Old 09-14-2005, 07:19 PM   #3
raindogs
LQ Newbie
 
Registered: Oct 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for the reply. I did enter the "s:" before the key, but the same errors happen. I should also note that I had this same problem on a network at a cafe that had an SSID but no encryption. It seems that I have something incorrect on some deeper level, but I'm left scracthing my head as to what that might be.




Quote:
Originally posted by Matir
If you are using an ascii key, you must prepend it with "s:".
 
Old 09-14-2005, 10:34 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Well, all networks have an SSID. Are you sure you have the right/proper driver?
 
Old 09-15-2005, 10:08 AM   #5
raindogs
LQ Newbie
 
Registered: Oct 2004
Posts: 9

Original Poster
Rep: Reputation: 0
I'm pretty sure I do, as it has worked before on networks that are open and insecure. Of course it's possible that I'm inadvertantly changed something, is there a way I can double check this? The selection in the GUI device setup does claim to be detecting the correct device.


Quote:
Originally posted by Matir
Well, all networks have an SSID. Are you sure you have the right/proper driver?
 
Old 09-15-2005, 10:30 AM   #6
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Just checking. Are eth0 and wifi0 the same device on your system?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connect to Wireless Network RySk8er30 Linux - Wireless Networking 8 11-19-2007 01:55 AM
not able to connect to secure sites with Squid 3.0 (Fedora) Khetho Linux - Enterprise 3 11-08-2005 09:53 PM
can't connect to my wireless network hedpe Linux - Wireless Networking 14 01-28-2005 02:47 PM
cannot connect to wireless network anartz Linux - Wireless Networking 13 10-27-2004 10:38 AM
how to secure your wireless network srenar Slackware 6 06-20-2004 07:55 PM


All times are GMT -5. The time now is 12:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration