LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 06-11-2006, 11:35 PM   #1
dsmits
LQ Newbie
 
Registered: Jun 2006
Location: Norfolk, VA
Posts: 3

Rep: Reputation: 0
Cannont change iwconfig/be recognized by AP


Ok, so here is the deal...
I have a WMP54GS Linksys card and am trying to connect to a Linksys router. Just to let you know I am a major newbie to all this so bare with me. I used the ndiswrapper program to make the drivers work and it detects the card fine and I am able to see my essid. The problem lies in connecting to my router. When I enter code: iwconfig wlan0 key restricted s:"my hexkey"
I get the message Error for wireless request "Set Encode" (8B2A)
SET failed on device wlan0 ; Invalid argument.

Also when I enter code: iwconfig wlan0 essid "my essid"
It acts as if it accepted the essid, but when I run code:
iwconfig
I still am displayed with ESSID: off/any
my Access Point is still showing up as Access Point: 00:00:00:00:00

I have even turned off WEP encryption completly and still cannot connect with it wide open. Its like it doesn't accept my changes to iwconfig. Keep in mind I am able to scan and see wireless networks, but I cannot connect to them. I also tried pinging my router and it doesn't work. It just keeps coming back with Network is unreachable. Anyways I would greatly appreaciate any advice. I'll try anything at this point. Be patient on my reply as I will be out of town until Friday, but keep the suggestions coming because I really want to be part of the linux community. Also I am using Knoppix 4.0 if that helps, and I used the latest drivers from linksys with the ndiswrapper.
 
Old 06-11-2006, 11:56 PM   #2
dsmits
LQ Newbie
 
Registered: Jun 2006
Location: Norfolk, VA
Posts: 3

Original Poster
Rep: Reputation: 0
ok, one quick update after reading another thread.
I changed my mode to Ad-Hoc and was able to set the essid, and in doing that the correct mac address for my AP showed up, however I still recieved the same error when trying to set my hex key. Then as soon as I switched mode back to auto the essid went right back to ESSID: off/any. Also, I am absolutly positive I am entering my hex key correctly. I have entered it like a million times.
 
Old 07-19-2006, 08:58 PM   #3
alexandr0s
LQ Newbie
 
Registered: Jul 2006
Posts: 1

Rep: Reputation: 0
same

I'm having the same problem. I just bought a wg111v2 usb adapter. I'm on the most recent slack and my iwconfig is being whack also. Changing the mode to helped me slightly, as in your case, and I am able to scan and find several networks in the area. However I cannot connect to a single AP. Bummer
 
Old 07-19-2006, 10:40 PM   #4
Knight Templar
LQ Newbie
 
Registered: Jul 2006
Posts: 20

Rep: Reputation: 0
why don't you use the GUI that comes with knoppix the easy set up , its plain easier if you are having problems

Last edited by Knight Templar; 07-19-2006 at 10:43 PM.
 
Old 07-20-2006, 06:03 AM   #5
dsmits
LQ Newbie
 
Registered: Jun 2006
Location: Norfolk, VA
Posts: 3

Original Poster
Rep: Reputation: 0
I'm having the same problem using the GUI interface, just thought it would be easier to explain through CLI
 
Old 08-11-2006, 04:17 PM   #6
Cool dude
LQ Newbie
 
Registered: Dec 2005
Posts: 10

Rep: Reputation: 0
Wmp54gs

dsmits,

Are you sure that you are entering your wep key correctly? It has to be letter perfect. You also have to be root to carry out this operation. Enter the Key like this, change to root: su root,
enter your root password ..... then enter iwconfig wlan(x) key (hex key) then press enter. The x after wlan is you wireless card allocation no.

Cd
 
  


Reply

Tags
broadcom, linksys, networking, wmp54gs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't change channel on NETGEAR Wireless Adaptor with iwconfig dr_zayus69 Linux - Hardware 1 12-25-2005 02:36 AM
FC3 cannont mount cdrom drive ZhiYi Fedora 1 06-28-2005 03:32 PM
Mencoder Cannont initalize video driver bratch Linux - Software 2 05-06-2005 05:07 PM
Cant change ESSID with iwconfig svenbox Linux - Hardware 1 04-27-2005 06:54 AM
eth0 recognized but not recognized? rafc Linux - Newbie 7 04-21-2004 05:13 AM


All times are GMT -5. The time now is 01:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration