LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-09-2007, 08:35 AM   #1
hjalmarreitz
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Rep: Reputation: 0
Question Can't get ndiswrapper to work with atheros AR5005G


Hi there, I'm trying to get my atheros to work on my toshiba laptop using ndiswrapper.
Using Suse 10.2, installed ndiswrapper from the same dvd
Wireless card: AR5005G
Kernel version: 2.6.18.2-34-default

I've installed ndiswrapper, installed the driver (net5211.inf)
Get the following response from these commands:

linux-suse:/Atheros/Driver # ndiswrapper -l
installed drivers:
net5211 driver installed, hardware (168C:001B) present

linux-suse:/Atheros/Driver # dmesg | grep ndiswrapper
ndiswrapper version 1.25 loaded (preempt=no,smp=yes)
ndiswrapper: driver net5211 (,09/13/2005,4.1.2.108) loaded
ndiswrapper (NdisMAllocateMapRegisters:855): invalid request: 256
ndiswrapper (NdisWriteErrorLogEntry:237): log: C000009A, count: 4, return_address: dd1a8244
ndiswrapper (NdisWriteErrorLogEntry:240): code: 3677087744
ndiswrapper (NdisWriteErrorLogEntry:240): code: 35
ndiswrapper (NdisWriteErrorLogEntry:240): code: 3669098496
ndiswrapper (NdisWriteErrorLogEntry:240): code: 3669098496
ndiswrapper (miniport_init:269): couldn't initialize device: C000009A
ndiswrapper (pnp_start_device:426): Windows driver couldn't initialize the device (C0000001)
ndiswrapper (miniport_halt:326): device db2be400 is not initialized - not halting
ndiswrapper: device eth%d removed
ndiswrapper: probe of 0000:02:04.0 failed with error -22
usbcore: registered new driver ndiswrapper

Can anyone give me a clue as to why I get the above error?
THANKS!!
 
Old 03-09-2007, 09:42 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,832

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
I'm not sure I can help with your question, however, I wondering why you are bothering with windbloze drivers when this card is supported by MadWiFi native linux drivers. See www.madwifi.org for a ton of information including the drivers. I would bet your distro has them available through package management.
 
Old 03-10-2007, 07:37 AM   #3
hjalmarreitz
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks man

Thanks my friend. I got the madwifi working to a point. Just struggling to join my secure wireless network. working on it though. I'm using the yast control program to set it up. Should I rather use the command line tools? Gonna give it a bash later again.

Thanks camorri
 
Old 03-10-2007, 08:51 AM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,832

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
Should I rather use the command line tools?
It is your choice, I'm not familiar with Yast, if it works, use it. Command line will work on any distro.

You are most welcome, glad I could help.
 
Old 03-10-2007, 05:24 PM   #5
hjalmarreitz
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Hi there, I'm back. Thought that was a bit too easy, :-)
I tried using network manager in yast with 101 different settings and no luck.
I also tried the command line tools.
I can scan and pick up my essid (name of my network), yet when I type in the following command as instructed it gives me this syntax error. I'm probably just being a prat and typed it wrong.
It's obviously working in the sense that it picks up networks in my area but I can't connect.
Can you help please. Thanks.

sonic@linux-suse:~> iwconfig key <xxxxxxxxxx>
bash: syntax error near unexpected token `newline'
sonic@linux-suse:~>



Also I tried re-installing madwifi, paying closer attention to the 'requirements' section.
It mentions I need to configure the kernel with the following options:

Kernel

* Linux Kernel 2.4.23+ and 2.6.x series
o Others may work, but are unsupported
* Kernel Source and Headers of running kernel
* No module versioning support
o option CONFIG_MODVERSIONS
* Wireless Extensions support in kernel
o v14+ required, v17+ recommended; option CONFIG_NET_RADIO
* Sysctl support in kernel
o option CONFIG_SYSCTL
* Crypto API support in kernel
o option CONFIG_CRYPTO
* HMAC support
o option CONFIG_CRYPTO_HMAC
* AES support (for WPA networks)
o option CONFIG_CRYPTO_AES


Where and how do I go about doing this?? I assume it's a file I must edit, where is it?

Thanks my friend.

Last edited by hjalmarreitz; 03-11-2007 at 06:18 AM.
 
Old 03-11-2007, 06:59 AM   #6
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,832

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Quote:
iwconfig key <xxxxxxxxxx>
You need to enter the interface name you are adding the key to. ie 'iwconfig ath0 key <xxxxxxxx>'
should work for if the wireless lan is named ath0, it could be named something other than ath0.

To scan for a WAP, try 'iwlist ath0 scan' ( without quotes ) and adjust the name of the interface to match your system.

After you have set up the wireless settings, check them by entering 'iwconfig' ath0' to see if they look right.

Then you need to set up IP address mask etc. These are set with 'ifconfig' Once those are correct, run 'ifconfig ath0 up' If things are configuring O.K. you will see another interface when you do a 'ifconfig', on my system it is called wifi0. It needs to be there, it is a virtual interface. MadWifi has an explanation why it is there.

Hope this gets you going.
 
Old 03-13-2007, 05:30 PM   #7
hjalmarreitz
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Nope, still not.

Hello. Sorry man, that wep key thing was my fault, I was actually using the symbols < > in the command: iwconfig ath0 key <xxx>.
Never the less, I still can't connect. Tried using DHCP>> dhclient ath0, and dhcpcd ath0. Neither worked.
Then also tried a static ip address with net mask and so on. Also specified which AP the system should use by this command: iwconfig ath0 ap <hex mac address> (something like that).
Also specified nameservers in /etc/resolv.conf.
Also tried connecting to my router without any security WEP/WPA.
I thought it might be a security setting since the command: iwlist (I think, more or less)
told me that I was using a 40bit WEP key. Which is not what it says on my router. My router says it's a 64bit WEP key. It's the same Hex key on both (router and laptop), yet there's this discrepency.

So far, I can enter my WEP key, I can scan for networks. Just can't connect. Hu? Tried just about everything.
You might not have read my previous relpy fully cause I edited it after it was posted.
Just want to check that the 'Requirements' of Madwifi are met.
If you refer back you'll see that I need to configure options in the kernel, how do I do this?

You'll be getting bored of me soon, I'm quite fed up already. Fun hey!!
Thanks Cliff
 
Old 03-14-2007, 12:37 PM   #8
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,832

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
I don't know your distro, but it seems various distros have different ways of getting an IP address with DHCP.

Quote:
Never the less, I still can't connect. Tried using DHCP>> dhclient ath0, and dhcpcd ath0. Neither worked.
Since the above didn't work, have you tried pump? It is a daemon for getting IP, DNS, default route... Try pump --help or man pump. If you have it installed, try

'pump -i ath0' to get an IP and go online. 'pump -i ath0 --status' will give you a few lines of configuration information.

From what I can see in your attempt to set a static IP address, you would need to specify a default route as well, use the route command to set a default route. The rest looks good.

Hope this helps.
 
Old 03-14-2007, 01:10 PM   #9
hjalmarreitz
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
I'll try that.

Thanks Cliff I'll try the pump thing. Maybe I should 'pump' some money into it and get another network card :-)
My distro is openSuse 10.2
 
Old 03-14-2007, 01:45 PM   #10
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,832

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
If it is an Antheros chip set, they are good cards. OpenSuse, no reason to believe this is part of the problem, outside of configuration.

I helped another person with a wifi problem, 54 posts later the user discovered an issue the to do with a boot option, if I can remember it had to do with polling. Don't want to scare you off... that was reality.
 
Old 03-15-2007, 09:30 AM   #11
hjalmarreitz
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Man that's nuts. How difficult is this allowed to get?
I agree that this is probably a config issue.
The card works, madwifi and the card are working together, how else can I pick up networks in the area.

Anyway, config, I still need to check those Kernel options. (hint hint, nudge nudge)

Any other websites I can check as well?

Thanks for your help so far Cliff.
 
Old 03-15-2007, 09:32 AM   #12
hjalmarreitz
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Forgot, that pump command doesn't work on my distro, unless I can download it from some where. Although I'm sure it's not going to help. I do get feedback from the dhlcient command, it just can't connect to the AP. Hence config problem somewhere...
 
Old 03-29-2007, 09:52 PM   #13
j0sh0
LQ Newbie
 
Registered: Mar 2007
Posts: 1

Rep: Reputation: 0
atheros chips

not sure if it applies to your card/chip, but on mine, I have to set
"sudo iwpriv ath0 authmode 2"
to connect to my WEP shared network.
it's worth a try!
 
Old 04-01-2007, 08:45 AM   #14
hjalmarreitz
LQ Newbie
 
Registered: Mar 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks Josh

I think I've tried that, yet I've tried it again for what it's worth. Not working. Quite frankly I give up. I can't be asked to piss about with the stupid thing any longer. I'll just use the good old cable...!

Thanks for all your help guys.

Regards
Hjalmar
 
Old 05-12-2007, 09:56 PM   #15
mickwi
LQ Newbie
 
Registered: May 2007
Location: Uppsala, Sweden
Distribution: Ubuntu 7.04 AMD_64, Slackware 11
Posts: 3

Rep: Reputation: 0
I have the same card, and also use madwifi. Got it to work, but not flawlessly. I can only connect if the router uses WEP, it doesn't work with WPA or WPA2. But just as you say, I can see all networks in the area.

It's also a bit buggy sometimes and refuses to connect at all for a couple of minutes, but otherwise it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
madwifi/ndiswrapper on Atheros AR5004G biggjimmy7 Linux - Wireless Networking 7 01-05-2008 12:11 PM
Help with Slackware not detecting Atheros AR5005G wireless adapter TonyJephson Slackware 6 12-23-2006 08:37 AM
fc5 madwifi atheros ar5005g wireless network mike_morley Linux - Wireless Networking 0 10-27-2006 04:08 PM
How to install Wifi Card Atheros ar5005G on Ubuntu? andresmilleiro Linux - Hardware 2 08-26-2006 10:41 AM
Atheros AR5004G and madwifi/ndiswrapper biggjimmy7 Linux - Wireless Networking 1 05-03-2005 02:17 PM


All times are GMT -5. The time now is 07:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration