LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-18-2007, 06:39 PM   #1
pauls69p
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
Can't find a GUI to configure wireless in CentOS 5


I recently posted a challenge with Broadcom wireless on an HP computer. I had the opportunity to exchange the computer for a Toshiba with an Atheros card. I was able to get the machine to recognize the wireless card using madwifi. The challenge I have now is actually configuring and using the wireless. The system sees the card but will not activate it because it is not configured... I have gone through the gui but cannot find a place to set the SSId, Wep Key, etc. I have looked under System, Administratin, Network. It only has options to set IRQ, DMA, etc. I am running CentOS 5 and it is completely updated. Anyone have any thoughts? I have read online about Network Manager but cannot seem to install it with yum. I would be ok with manually configuring it through a shell but cannot seem to get that going either trying to use iwconfig. Any help is much appreciated.
 
Old 04-19-2007, 06:24 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Just create a file in /etc/sysconfig/network-scripts named something like ifcfg-wifi0 and another called keys-wifi0 for your WEP key. Examples below;
ifcfg-wifi0 file;

TYPE=Wireless
DEVICE=wifi0
HWADDR=
BOOTPROTO=dhcp
IPADDR=
NETMASK=255.255.255.0
GATEWAY=
DHCP_HOSTNAME=MyCoumpterNameHereIfDesired
DOMAIN=
ONBOOT=yes
ONHOTPLUG=yes
USERCTL=yes
IPV6INIT=no
PEERDNS=no
ESSID=MyRoutersSSID
CHANNEL=X

keys-wifi0 file;
KEY=<some HEX number here>

or

KEY=s:<some ascii string here>

Also make sure that the wireless device has a line entry in /etc/modpobe.conf like;
alias wifi0 madwifi

Then restart the network service as root: service network restart

Use the typed command 'iwlist wifi0 scan' minus the single quoutemarks to find out things like which CHANNEL (see the ifcfg-wifi0 example) to use, example;

Code:
wlan0     Scan completed :
          Cell 01 - Address: 00:0A:E9:09:EC:60
                    ESSID:"MyRouter"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.422 GHz (Channel 3)
                    Quality:81/100  Signal level:-44 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
                              11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=1000
                    Extra:atim=0
It is betyer to start with WEP off until you get your connection the first time.

Try using the Network GUI (system-config-network) if you cannot find it in the menu then open a terminal as root and type: system-config-network

If you get no response then check if the package is installed or not;

rpm -qa system-config-network
 
Old 07-05-2011, 10:45 PM   #3
richardbaxter
LQ Newbie
 
Registered: May 2008
Posts: 5

Rep: Reputation: 1
This seemed to work;

gedit /etc/sysconfig/hwconf
search for the reference to "wlan0", and find the name of the deviceId
su root
cd /sbin
modprobe wirelessDeviceIdName
./chkconfig network off
./chkconfig wpa_supplicant off
./chkconfig NetworkManager on
./service NetworkManager start
 
  


Reply

Tags
atheros, gui, madwifi, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS -- problem installing dvipng -- error: cannot find/use libpng oakami Linux - Software 1 03-29-2007 10:11 AM
eth0 hangs GUI Centos 4.4 x86_64 on ASUS A8N-M Chebi Linux - Newbie 0 03-07-2007 12:20 PM
Linux (CentOS) and Atheros Wireless Driver nentendo Linux - Newbie 33 08-28-2006 12:43 AM
how to configure CentOS as internet server? czarjohnph Linux - Networking 2 01-16-2006 12:29 AM
cannot find dependent files for Mplayer for CentOS-3(redhat el-3?) rolandkirk55 Linux - Software 1 08-15-2004 08:41 AM


All times are GMT -5. The time now is 06:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration