LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-05-2004, 08:53 AM   #1
baters
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.0 Pro
Posts: 6

Rep: Reputation: 0
Can't connect to wireless network when SSID broadcast is disabled, Atheros card/SuSE9


I am trying to get my Toshiba A4 Satellite Notebook to connect to my wireless network under SuSE 9.0 Pro with an Atheros AR5001X+ built-in wireless card.

I was able to connect to the wireless network with no problems when I broadcast the network's SSID from my router/access point, but I cannot connect if I disable SSID broadcast. I am able to connect to the network under Windows.

KWifiManager is not showing any signal, is there something I need to add to the wlan0 configuration file in order to be able to connect? It's not a huge deal, I just don't think I need to broadcast my SSID given I'm the only user in a small home network. If anyone has any suggestions as to how I can get around this problem, I'd appreciate any help you can provide. I'm fairly new to Linux so the more detail, the better.

Thanks,

Clay
 
Old 05-05-2004, 11:48 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,781
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Are you setting your essid with the iwconfig comman?


iwconfig wlan0 essid youressidhere

If you are using WEP you can similarly add the WEP key:

iwconfig wlan0 key WEPkeyvalue
 
Old 05-06-2004, 07:08 AM   #3
baters
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.0 Pro
Posts: 6

Original Poster
Rep: Reputation: 0
I set the essid and the WEP key through the YaST configuration manager. Here's what the ifcfg-wlan0 config file looks like:

BOOTPROTO='dhcp'
BROADCAST='192.168.0.255'
IPADDR='192.168.0.110'
MTU=''
NETMASK='255.255.255.0'
NETWORK='192.168.0.0'
REMOTE_IPADDR=''
STARTMODE='onboot'
DHCLIENT_MODIFY_RESOLV_CONF='yes'
DHCLIENT_SET_DEFAULT_ROUTE='yes'
UNIQUE='ul7N.tUUwRYkMFJ2'
WIRELESS_ESSID='xxxxxxxx'
WIRELESS_KEY='xxxxxxxxxx'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''

I'm not sure what the problem is, as I've mentioned these wireless settings work great if I have SSID broadcast enabled from my router. As soon as I disable it, I lose the connection.
 
Old 05-06-2004, 07:35 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,781
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Well, that looks OK. Just out of curiosity, if you run iwconfig without parameters, can you see that wlan0 has the correct parameters?

If it does, maybe the problem is with your router. Is it possible that by turning off the SSID broadcast, the router also turns off wireless completely? Do you have another way to check that the router is working correctly if the SSID broadcast is turned off?
 
Old 05-06-2004, 07:49 AM   #5
baters
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.0 Pro
Posts: 6

Original Poster
Rep: Reputation: 0
The router works correctly with SSID broadcast off when I boot Windows, I can connect with no problems.
 
Old 05-06-2004, 08:10 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,781
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Well, that rules out a router problem. Can you post the output of iwconfig?
 
Old 05-06-2004, 08:31 AM   #7
baters
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.0 Pro
Posts: 6

Original Poster
Rep: Reputation: 0
Here's the output of iwconfig when SSID broadcast is enabled:

wlan0 IEEE 802.11 ESSID:"xxxxxxxx" Nickname:"linux"
Mode:Managed Frequency:2.437GHz
Access Point: 00:80:C8:15:6C:6D
Bit Rate:54Mb/s Tx-Power:off Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:xxxx-xxxx-xx Security mode:open
Power Management:off
Link Quality:37/94 Signal level:-58 dBm Noise level:-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Here's what it is when SSID is disabled:

wlan0 IEEE 802.11 ESSID:"xxxxxxx" Nickname:"linux"
Mode:Managed Frequency:2.417GHz
Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:1Mb/s Tx-Power:off Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Encryption key:xxxx-xxxx-xx Security mode:open
Power Management:off
Link Quality:0/94 Signal level:-95 dBm Noise level:-95 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
 
Old 05-07-2004, 07:26 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,781
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
I'm going to admit that I'm very confused by this. My understanding is that an SSID broadcast is not required if you supply the SSID via another method, which you are doing. Obivously your card hasn't forgotten its ESSID setting or WEP key (at least I'm assuming the info you masked out hasn't changed). What does disturb me a bit is the change in access point MAC address. That (along with some of the other connection info) definitely says that your card has lost track of the access point.

Here are a few things I'd try if I were in your shoes, but I am fishing at this point:

1) If you haven't already, try booting when the SSID broadcast is already off.

2) Check the output of ifconifg both with SSID broadcast on and off

3) Check the output of route -n and see if anything there changes

4) Try pinging the IP address of your access point with SSID on and off.


If anyone else has any ideas, please chime in.

<edit>
You might also check the contents of your syslog and messages file in /var/log and see if anything there can shed some light on what is happening.
</edit/>

Last edited by Hangdog42; 05-07-2004 at 07:28 AM.
 
Old 05-07-2004, 10:12 AM   #9
baters
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.0 Pro
Posts: 6

Original Poster
Rep: Reputation: 0
I've tried just about everything I can think of with my limited knowledge of Linux to get this to work.

Booting when the SSID broadcast is off doesn't let me connect. I can't ping the router and route -n produces this:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface

If I turn SSID broadcast on, I can ping the router and route -n gives me this:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 wlan

Now, here's the confusing part. I can boot with SSID broadcast enabled, then turn the broadcast off from the machine wired to the router and still be able to connect through my wireless laptop. If I shut down or reboot and try to connect again with SSID broadcast off, I am unable to. If I try to enable SSID broadcast from the wired machine after I've already booted my wireless machine, I still can't connect. I can't ping the router and the access point is showing up as having no signal in Kwifimanager and when I try iwconfig wlan0 with no parameters.

Thanks for your help thus, any other suggestions?
 
Old 05-07-2004, 12:02 PM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,781
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Do you have WEP enabled?

The reason I'm asking is this:
Quote:
Now, here's the confusing part. I can boot with SSID broadcast enabled, then turn the broadcast off from the machine wired to the router and still be able to connect through my wireless laptop. If I shut down or reboot and try to connect again with SSID broadcast off, I am unable to.
This makes some sense IF you don't have WEP enabled AND dhcp is asking for an IP address before your card is configured.

One way to test this would be to boot linux with SSID broadcast disabled and then issue a dhcpcd wlan0 from a console.

I would also do a little rummaging around in the log files and see if there are any messages from the failures. That could be very illuminating.
 
Old 05-07-2004, 12:31 PM   #11
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
This is not the answer you want, but ...

You can't really turn off the SSID broadcast. The AP has to respond to clients that probe it in an attempt to connect or no one can connect. The "disable SSID broadcast" only turns off the regular beaconing of the SSID. From a practical perspective, then, disabling the beacon provides no real security benefit (the most oft-used rationale for disabling). While NetStumbler might not see it, your AP will be visible to someone using Kismet or similar tools. It could reasonably be argued that someone using the more sophisticated scanner is more of a threat than the NS guy.

Some hardware seems to be more susceptible than other to connection problems when the beacon is off. Since connection under that scenario is not part of the "spec," the h/w vendors probably don't spend much time trying to fix it. FWIW, most of the posts I've read about broadcast disabled connection problems are with XP configurations. It's interesting that you situation is reversed.

I wonder if running Ethereal would tell you anything more about the underlying mechanism and what's not working. Again, sorry if this is off the track. Stealth is an understandable goal, but you won't accomplish it by turning off the beacon.
 
Old 05-07-2004, 01:16 PM   #12
baters
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.0 Pro
Posts: 6

Original Poster
Rep: Reputation: 0
All I was really trying to accomplish by turning of the SSID broadcast was to gain a little bit of security, it worked fine under Windows so i assumed it wouldn't be a problem under Linux. I know it's not going to make that much a difference if someone really wants to gain access to my network, i just thought it might help deter that kind of activity.

I have WEP enabled and these are the only messages i can see in var/log/ that might shed any light on this:

When SSID broadcast disabled:
linux kernel: wlan0: no IPv6 routers present
linux dhcpcd[2434]: timed out waiting for a valid DHCP server response
May 7 14:26:14 linux dhcpcd[933]: recvfrom: Network is down

With SSID broadcast enabled:
linux kernel: wlan0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
May 7 10:03:39 linux kernel: wlan0: 802.11 address: 00:90:96:82:96:76
May 7 10:03:39 linux kernel: wlan0: Atheros 5212: mem=0xcfff0000, irq=11

If there's no easy solution to this, it's not that big a deal.
 
Old 05-07-2004, 01:36 PM   #13
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,781
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
The only other thing I can think of is to set the SSID on your linux box to any. I think that disables SSID checking by the card. Other than that, I'm out of ideas.
 
Old 01-29-2005, 11:34 PM   #14
cheapuser
LQ Newbie
 
Registered: Jan 2005
Posts: 2

Rep: Reputation: 0
Question same prob: no connection when broadcast ssid disabled

I have same issue:
System config:
SuSE 9.2 on Dell Lattitude C610
Netgear WG511T PCMCIA wireless card
Software, all from instalation (madwifi driver, wpa supplicant, kwifimanager)
Configured using Yast
Noteworthy: Yast does not check for wpa supplicant even when wpa configured, wpa is not installed by default nor kwifimanager (i would expect the later, but not wpa supplicant missing and Yast not complaining, too a while to debug)

Problem:
Wireless connection breaks down when route has SSID broadcast disabled
If SSID broadcast is enabled all is fine (Windows works fine with both enabled & disabled SSID broadcast)

Note that kwifimanager does sniff the router even though net connection for apps (e.g. web browser) is severed.

Any suggestions? Is the problem with madwifi, wpa supplicant or something else in SuSe 9.2

I was very pleased how everything worked out of the ftp box, but would love to hide SSID. (can not say same for FC3 which i gave up on)

Also, can anyone recommend a utility that would scan SSIDs and allow me to configure "allwoable" network connections and their WEP or WPA profiles? Same as the utility that comes from Netgear for Windows? kwifimanager scans SSIDs but is not aware of WPA keys.

As an old returning Unix (Ultrix & SunOS) user who has been absent from Unix world for over a decade i love what people have done with Linux, but, the decentralization also has it quirks... experts are not all in one building

thanks in advance,
cheapuser
 
Old 01-30-2005, 12:34 AM   #15
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
baters,

Did you notice this difference from your post when broadcast is enabled/disabled:

[quote]
Mode:Managed Frequency:2.437GHz
...
Mode:Managed Frequency:2.417GHz
[\quote]

It would appear that you need to specify the channel since it's found differently with a broadcast/not broadcast, as they are different (above) and perhaps also employ iwconfig's "ap" param, as in: iwconfig <dev> ap xx:xx:xx:xx:xx:xx.

Also, as an exercise, you may want to fire up kismet and see how much "security" a non-broadcasted ssid gives you, IMO, not much, the MAC of your ap is still easily discerned.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
intel wireless pro 2200 detected as atheros wireless card? whf Suse/Novell 5 08-29-2005 06:04 PM
SuSE 9.2 wireless connection loss when SSID broadcast disabled on router cheapuser Suse/Novell 0 01-30-2005 12:03 AM
Wireless Network SSID? jeopardyracing Linux - Newbie 3 09-19-2004 12:13 PM
Turning off ssid broadcast laclac01 Linux - Wireless Networking 2 04-26-2004 09:48 AM
WPC11 v4 - SSID broadcast - hiddenAP=true Lasse_tj Linux - Wireless Networking 4 02-25-2004 08:04 PM


All times are GMT -5. The time now is 05:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration