LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-25-2009, 11:20 PM   #1
dpeterson3
Member
 
Registered: Jun 2008
Distribution: Debian
Posts: 157

Rep: Reputation: 16
Can't connect to encrypted networks Lenny


I am on vacation and can't connect to any encrypted networks. Every time I put in a key my machine gives me a message saying "aquiring key from network" and then asks me for a key again. I happen to have my own router with me. Works fine with the key I use at home, but it can' connect to any other encrypted networks. All of them have been WEP encrypted. It can connect to open AP's no problem. I think it might be trying to use my home key for other networks.

BTW using nm-applet on Lenny.
 
Old 07-26-2009, 12:59 AM   #2
sparc86
Member
 
Registered: Jul 2006
Location: Nuremberg, Germany
Distribution: Debian, Gentoo
Posts: 294
Blog Entries: 1

Rep: Reputation: 31
Have you ever tried WICD? It works pretty well here.

Lightweight, functional and very easy to use.
 
Old 07-27-2009, 05:40 PM   #3
dpeterson3
Member
 
Registered: Jun 2008
Distribution: Debian
Posts: 157

Original Poster
Rep: Reputation: 16
I might try that. I am not sure it is my network manager, though. I can't even get ifconfig to work on my LAN card.
 
Old 07-27-2009, 06:00 PM   #4
sparc86
Member
 
Registered: Jul 2006
Location: Nuremberg, Germany
Distribution: Debian, Gentoo
Posts: 294
Blog Entries: 1

Rep: Reputation: 31
Could you please show us your iwconfig output when you try to connect to this network?

Quote:
#iwconfig
 
Old 08-02-2009, 06:03 PM   #5
dpeterson3
Member
 
Registered: Jun 2008
Distribution: Debian
Posts: 157

Original Poster
Rep: Reputation: 16
Would love to if I could. We are home now so I don't have another network to try at the moment. I will have to wait until I go to a friend's house and try their network. Here at home the output is
Code:
$ iwconfig
eth1      IEEE 802.11g  ESSID:"phome"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:1E:E5:6F:86:77   
          Bit Rate:36 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:FCD5-2A44-1092-CBD6-D46D-470C-6AA9-D67D-E89E-9C0E-EA37-1516-F216-CC96-FD7D-57BD   Security mode:open
          Power Management:off
          Link Quality=73/100  Signal level=-55 dBm  Noise level=-90 dBm
          Rx invalid nwid:0  Rx invalid crypt:2  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:0   Missed beacon:0
 
Old 08-03-2009, 12:43 AM   #6
sparc86
Member
 
Registered: Jul 2006
Location: Nuremberg, Germany
Distribution: Debian, Gentoo
Posts: 294
Blog Entries: 1

Rep: Reputation: 31
At home you have WEP encryption and at your friend's house WEP as well?
 
Old 08-03-2009, 08:02 AM   #7
dpeterson3
Member
 
Registered: Jun 2008
Distribution: Debian
Posts: 157

Original Poster
Rep: Reputation: 16
Sorry. I guess I didn't mention it. I use WPA at home. Every hotel we stayed at on vacation used WEP. I also have friends that use WEP. I will try one of their networks and see what happens. I also have a second router I can configure as WEP and see what happens.
 
Old 08-03-2009, 12:22 PM   #8
sparc86
Member
 
Registered: Jul 2006
Location: Nuremberg, Germany
Distribution: Debian, Gentoo
Posts: 294
Blog Entries: 1

Rep: Reputation: 31
Yes, do it, then see what happens and tell us here, I'm pretty curious about this problem...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Creating A Fully Encrypted Para-Virtualised Xen Guest System Using Debian Lenny LXer Syndicated Linux News 0 05-03-2009 10:20 AM
Why ist wicd doing its job on encrypted networks ??? delta function Slackware 3 02-14-2009 03:35 AM
Can't Connect to any Encrypted Wireless Networks markackerman8@gmail. Linux - Newbie 3 07-13-2008 12:52 PM
Can see networks, but cannot connect Shaggy1054 Linux - Wireless Networking 2 06-11-2008 12:14 PM
Wireless card fails to connect to encrypted networks rhathar Linux - Wireless Networking 4 02-29-2008 11:44 PM


All times are GMT -5. The time now is 01:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration