LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 11-15-2005, 12:06 PM   #1
nelamvr6
Member
 
Registered: Oct 2005
Location: New London, CT USA
Distribution: Ubuntu 7.04
Posts: 49

Rep: Reputation: 15
Can't connect if wired & wireless both installed


I'm havening a weird problem. I'm using SuSE 10.0 on a Sager notebook with w built in Realtek NIC and an Intersil/Prism wireless.

If both the wired and wireless interfaces are enabled and configured I can access local addresses on my LAN, but I cannot connect to the Internet.

If I go into Yast and delete the wireless (so it is listed as "not configured") I can then connect to both the LAN and the Internet.

Here is a snip it from the startup log with both interfaces enabled:

Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8
done eth0 device: Intersil Corporation Intersil ISL3890 [Prism GT/Prism Duette] (rev 01)
eth0 configuration: wlan-id-00:90:4b:2b:7d:ff
eth0 (DHCP) . . . . . <notice>checkproc: /opt/kde3/bin/kdm 5128
<notice>killproc: kill(5076,15)
no IP address yet... backgrounding.
waiting
eth1 device: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
eth1 configuration: eth-id-00:90:f5:27:08:d3
<notice>checkproc: /sbin/dhcpcd 5051
eth1 (DHCP) . IP/Netmask: 192.168.1.103 / 255.255.255.0
doneWaiting for mandatory devices: wlan-id-00:90:4b:2b:7d:ff
12 11 10 8 7 6 4 2 1
eth0 interface could not be set up
failedSetting up service network . . . . . . . . . . . . . . . .failed


Here is the log entry with the wireless not configured:

Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8
done eth0 device: Intersil Corporation Intersil ISL3890 [Prism GT/Prism Duette] (rev 01)
eth0 No configuration found for eth0
unused eth1 device: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)
eth1 configuration: eth-id-00:90:f5:27:08:d3
eth1 (DHCP) . IP/Netmask: 192.168.1.103 / 255.255.255.0
doneSetting up service network . . . . . . . . . . . . . . . .done

I noticed that either way the wired card is assigned the same IP address by the router, but I can connect only with the wireless card disabled.

Please help!

Thanks in advance!
 
Old 11-16-2005, 09:10 PM   #2
WRSpithead
Member
 
Registered: Mar 2005
Posts: 60

Rep: Reputation: 15
are both devices going to the same router? if so, you're going to run into some routing issues.
 
Old 11-17-2005, 07:51 PM   #3
Belfegor
LQ Newbie
 
Registered: Oct 2004
Location: Lavra-Portugal
Distribution: SuSE 9.1 pro
Posts: 4

Rep: Reputation: 0
Same Problem

I have an Acer 291LMI, and i'm facing the same problem. Hope someone can help us. Thanks in advance
 
Old 11-17-2005, 08:25 PM   #4
WRSpithead
Member
 
Registered: Mar 2005
Posts: 60

Rep: Reputation: 15
you can't have your default gateway going through two devices. try this:
Code:
route | grep default
How many results come up? If there is more than one and they have different Ifaces, that's gonna be a problem.

Also, chances are your wireless card isn't going to be recognized by YaST. You're just gonna have to get your hands dirty and use either a native driver or ndiswrapper to set it up. Search the web for what you need to do for that specific card.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Sarge Wired & Wireless Network configuration yoonsangkyun Linux - Wireless Networking 2 03-28-2005 07:59 PM
Wireless Laptop to Wired ethernet via Linux PC (wired/wireless) sambartle Linux - Wireless Networking 0 01-30-2005 04:37 AM
wired & wireless different subnets rickenbacherus Linux - Wireless Networking 2 11-10-2004 06:45 AM
Wired to Wireless back to Wired The_Nerd Linux - Hardware 5 09-15-2004 09:20 PM
Cannot connect to internet via wired adapter psycovic23 Linux - Networking 1 06-05-2004 09:17 AM


All times are GMT -5. The time now is 11:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration