LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 07-09-2004, 06:05 AM   #1
peekho
LQ Newbie
 
Registered: Jul 2004
Location: San Diego
Distribution: Slackware 10.0
Posts: 13

Rep: Reputation: 0
built-in wlan NIC problem


Okay guys,
I'm totally new to Linux but decided to jump in the deep end. Here's my problem: I got an eMachines laptop M5312 it uses a built in wireless card from Broadcom. I installed Slackware 10.0 in a dual boot with XP. Surprisingly, the install went great and I managed to get KDE running and everything works fine. The only prolem is I don't know how to set up my wireless net connection. I used pretty much all defaults on the install so I think I am using the 2.4.26 kernel. If this is just a totally stupid question please point me to a beginners guide. Oh yeah I'm trying to connect to a Linksys wrt54g router/AP. I'm pretty sure my problem is with the drivers though. Any help is greatly appreciated. Oops, probably shoulda posted this in the newbie section, feel free to move it.

Last edited by peekho; 07-09-2004 at 06:07 AM.
 
Old 07-09-2004, 08:40 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Welcome to the deep end.........

Broadcom is one of the lovely companies that refuses to release linux drivers, however there are a couple alternatives that let you use the Windows drivers for most Broadcom chipsets. They are linuxant , which has a commercial product (free for 30 days) and ndiswrapper which is open source. I've used ndiswrapper with a Broadcom card and not had any difficultly, but others have had extreme difficulty. At least with ndiswrapper the INSTALL file actually has very good step-by-step instructions.

If you're working from the stock Slackware kernels, you should be OK, however you'll have to install the kernel source code if you haven't already done so.
 
Old 07-09-2004, 06:38 PM   #3
peekho
LQ Newbie
 
Registered: Jul 2004
Location: San Diego
Distribution: Slackware 10.0
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks for the help

Okay, here's another newbie question, will my builtin wireless NIC show up as a PCI device, PCMCIA or something else?
 
Old 07-10-2004, 08:31 AM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I'd guess that it will show up as a PCI device. If you run lspci you'll probably see it.
 
Old 07-10-2004, 08:12 PM   #5
peekho
LQ Newbie
 
Registered: Jul 2004
Location: San Diego
Distribution: Slackware 10.0
Posts: 13

Original Poster
Rep: Reputation: 0
Thx a lot for your help Hangdog42,
I've almost got the wireless fully set up. I've managed to get the ndiswrapper working and my wireless seems to be working. When I run Kwifimanager, it shows a 54MBit/s speed and a signal strength of 92. The only thing is, I can't seem to ping or connect to any other computer. It does say AccessPoint: UNKNOWN but I'm getting a Connected to Network: MYSSID, I don't quite understand???

Last edited by peekho; 07-10-2004 at 08:13 PM.
 
Old 07-11-2004, 07:57 AM   #6
stuart
Member
 
Registered: Jun 2004
Location: aussie in germany
Distribution: mandrake 10 powerpack
Posts: 104

Rep: Reputation: 15
this probably wont help you much but i just got my broadcom card setup using ndiswrapper also but my card connects to everything and i can ping other machines, however in Kwifimanager i also get "AccessPoint: UNKNOWN" even though it shows " Connected to Network: MYSSID"

Does your card show an ip in Kwifimanager??

Does your AP use DHCP?

it seems you are pretty close to getting this to work
 
Old 07-11-2004, 09:11 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I think stuart is on the right track. If the kwifimanager isn't helping, try opening a console and posting the output of ifconfig and iwconfig.
 
Old 07-11-2004, 09:18 AM   #8
stuart
Member
 
Registered: Jun 2004
Location: aussie in germany
Distribution: mandrake 10 powerpack
Posts: 104

Rep: Reputation: 15
I'm on mandrake 10 also, since you said your a noob like me then you need to logged in as root to run iwconfig, and you need to have wireless tools installed for it to be there.
(these are probs i had when trying to do this
 
Old 07-15-2004, 12:47 AM   #9
peekho
LQ Newbie
 
Registered: Jul 2004
Location: San Diego
Distribution: Slackware 10.0
Posts: 13

Original Poster
Rep: Reputation: 0
SUCCESS!

Well, after I tried to the install of ndiswrapper about ten times, I realized that the problem was a simple 'ID10T' error. In other words, I wasn't following the instructions exactly. I was doing the make command in the wrong directory . Funny thing is, even though I didn't do it right I could still see "connected to network: "myssid" but I couldn't ping. When I finally did get the install right, I had to learn a lot about iwconfig and ifconfig . Once I was certain I had these set up correctly, I could finally ping the router, but not the world outside my network . I knew the problem was that I hadn't set my default gateway, so I learned about 'route add default gw <addr> wlan0' another personal victory. Well, I was almost there, all I needed was name resolution, this was when I learned about '/etc/resolve.conf'. So I got it working and I'm actually sending this post wirelessly . Only a few more things to do, I can't figure out how to get these network settings to be persistent after shutdown. The instructions in the ndiswrapper install doc didn't seem to work for me; namely the part where we create and alias:
bash-2.05b# alias wlan0 ndiswrapper
bash: alias: wlan0: not found
bash: alias: ndiswrapper: not found
bash-2.05b#

I am logged in as root and the device is wlan0

After I solve this problem, all that is left is configuring my touchpad to use the scroll bar and maybe looking into the power management features (I think my laptop runs hotter when I run Linux than when I run XP). I'd like to thank those of you who helped me in this thread and some of the archived were valuable as well. Hopefully I won't be such a for long.
 
Old 07-15-2004, 08:18 AM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
I can't figure out how to get these network settings to be persistent after shutdown.
That one's pretty easy. All you have to do is edit your /etc/rc.d/rc.local file and enter all the commands you normally use to set up your card and get it running. The rc.local script is run at the end of every boot, so your card should be up and running every time.

Quote:
namely the part where we create and alias:
This isn't a keyboard command. If you look closely at the INSTALL file, you'll see you're actually editing your /etc/modules.conf file. The easiest way to deal with this is run ndiswrapper -m. That makes all the alias changes for you.

Congrats on getting your wireless up and running....No small feat. And don't worry, even after using linux for a couple of years there are still plenty of times I feel like a .
 
Old 07-15-2004, 08:38 PM   #11
peekho
LQ Newbie
 
Registered: Jul 2004
Location: San Diego
Distribution: Slackware 10.0
Posts: 13

Original Poster
Rep: Reputation: 0
I edited the rc.local file but I don't think the commands executed. I don't have any scripting experience at all. The way I did it was to simply put in the commands just as I enter them in the command prompt, here's what it looks like:
#!/bin/sh
#
# /etc/rc.d/rc.local: Local system initialization script.
#
# Put any local setup commands in here:
modprobe ndiswrapper
/usr/sbin/loadndiswrapper 14e4 4320 /lib/windrivers/bcmwl5.inf /lib/windrivers/bcmwl5.sys
iwconfig wlan0 mode managed
iwconfig wlan0 essid myssid key restricted keyinhex
ifconfig wlan0 up
ifconfig wlan0 192.168.1.68 netmask 255.255.255.0 broadcast 192.168.1.255
route add default gw 192.168.1.100 wlan0


I think I might need to add the # symbol to each line but i'm not sure. Thanks again for your help HangDog42.
 
Old 07-15-2004, 10:49 PM   #12
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
I think I might need to add the # symbol to each line but i'm not sure
The answer to that would be no. The # is used for comments, so if you DON'T want a command to run, put the # in front of the line. Similarly if you want to add notes for yourself, start the line with a # and bash will ignore the line.

Quote:
/usr/sbin/loadndiswrapper 14e4 4320 /lib/windrivers/bcmwl5.inf /lib/windrivers/bcmwl5.sys
Can I ask what version of ndiswrapper you are using? That command hasn't been needed since about 0.4.

The other thing you may need to do is use the full path to commands. So instead of iwconfig, you may need to use /sbin/iwconfig. The same would go for ifconfig and route.

Here is the script I use to start up my card:
Code:
#!/bin/sh
   #
   # rc.wlan0
   #

   #CHANNEL=_
   ESSID="MyESSID"
   INTERFACE="wlan0"
   KEY="MyKey"
   MODE="Managed"

   #Load the module
   echo "Loading NDISWRAPPER"
   /sbin/modprobe ndiswrapper

   # Set up the WiFi card

   echo "Configuring ${INTERFACE}:"
   /sbin/iwconfig ${INTERFACE} essid ${ESSID}
   #/usr/sbin/iwconfig ${INTERFACE} channel ${CHANNEL}
   /sbin/iwconfig ${INTERFACE} mode ${MODE}
   /sbin/iwconfig ${INTERFACE} key ${KEY}

   # Get IP address from dhcp

   /sbin/dhcpcd -t 10 -d wlan0

   # Bring up interface - I'm not sure if this is necessary, 
   # but it doesn't hurt

   ifconfig wlan0 up
 
Old 07-15-2004, 11:22 PM   #13
peekho
LQ Newbie
 
Registered: Jul 2004
Location: San Diego
Distribution: Slackware 10.0
Posts: 13

Original Poster
Rep: Reputation: 0
Actually I am using the 0.4 version, I read on a site that the 0.5 through 0.7 version didn't work for eMachines m5312. I did notice that the 0.8 version is out but I thought I'd play it safe and use what someone had previously gotten to work on my laptop. Also, I noticed that you don't use the entire path ( /usr/sbin/[command]) but you use /sbin/[command]. Is the /usr unnecessary in the path? I will try to put the path in and see if it works. Thanks again for pointing me in the right direction.
 
Old 07-16-2004, 08:27 AM   #14
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I based my paths on the output of the which command. So I would type which iwconfig and use that path.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
asus built in NIC Rammstein666 Linux - Hardware 7 11-27-2005 09:31 PM
WLAN Problem Truemobile 1300 WLAN on Debian 3 with NDISWRAPPER FordPrefect Linux - Laptop and Netbook 2 08-08-2005 11:00 AM
RH9 built-in NIC probelm...please help!! faruquehabib Red Hat 5 02-16-2004 10:36 AM
NIC w/ built-in hub -> cable modem + LAN ? TedMaul Linux - Networking 3 01-21-2004 11:16 AM
NIC to use with wlan-ng and M9.2 ?? dlocalized Linux - Wireless Networking 5 01-11-2004 08:23 PM


All times are GMT -5. The time now is 01:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration