LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-15-2010, 01:07 AM   #31
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,541
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176

Quote:
Originally Posted by woodmaster View Post
Code:
ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0f:1f:48:8c:c4  
          inet addr:70.44.177.135  Bcast:70.44.183.255  Mask:255.255.248.0
I don't think this is right.
It certainly doesn't look right for configuring the Belkin! It looks as if the system configured itself from the DPC2100R2. Please post the /etc/interfaces file, the one you prepared for configuring the Belkin. The simplest way to make a new interfaces file take effect is to remove any connection to the DPC2100R2 and reboot the commputer.
 
Old 05-15-2010, 01:12 AM   #32
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,541
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by woodmaster View Post
Also, when I do the reset procedure, the lights never go out on the Belkin...is this normal?
I don't have access to this particular model but it's certainly not as documented and not normal for the models I have reset. Are you confident you are actuating the reset switch?
 
Old 05-15-2010, 08:30 AM   #33
woodmaster
Member
 
Registered: Jan 2010
Location: PA
Distribution: Karmic Koala
Posts: 49

Original Poster
Rep: Reputation: 15
pretty sure I am actuating it. I can feel a click of sorts when I push it in. I will post the interfaces file when I get back to that PC later, but it is definately saved as per the settings you suggested earlier. I was sure to double check on that and I have unplugged, rebooted, replugged, etc. in various combinations, all to no avail. Of interest too may be that it is not /etc/interfaces on my box...it's /etc/network/interfaces. IDK if that's a problem or not...
 
Old 05-15-2010, 08:38 AM   #34
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,541
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by woodmaster View Post
Of interest too may be that it is not /etc/interfaces on my box...it's /etc/network/interfaces. IDK if that's a problem or not...
Sorry -- it should be /etc/network/interfaces; my mistake for calling it otherwise.
 
Old 05-15-2010, 10:41 AM   #35
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,227

Rep: Reputation: 170Reputation: 170
@woodmaster
I have ad this happen.
Unplugging and replugging the router and rebooting the problem computer fixes it.
 
Old 05-15-2010, 12:08 PM   #36
brucehinrichs
Member
 
Registered: Mar 2008
Location: US
Distribution: Debian Sid; Sabayon, UbuntuStudio, Slackware-multilib 13.1, Peppermint Ice, CentOS
Posts: 575

Rep: Reputation: 67
With some routers, I've done the reset by unplugging, waiting a couple of minutes, then plugging it back in while holding the reset button in, and continuing to hold the reset button in for about 30 seconds after applying power.
 
Old 05-16-2010, 04:55 AM   #37
woodmaster
Member
 
Registered: Jan 2010
Location: PA
Distribution: Karmic Koala
Posts: 49

Original Poster
Rep: Reputation: 15
unplugging, rebooting, replugging while holding reset, etc. Have tried all this to no avail...several times.
 
Old 05-16-2010, 05:31 AM   #38
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,541
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Quote:
Originally Posted by woodmaster View Post
unplugging, rebooting, replugging while holding reset, etc. Have tried all this to no avail...several times.
It will not work however many times you try it if the computer does not have the right IP configuration to connect with the Belkin, as established in this post above where the content of the /etc/network/interfaces (name corrected) was requested.
 
Old 05-16-2010, 11:32 PM   #39
kaushalpatel1982
Member
 
Registered: Aug 2007
Location: INDIA
Distribution: CentOS, RHEL, Fedora, Debian, Ubuntu, LinuxMint, PCLinuxOS
Posts: 137

Rep: Reputation: 7
I didnt see the Wlan interface on your router. As you said you are trying to connect the router with wireless, first enable the wireless then try to connect.
 
Old 05-18-2010, 12:56 PM   #40
woodmaster
Member
 
Registered: Jan 2010
Location: PA
Distribution: Karmic Koala
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by kaushalpatel1982 View Post
I didnt see the Wlan interface on your router. As you said you are trying to connect the router with wireless, first enable the wireless then try to connect.
This is not the PC I am connecting wirelessly from. It is wired. The wireless on the router was enabled and working, until I made an error: I was attempting to configure a wireless card on another computer on my network when it froze during the reboot phase after making settings adjustments.
 
Old 05-18-2010, 12:58 PM   #41
woodmaster
Member
 
Registered: Jan 2010
Location: PA
Distribution: Karmic Koala
Posts: 49

Original Poster
Rep: Reputation: 15
Here is my interfaces file's contents

Quote:
auto lo
iface lo inet static
address 192.168.2.200
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255
gateway 192.168.2.254
route -n

Quote:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
70.44.176.0 0.0.0.0 255.255.248.0 U 1 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
0.0.0.0 70.44.176.1 0.0.0.0 UG 0 0 0 eth0
ifconfig

Quote:
eth0 Link encap:Ethernet HWaddr 00:0f:1f:48:8c:c4
inet addr:70.44.177.135 Bcast:70.44.183.255 Mask:255.255.248.0
inet6 addr: fe80::20f:1fff:fe48:8cc4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3190942 errors:0 dropped:0 overruns:0 frame:0
TX packets:509188 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1883745604 (1.8 GB) TX bytes:144081686 (144.0 MB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:683797 errors:0 dropped:0 overruns:0 frame:0
TX packets:683797 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:60719164 (60.7 MB) TX bytes:60719164 (60.7 MB)
 
Old 05-19-2010, 02:15 AM   #42
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,541
Blog Entries: 28

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
The interfaces file looks good but the ifconfig output shows it has not been effective. Rebooting should have made it effective but something else may be changing eth0 (the first Ethernet adapter). We need to apply those settings so let's try with more finesse than rebooting. Can you try
Code:
sudo ifconfig eth0 down
sudo ifconfig eth0 up
sudo ifconfig
If that shows
Code:
eth0      Link encap:Ethernet  HWaddr 00:0f:1f:48:8c:c4  
          inet addr:192.168.2.200  Bcast:192.168.2.255  Mask:255.255.245.0
then we are OK and you can try continuing with "Logging into the WURE" on page 15 of the manual.
 
Old 05-19-2010, 06:22 AM   #43
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,529
Blog Entries: 3

Rep: Reputation: 209Reputation: 209Reputation: 209
I have been reading this on and off. Your other computer that is wired will connect to the internet through the router. but the other computer wireless has only one ether-net card and it is just wireless.
if this is so it would be eth0. if that computer has 2 cards then the wireless would be eht1 or wlan0. that said.

your wireless eth0 card is not connecting to the internet. Please ask your self and the IP company do you need to clone your mac address that used by the original ether card from the wired machine.
That would mean you need to have the router use the mac address as the card you set your account up with.

What will happen after a complete reset it will pass the packets from your wired card right through the router and you will connect but the router will not be working. you need to configure the router to use the
mac address of your original card that set up the account.

Disconnect the router from the modem. Reset the router. Configure mac and router. turn off the modem turn off the router.turn off your PC. Reconnect router to modem. restart modem wait till green then start the router. then start your pc.

this way the IP will talk to the router and you can connect to the router. this is in the manual. but not about some IP's cloning mac's like most of the cable IP do. In your router configuration set the router mac address as the original wired card used to set up the account.
if you are unable to access the router then life is to short to spend days working on a 50 dollar router.

Good luck

Last edited by Drakeo; 05-19-2010 at 06:39 AM.
 
Old 05-19-2010, 11:42 AM   #44
woodmaster
Member
 
Registered: Jan 2010
Location: PA
Distribution: Karmic Koala
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
I have been reading this on and off. Your other computer that is wired will connect to the internet through the router. but the other computer wireless has only one ether-net card and it is just wireless.
if this is so it would be eth0. if that computer has 2 cards then the wireless would be eht1 or wlan0. that said.
The PC has 2 cards...wlan0 is the wireless. It won't connect wired right now either though...

Quote:
your wireless eth0 card is not connecting to the internet. Please ask your self and the IP company do you need to clone your mac address that used by the original ether card from the wired machine.
That would mean you need to have the router use the mac address as the card you set your account up with.
Never really set up an ISP account. The cable guy had no clue what Linux was. He did his work at the box outside, ran a cable in, plugged it into my Ubuntu PC(through the modem), and I was online. That was all. I will try the rest of your suggestion to see if it works. Unpowering/ rebooting can't hurt I think...
 
Old 05-19-2010, 11:42 AM   #45
woodmaster
Member
 
Registered: Jan 2010
Location: PA
Distribution: Karmic Koala
Posts: 49

Original Poster
Rep: Reputation: 15
@catkin:
Quote:
$sudo ifconfig eth0 down
$ sudo ifconfig eth0 up
$ sudo ifconfig
eth0 Link encap:Ethernet HWaddr 00:0f:1f:48:8c:c4
inet addr:70.44.177.135 Bcast:70.44.183.255 Mask:255.255.248.0
inet6 addr: fe80::20f:1fff:fe48:8cc4/64 Scope:Link
 
  


Reply

Tags
belkin, reset, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding new Linux firewall/router on network with pre-existing gateway/router grittyminder Linux - Networking 4 08-13-2008 02:17 AM
LXer: Open source's Fast Ethernet router outperformed Cisco's Router LXer Syndicated Linux News 0 04-13-2007 01:31 PM
Wireless broke with NetGear router -- unknown frame f202 Ima Sudonim Linux - Wireless Networking 2 05-04-2005 10:36 AM
Is new wireless router broke now? linuxhippy Slackware 3 04-26-2005 07:03 PM
NFS Broke my Router and DNS Server? Gsee *BSD 2 04-08-2005 01:30 AM


All times are GMT -5. The time now is 07:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration