LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-14-2006, 04:39 AM   #1
-Olly-
LQ Newbie
 
Registered: Aug 2006
Distribution: Suse 10.1/openSuse
Posts: 14

Rep: Reputation: 0
Broadcom/Linksys 64-bit drivers


Hi all.

Wireless card is Linksys wmp54g with broadcom bcm4306 chipset
System is Suse 10.1 (the free version) with a recent 64-bit kernel

-I couldn't get it to work with Yast directly, or with the version of ndiswrapper that came with the distro, so i downloaded/made/installed the latest ndiswrapper.

-Drivers that came with my card (bcmwl5.sys and .inf) are 32-bit. Cue endless screens of warnings at boot saying "bad magic". I downloaded bcmwl564.sys, but it says it's an invalid driver. what drivers should i be using, and where can i get them? Are there native linux drivers available? (the official broadcom site is less than helpful here)

Thanks in advance for your assistance

Olly
 
Old 09-14-2006, 07:14 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Have you checked the ndiswrapper wiki for links to a 64-bit driver? I know they have at least some information on using ndiswrapper on a 64 bit rig.

Also, have you tried bcm43xx? Since it is native linux, it might do better than ndiswrapper.
 
Old 09-14-2006, 02:07 PM   #3
-Olly-
LQ Newbie
 
Registered: Aug 2006
Distribution: Suse 10.1/openSuse
Posts: 14

Original Poster
Rep: Reputation: 0
Ok, it's half working. Did you mean the bcm43xx.cat file that comes with some driver packages, or the bcm43xx project website?

I tried the site from your link (thanks), but couldn't access the "basic instructions for kernel versions 2.6.15 and 2.6.16". That might be broken link, not sure.

In the end i tried a file called netbc564.inf that was with one of the broadcom bundles, and i can ping my access point. i can't access the internet yet, but i'll browse the forum and see what i find.

Thanks for your help

Olly


EDIT: sorry, possibly not your site - the bcm43xx project site, documentation section. I assumed you were involved, since the link's in your sig

Last edited by -Olly-; 09-15-2006 at 03:14 AM.
 
Old 09-14-2006, 02:24 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Quote:
Originally Posted by -Olly-
Ok, it's half working. Did you mean the bcm43xx.cat file that comes with some driver packages, or the bcm43xx project website?

The bmc43xx driver has been in the kernel since 2.6.17, so if you have a recent kernel, you could give it a try. The only bit I'm not sure about is the firmware. That has to be cut from a Windows driver file, and I don't know if you cut it from a 32 bit driver if it will work on a 64 bit system. The rumor is that it can work, but I don't know of any successful examples.

Quote:
Originally Posted by -Olly-
I tried the site from your link (thanks), but couldn't access the "basic instructions for kernel versions 2.6.15 and 2.6.16". That might be broken link, not sure.
Um, I'm not sure what linke you're referring to.

Quote:
Originally Posted by -Olly-
In the end i tried a file called netbc564.inf that was with one of the broadcom bundles, and i can ping my access point. i can't access the internet yet, but i'll browse the forum and see what i find.

Thanks for your help

Olly
If you can ping your access point, then you probably just need to configure the card and either request or assign an IP address.
 
Old 09-15-2006, 04:00 AM   #5
-Olly-
LQ Newbie
 
Registered: Aug 2006
Distribution: Suse 10.1/openSuse
Posts: 14

Original Poster
Rep: Reputation: 0
Still there?

Hmmm

I could ping my AP, but after i rebooted, iwconfig said:

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s Tx-Power:25 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

i ran >ifup wlan0 essid network

Is that the correct syntax? (my network essid is "network"). It said:

wlan0
wlan0 Startmode is 'auto'

but the iwconfig output remained the same.
I checked the file /etc/sysconfig/network/ifcfg-wlan0 as suggested in: http://www.linuxquestions.org/questi...d.php?t=465714, and i checked the setup in Yast, and the ESSID is set to that of my network. Is there some way to get the interface to scan for available networks?

Olly

Last edited by -Olly-; 09-15-2006 at 04:09 AM.
 
Old 09-15-2006, 08:08 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
To be honest, I simply don't trust Yast and its brethern to handle wireless configuration. They screw up a lot and hide important error messages.

Try configuring the card in a console using iwconfig, not ifup. If it works that way, you can always write a script that you can run whenever you need the card configures. So the basic procedure would be:

iwconfig wlan0 essid network
ifup wlan0

The ifup script brings up the card and requests an IP address from a DHCP server, but it doesn't configure the card.

As far as scanning goes, there is the iwlist command:

iwlist wlan0 scan

And that should return a list of the access points it sees.
 
Old 09-15-2006, 04:06 PM   #7
-Olly-
LQ Newbie
 
Registered: Aug 2006
Distribution: Suse 10.1/openSuse
Posts: 14

Original Poster
Rep: Reputation: 0
Thanks for the quick response, Hangdog. I see your name on most posts on this forum, and i really appreciate you taking the time to help newbies like me. The network comes up on the scan, so i'm probably just missing something very obvious.

# iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:14:BF:23:9E:80
ESSID:"network"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-39 dBm Noise level:-256 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

# iwconfig wlan0 essid network
# ifup wlan0
wlan0 device: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
wlan0 Startmode is 'auto'

If I then ping 192.168.1.1, I just get a stream of "destination host unreachable" messages. At what point should I enter the password to access the network, since it hasn't prompted me or warned me that I need to? Are these logs 'normal', or has my tooling about in Yast messed up some config file somewhere?

Once again, my profuse thanks for your patience - you're owed a lot of good karma, i think.

Olly

edit: if the problem is the passcode/security stuff, should i be using the wpa_supplicant stuff, as described on your site?

Last edited by -Olly-; 09-15-2006 at 04:14 PM.
 
Old 09-16-2006, 07:23 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
It's a little hard to tell from what you've posted if your configuration took. After you set the SSID, check the output of iwconfig. If you see a MAC address in the Access Point section, then you have associated with the access point (by the way, are you running WEP or WPA security? If so, then you have to have the key entered before the association can take place. I do like using wpa_supplicant for this and the stuff I've posted on my site works well, at least for me).

Once you've associated with an access point, running ifup should get an IP address if there is a DHCP server running on the router. After running check the output of ifconfig to make sure you do have an IP address. Also check the output of route -n to make sure that DHCP set up your gateway properly (it should have your router's IP address).

If you're still having trouble, post the outputs of iwconfig, ifconfig and route -n, and hopefully that will tell us where things have gone haywire.
 
Old 09-17-2006, 06:46 PM   #9
-Olly-
LQ Newbie
 
Registered: Aug 2006
Distribution: Suse 10.1/openSuse
Posts: 14

Original Poster
Rep: Reputation: 0
iwconfig returns more or less the same output as i posted in #5 of this thread - not associating with the access point. Interestingly, wlan0 doesn't appear on the basic ifconfig list, but if i do:

#ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:12:17:94:91:B6
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:50 Memory:d1008000-d100a000

#route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0


I thought my encryption was WPA, but now i'm not sure. is "iwconfig key" the right option to use for entering the key? because that gives me:

# iwconfig key password
Error for wireless request "Set Encode" (8B2A) :
invalid argument "password".

not sure if that means it is WPA after all, or not. (btw, my PSK isn't actually password :P )
I can't ping the AP any more, but it still shows up on iwlist wlan0 scan. I'm pretty sure this is an issue with the interface config, but i don't know what. Perhaps i shouldn't have screwed about with that ifcfg file, or perhaps i shouldn't have used Yast...

Edit: what do you reckon to this: http://www.linuxquestions.org/questi...d.php?t=479900
are we having the same problem?

Last edited by -Olly-; 09-18-2006 at 04:02 AM.
 
Old 09-18-2006, 07:15 AM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Quote:
iwconfig returns more or less the same output as i posted in #5 of this thread - not associating with the access point.
You need to focus on this first since nothing else can work until you get an association with an access point.

Quote:
I thought my encryption was WPA, but now i'm not sure. is "iwconfig key" the right option to use for entering the key? because that gives me:
You REALLY need to figure out if you are using WPA or WEP. With WEP you can set the key with iwconfig. With WPA, you need to install wpa_supplicant.

Quote:
# iwconfig key password
You've got a syntax error there. The correct command is iwconfig wlan0 key password.

Quote:
Interestingly, wlan0 doesn't appear on the basic ifconfig list, but if i do:
The lack of wlan0 in the vanilla ifconfig just means that the interface hasn't been brought up. The fact that it appears in ifconfig wlan0 is good since it means the system does recognize it as a valid interface.

At this point I'm not sure that you are getting your card configured properly, so it is probably not the same problem as the thread you're referring to.
 
Old 09-20-2006, 05:27 AM   #11
-Olly-
LQ Newbie
 
Registered: Aug 2006
Distribution: Suse 10.1/openSuse
Posts: 14

Original Poster
Rep: Reputation: 0
Okay, my network definitely uses WPA, I have wpa_supplicant installed, but i'm not really sure how to configure it. I have the following in my wpa_supplicant.conf file (copied and altered from HangDog's site: http://hangdog.pihl.no-ip.org/index....k=view&id=27):

network={
ssid="network"
scan_ssid=1
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="password"
priority=1
}

this remains unchanged after running:

# wpa_supplicant -Bw -Dndiswrapper -c/etc/wpa_supplicant.conf -iwlan0

iwconfig wlan0 still returns:

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.462 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s Tx-Power:25 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

and # iwlist scan wlan0:

wlan0 Scan completed :
Cell 01 - Address: 00:14:BF:23:9E:80
ESSID:"network"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:0/100 Signal level:-44 dBm Noise level:-256 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

So i can see the network, but the configuration is not complete, because iwconfig isn't reporting a connection to the AP. Sorry to keep bugging you with this stuff, we must be nearly there now.

Thanks

Olly
 
Old 09-20-2006, 07:02 AM   #12
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
I hate to say it, but I'm a bit stumped. What you've done so far should have worked. What I would do at this point is:

- Spend some quality time with your log files (/var/log/syslog, /var/log/messages, and the dmesg command output) and see what wpa_supplicant and/or ndiswrapper are up to.

-Check the output of lsmod and make sure that bcm43xx isn't loaded. It will cause serious conflicts with ndiswrapper and some distros are starting to include it with their stock kernels.

- Try some different Windows drivers and see if any behave better. The kind of symptoms you are describing can be caused by a Windows driver that isn't real happy functioning under ndiswrapper.

- Try linuxant driveloader. It functions similar to ndiswrapper (allows Windows drivers to run in Linux) but sometimes it works when ndiswrapper doesn't. The downside is that it isn't free, but they do provide a decent test period so you can try before you buy.
 
Old 09-20-2006, 02:55 PM   #13
-Olly-
LQ Newbie
 
Registered: Aug 2006
Distribution: Suse 10.1/openSuse
Posts: 14

Original Poster
Rep: Reputation: 0
Well, I'm writing this via my wireless connection. I think there was a conflict between configuration files here, if that's even possible. I went into Yast and deleted the wireless profile which had appeared there automatically, after i edited ifcfg-wlan0, meaning to start over, and then i was able to connect. I don't know if this state of affairs will persist after I reboot, but we'll find out.

Thankyou for your help and patience, HangDog. I hope this thread helps other new linux users to solve their problems.

Definitely working see you around the forums.

Last edited by -Olly-; 09-21-2006 at 02:31 PM.
 
Old 09-20-2006, 04:37 PM   #14
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,778
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
I got my fingers crossed! Congrats on figuring it out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom BCM4401 Drivers Veratien Linux - Hardware 8 08-12-2007 01:04 AM
Broadcom 64-bit wireless driver problem vital_101 Ubuntu 2 05-27-2006 04:21 AM
Broadcom WiFi drivers scompa Slackware 10 05-15-2006 02:15 PM
64 bit drivers for Broadcom 4319 chipset preeth26 Linux - Wireless Networking 4 02-20-2006 05:24 PM
Broadcom 802.11b/g setup under 64 bit SUSE 9.2 with ndiswrapper tavisor Linux - Wireless Networking 6 04-19-2005 11:29 PM


All times are GMT -5. The time now is 04:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration