LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-01-2008, 02:06 PM   #1
jayo3434
LQ Newbie
 
Registered: Jul 2008
Location: Worcester, MA
Distribution: Debian (etch) - stable
Posts: 7

Rep: Reputation: 0
Broadcom 4309 wireless problems: strange HWaddr


Hi. I'm a noob who has been playing with Linux (Debian etch) for the better part of a week.
I am using a Dell Latitude D505 which has a Broadcom 4309 Network controller. I am not able to connect to any wireless networks however I can see them with

$ sudo iwlist eth1 scan

When I try to get an IP address using

$ sudo dhclient eth1

I end up with "No DHCPOFFERS received."

Here are the outputs of some common commands I've seen on the forums:


--------------Interfaces file:--------------

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# Wireless Interface
allow-hotplug eth1
iface eth1 inet dhcp

# The primary network interface
allow-hotplug eth2
iface eth2 inet dhcp

allow-hotplug eth0
iface eth0 inet dhcp

auto eth2

auto eth1

auto eth0


--------------ifconfig:--------------

jogasian@linux-ntbk:~$ sudo ifconfig
eth0 Link encap:UNSPEC HWaddr 34-4F-C0-00-3C-3A-C0-81-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:66 dropped:66 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth1 Link encap:Ethernet HWaddr 00:90:4B:16:9D:B5
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:602 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:22876 (22.3 KiB)
Interrupt:11 Base address:0xc000

eth2 Link encap:Ethernet HWaddr 00:0D:56:E0:35:D8
inet addr:10.12.1.79 Bcast:10.12.1.255 Mask:255.255.254.0
inet6 addr: fe80::20d:56ff:fee0:35d8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:14088 errors:0 dropped:0 overruns:0 frame:0
TX packets:190 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1377596 (1.3 MiB) TX bytes:25044 (24.4 KiB)

eth1:avah Link encap:Ethernet HWaddr 00:90:4B:16:9D:B5
inet addr:169.254.7.102 Bcast:169.254.255.255 Mask:255.255.0.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
Interrupt:11 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:16 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1192 (1.1 KiB) TX bytes:1192 (1.1 KiB)


--------------iwlist:--------------

jogasian@linux-ntbk:~$ sudo iwlist eth1 scan
eth1 Scan completed :
Cell 01 - Address: 00:11:20:62:EF:20
ESSID:"WLOBBY"
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Encryption key:off
Bit Rates:5.5 Mb/s; 6 Mb/s; 9 Mb/s; 11 Mb/s; 12 Mb/s
18 Mb/s; 24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=-177 dBm
Extra: Last beacon: 352ms ago
Cell 02 - Address: 00:11:88:43:99:40
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=-173 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 2972ms ago
Cell 03 - Address: 00:0B:0E:1A:66:00
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:4
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=-173 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (2) : TKIP WEP-104
Authentication Suites (1) : 802.1X
Extra: Last beacon: 196ms ago


--------------dhclient:--------------

jogasian@linux-ntbk:~$ sudo dhclient eth1
There is already a pid file /var/run/dhclient.pid with pid 4500
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit xxxxxxxxxxxxx (can't post these yet :-P )

Listening on LPF/eth1/00:90:4b:16:9d:b5
Sending on LPF/eth1/00:90:4b:16:9d:b5
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 21
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I think the problem may reside with that extra-long HWaddr for eth0.

I have also used fwcutter to cut in new FW for bcm43xx (however it may not be the most recent...the newest ones in the fwcutter README were unavailable on the given sites).

Thanks in advance for any help that can be provided.
 
Old 07-01-2008, 03:06 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
Did you actually configure your card to use an access point before you requested an IP address?
 
Old 07-01-2008, 03:31 PM   #3
jayo3434
LQ Newbie
 
Registered: Jul 2008
Location: Worcester, MA
Distribution: Debian (etch) - stable
Posts: 7

Original Poster
Rep: Reputation: 0
I entered the network-manager and in the properies set eth1 (wireless) to essid WLOBBY (no encryption) and enabled DHCP. The interfaces file now reads:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# Wireless Interface
allow-hotplug eth1
wireless-essid WLOBBY
iface eth1 inet dhcp

# The primary network interface
allow-hotplug eth2
iface eth2 inet dhcp

allow-hotplug eth0
iface eth0 inet dhcp

auto eth2

auto eth1

auto eth0
----------------------------

I still get the same output for dhclient. Since the first post I booted into Win XP Pro (dual-boot) and got everything from ipconfig/all.
I used that information to try to manually configure eth1 (using wifi-radar package). After doing that I connected to the wireless network (I think) and could ping the network address but not google.com. I couldn't view websites on iceweasle eaither.

Any other suggestions? Thanks!
 
Old 07-01-2008, 03:39 PM   #4
jayo3434
LQ Newbie
 
Registered: Jul 2008
Location: Worcester, MA
Distribution: Debian (etch) - stable
Posts: 7

Original Poster
Rep: Reputation: 0
Oh yeah...from ipconfig/all in XP the MAC address for eth0 was 00-90-4B-16-9D-B4 (not nearly as long as the one from ifconfig.
It was very similar to the HWaddr for eth1 (last sigit was one less).
This is probably a stupid question but what is the difference between eth0 and eth1? Are they the same peice of HW or different? I'v been thinking about it as eth0 controlls eth1 (wireless) and eth2 (wired ethernet).

Thanks again
 
Old 07-01-2008, 04:10 PM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
If you look at the output of iwconfig, does your wireless card have the SSID and is there a MAC address in the Access Point field? I'm wondering if you've actually associated with the AP.

Quote:
I used that information to try to manually configure eth1 (using wifi-radar package). After doing that I connected to the wireless network (I think) and could ping the network address but not google.com. I couldn't view websites on iceweasle eaither.
That's actually good and it means the driver is working. When you manually configure a card you have three things you have to supply:
1)The IP address (ifconfig eth1 xxx.xxx.xxx.xxx)
2) The router IP address (route add default gw yyy.yyy.yyy.yyy)
3) At least one DNS entry in /etc/resolv.conf (you can edit this with any text editor and add nameserver zzz.zzz.zzz.zzz where zzz is the IP address of a nameserver).

If you didn't do all those things, that is why you couldn't see websites by name.
Quote:
This is probably a stupid question but what is the difference between eth0 and eth1? Are they the same peice of HW or different? I'v been thinking about it as eth0 controlls eth1 (wireless) and eth2 (wired ethernet).
Each ethX should be a separate piece of hardware. So I'm guessing eth0 is your wired card, although from your original ifconfig output, eth2 might be your wired card since it has an IP address. At any rate, eth1 seems to be your wireless card and iwconfig should confirm that. I'm not sure what all the MAC address funkiness is about however.
 
Old 07-01-2008, 06:10 PM   #6
jayo3434
LQ Newbie
 
Registered: Jul 2008
Location: Worcester, MA
Distribution: Debian (etch) - stable
Posts: 7

Original Poster
Rep: Reputation: 0
OK we're working with a different network now. (home from work).

There are a lot of addresses floating around and I'm not really sure which are which. This is everything I could extrapolate about the network from my Windows machine:

C:\Users\Jason>ipconfig/all

Windows IP Configuration

Host Name . . . . . . . . . . . . : JRO-notebook
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : myhome.westell.com

Ethernet adapter Local Area Connection 2:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : wpi.edu
Description . . . . . . . . . . . : TAP-Win32 NetDirect Adapter
Physical Address. . . . . . . . . : 00-FF-D8-7D-D1-89
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . : myhome.westell.com
Description . . . . . . . . . . . : Atheros AR5007EG Wireless Network A

Physical Address. . . . . . . . . : 00-19-7E-98-4C-FB
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::f15f:b039:2614:400%9(Preferre
IPv4 Address. . . . . . . . . . . : 192.168.1.39(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Tuesday, July 01, 2008 5:26:10 PM
Lease Expires . . . . . . . . . . : Wednesday, July 02, 2008 5:26:10 PM
Default Gateway . . . . . . . . . : 192.168.1.1
DHCP Server . . . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.1
192.168.1.1
NetBIOS over Tcpip. . . . . . . . : Enabled


Question 1: Is "myhome.westell.com" setup by the owner of the network or is it the DNS that it happend to connect to at this particular login? Also, if this is the DNS then what are the IP addresses supplied at the bottom?

Question 2: What does the "Physical Address" correspond to? I'm guessing it is a MAC address but is it for my wirelss card or the router?

Question 3: What is the Gateway and what is the IPv4 IP address? Are any of these the IP address of my computer?

Question 4: In the first step you gave me you wanted me to use ifconfig to enter "the IP address" is this the IP address of my notebook? How do I find it/do I just make one up?

Question 5: You second step asks for the router IP address. From my windows machine I'm guessing that's the 192.168.1.39? Where do I enter this information? /etc/networks/interfaces?

Question 6: This is the first I have heard of /etc/resolv is ther anything else that should be in there?

I know this is a lot of questions and they're probably all really basic things I should know, sorry for asking so much.

One other thing I wanted to know is why I have to enter all of this in manually every time and why the DHCP server doesn't just send it to me like in Windows. Thanks again for all the great advice!
 
Old 07-02-2008, 07:43 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
1) That looks to me like a domain supplied by the ISP. When you request an IP address by DHCP, you get the IP address, the gateway and any DNS information you need to work with that network. The DHCP client handles all of this automatically.

2) Yes, physical address and MAC address are usually the same thing. However, from your output I can't really figure out which device that MAC belongs to. Though to be honest, right now I don't think it matters.

3) The gateway address should be the IP address of your router. Essentially it is the address of whatever device allows you to access other computers both on your LAN and the WAN. It usually isn't your computer's IP.

4) Yes, ifconfig lets you set the IP address of your notebook. You are sort of just making one up, but it has to be consistent with the IP address range your LAN uses. For example, I have a router connected to the internet, and it serves out addresses in the 192.168.1.X range, so any IP I assign to a computer has to be 192.168.1.xxx or it won't work.

5) Actually, I bet the 192.168.1.39 is the address of your computer, not your router. From what you've posted, 192.168.1.1 is your router address (which would be consistent with how most consumer routers work). You can enter this in your interfaces file or you can use the route command to set it as I showed in my earlier post. The advantage of using your interfaces file is that you won't have to set it every time you boot.

6) Resolv.conf is the file that holds the IP addresses of the DNS servers the computer should be using. It should have at least one line that looks something like this:

nameserver xxx.xxx.xxx.xxx


Where xxx is an IP address. This should get set by DHCP but if you manually issue an IP address, you'll have to edit this. If you're lucky, you can use your router's IP address and it will pass the request on to your ISP, but sometimes it's faster to just add your ISP's DNS IP addresses directly.

Quote:
One other thing I wanted to know is why I have to enter all of this in manually every time and why the DHCP server doesn't just send it to me like in Windows.
Usually you don't, but in your case dhclient is failing. Setting it manually is an alternative to allow you wireless access until you can figure out what is going wrong with dhclient. By the way, I don't know if Debian uses ifup, but it might work better than dhclient:

ifup eth1

If you've configured your card, that might do the trick.
 
Old 07-02-2008, 09:59 AM   #8
jayo3434
LQ Newbie
 
Registered: Jul 2008
Location: Worcester, MA
Distribution: Debian (etch) - stable
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for spending so much time with this, I really appreciate it.

It turns out that the address I was pinging yesterday was most likely my own IP address (69.16.27.69). So maybe that didn't indicate that all the drivers are working. I'm starting to think there is a bigger problem going on here.

But for now these are the steps I am taking:

Setup /etc/network/interfaces from data received in XP:

----------------------------------------------------

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# Wireless Interface
allow-hotplug eth1
iface eth1 inet static
wireless-essid WLOBBY
address 69.16.27.69
netmask 255.255.255.0
gateway 69.16.27.254

# The primary network interface
allow-hotplug eth2
iface eth2 inet dhcp

allow-hotplug eth0
iface eth0 inet dhcp

auto eth2

auto eth1
----------------------------------------------------

This is the network from $ sudo iwlist eth1 scan:

eth1 Scan completed :
Cell 01 - Address: 00:11:20:62:EF:20
ESSID:"WLOBBY"
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Encryption keyff
Bit Rates:5.5 Mb/s; 6 Mb/s; 9 Mb/s; 11 Mb/s; 12 Mb/s
18 Mb/s; 24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=-182 dBm
Extra: Last beacon: 352ms ago
----------------------------------------------------

$sudo iwconfig eth1:

eth1 IEEE 802.11a/b/ ESSID:"WLOBBY" Nickname:"Broadcom 4306"
Mode:Managed Frequency=2.484 GHz Access Point: Invalid
Bit Rate=1 Mb/s Tx-Power=14 dBm
RTS thrff Fragment thrff
Encryption keyff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

----------------------------------------------------

and finally $sudo ifconfig eth1:

eth1 Link encap:Ethernet HWaddr 00:90:4B:16:9D:B5
inet addr:69.16.27.69 Bcast:69.16.27.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:266 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:10780 (10.5 KiB)
Interrupt:11

----------------------------------------------------

Thing thing that jumps out at me is that in iwconfig the Access Point address is "invalid".

if I do $sudo iwconfig eth1 ap 00:11:20:62:EF:20 (from iwlist above)
Nothing changes.

I'm now starting to wonder if it is a driver problem. I also get a bunch of stuff about bcm43xx during startup. If you think this would be helpful i can post some of dmesg. Let me know.

THANK YOU
 
Old 07-02-2008, 01:49 PM   #9
jayo3434
LQ Newbie
 
Registered: Jul 2008
Location: Worcester, MA
Distribution: Debian (etch) - stable
Posts: 7

Original Poster
Rep: Reputation: 0
Problem solved (kind of).

I cheated and installed ndiswrapper. I wanted to avoid running windows anything on this machine but saw no way around it. Thanks for all the help.

For anyone else reading this ndiswrapper worked perfectly (after downloading kernel headers) and was quite straight-forward to set up. Just visit their website for any and all information you may need.

Thanks again Hangdog42, you really helped me learn a lot even if in the end it was a different problem.
 
Old 07-02-2008, 04:12 PM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,769
Blog Entries: 1

Rep: Reputation: 410Reputation: 410Reputation: 410Reputation: 410Reputation: 410
Congrats on getting it solved! Yeah, Broadcom's junk really stinks when it comes to getting it working. Personally, I've started using Intel wireless stuff, it works great and Intel truly supports it.
 
  


Reply

Tags
broadcom, ifconfig, iwlist


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broadcom 4309 pulls ip won't communicate nightshade_1977 Linux - Wireless Networking 3 07-23-2007 01:16 AM
Fedora 7 / Dell D600 / Broadcom 4309 CaliMale Linux - Hardware 1 07-02-2007 08:35 PM
Broadcom Wireless (BCM4306) Wireless problems: modprobe ndiswrapper freezes HP Laptop shthap3ns Linux - Hardware 11 02-11-2007 12:53 PM
Broadcom 4309 with kernel driver freezes on DHCP platypeanArchcow Linux - Hardware 1 10-15-2006 08:18 PM
wireless problems; Broadcom 802.11G Mini PCI Wireless with redhat WS surfbass Linux - Laptop and Netbook 1 12-17-2004 12:48 PM


All times are GMT -5. The time now is 05:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration