LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-15-2006, 12:55 PM   #1
Phrenchax
LQ Newbie
 
Registered: Jun 2006
Location: Glens Falls, NY
Distribution: Debian Etch
Posts: 19

Rep: Reputation: 0
Bizarre wireless DHCP problem


Here is my situation, and it's a bit convoluted:

I have a desktop machine at home, running linux, and I have Verizon DSL. Verizon gave me their standard DSL modem, which includes a wireless antenae.

A couple weeks ago, a relative gave me two old laptops: a Dell and a Roadster with 64MB ram. The Dell still has windows, but I have installed Debian Etch on the Roadster. I did the netinstall through the wired connection. So far so good.

Then I went to buy a wireless card for my two laptops. I did my homework and made sure to get an atheros chipset so that I could use madwifi. When I scan for access points (APs), I see my network and my neighboor's. Now here is the funny part:

Using the Dell (windows laptop), I can DHCP into my modem without any trouble. Using the Roadster (Etch), I can only DHCP into my neighboor's modem. I can surf the web and everything, but obviously I don't want to be stealing his bandwidth. When I iwconfig to my network, DHCP refuses to connect...

Any ideas?
 
Old 10-16-2006, 09:31 AM   #2
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
It sounds like both you and your neighbor have not put any security in place. ie, you have not set an SSID, you are not using wep.

Routers come pre-configured to work out of the box, without any config. The problem is anyone can connect.

If I were you, go into your routers config for wireless and set a SSID and set up wep. Keep in mind you will have to set up the same options on windoze and linux laptops.

That should stop outside intruders, after all, if you can connect to his, the reverse is likely true also. BTW, if you like your neighbor, suggest to him to set up some security...

Once you set up the security, linux may not connect to anyone, until we figure out why not. Just a guess, but your neighbors router may respond to the DHCP request faster than your router, and on open networks, it will connect to the first one answering. Once you have set up some security, that issue should go away.

I can see my neighbors router also, but we both have some security in place.

Another thought, what channel is your wireless router set to? and are you trying to connect on the same channel on linux?

Last edited by camorri; 10-16-2006 at 09:36 AM.
 
Old 10-17-2006, 05:12 AM   #3
Phrenchax
LQ Newbie
 
Registered: Jun 2006
Location: Glens Falls, NY
Distribution: Debian Etch
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks for the quick reply!
Yes you are correct in assuming that neither my neighboor or me have any security in place. I will try to do something about that...

My wireless router appears to be set to channel 6, as does my neighboor's.

Here is the sequence of commands I enter to try to connect:

#ifconfig ath0 up

#wlanconfig ath0 list scan #this shows the two routers

#iwconfig ath0 essid "my router name"

#iwconfig #this shows that I am indeed connected to my router

#dhclient ath0 #this is the step that fails. It goes through the motions, but does not receive a DHCPOFFER and eventually times out.

Am I missing something? How do I go about checking what channel I am trying to connect on?
 
Old 10-17-2006, 09:31 AM   #4
camorri
Senior Member
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.0 + 14.1
Posts: 4,834

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
The fact that you can see the correct essid is good.

When iwconfig shows you are connected, can you ping your router?

I have never used a command like 'dhcpclinet' . To get an IP address I use 'pump -i ath0' in a root shell. After that, I have an IP address an all is good and online.
 
Old 12-03-2006, 01:43 AM   #5
paulsm4
Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

I realize this post is over a month old, and you've probably long since resolved the problem ... but on the off chance this might be of use to you ... or somebody else with a similar problem ...

... Make sure your DSL modem is set to "bridged mode". Or DHCP will fail with the exactly the symptoms you describe.

'Hope that helps .. PSM
 
Old 08-12-2007, 06:33 AM   #6
Phrenchax
LQ Newbie
 
Registered: Jun 2006
Location: Glens Falls, NY
Distribution: Debian Etch
Posts: 19

Original Poster
Rep: Reputation: 0
SOLVED!

I gave up on this issue for several months, then recently decided to give it another shot.

It turns out the issue was specific to my router (westell versalink 327w), and even more specifically to the firmware. I upgraded to the latest firmware and Presto: it works flawlessly.

Thanks to all for your input!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP problem with wireless network SlackPingo Slackware 15 12-30-2005 10:24 AM
Linux (Fedora) wireless working but now XP can't connect - DHCP problem? willy6743 Linux - Wireless Networking 3 08-01-2005 03:00 PM
Problem with network wireless conf dhcp jorfermo Linux - Wireless Networking 0 01-14-2005 03:42 AM
Bizarre CD problem masterJ Slackware 9 07-02-2003 08:31 AM
a Bizarre problem seemed to be..... yunxiang Linux - General 2 02-06-2003 04:49 AM


All times are GMT -5. The time now is 09:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration