LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Belkin F5D7010 modprobe problem?? (http://www.linuxquestions.org/questions/linux-wireless-networking-41/belkin-f5d7010-modprobe-problem-228234/)

st00 09-08-2004 12:54 PM

Belkin F5D7010 modprobe problem??
 
Hey there, I've just got a Toshiba Tecra 8000 and installed Fedora Core 1. Everything seems to be fine but I can't seem to get my wireless card to work. The weird thing is that it got quite far the first time I installed it. Here's what I get...

$cardctl ident
Socket 0:
product info: "3Com Corporation", "3CCFE575BT", "LAN Cardbus Card", "001"
manfid: 0x0101, 0x5157
function: 6 (network)
Socket 1:
product info: "Broadcom", "802.11g CardBus", "4.5"
manfid: 0x02d0, 0x0417
function: 6 (network)

$ndiswrapper -l
Installed ndis drivers:
bcmwl5 present

$modprobe -l | grep ndis
/lib/modules/2.4.22-1.2188.nptl/kernel/drivers/net/ndiswrapper/ndiswrapper.o

$iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

$dmesg | grep ndis
ndiswrapper version 0.7 loaded
ndiswrapper adding bcmwl5.sys

The first time I installed it was just after I installed the new kernel and the OSS sound driver didn't work in xmms, the wireless card appeared in iwconfig then (don't know if the sound has anything to do with it, conflict perhaps??).
There's no lights on the wireless card, but it works fine in Wimpdows and also appears in the list when running redhat-config-network, but I can't seem to get it to activate, it reports that wlan0 doesn't seem to be present.

Please help, I feel so close to getting it working !!!!

st00 09-12-2004 04:27 AM

I've managed to get a bit further but my sketchy linux and networking knowledge is hampering further progress.

I found that ndiswrapper -m added the line

alias wlan0 ndiswrapper

to /etc/modules.conf but by commenting this out and editing the ifcfg-wlan0 and /etc/ndiswrapper/bcmwl5/14E4:4320.conf files I can get the light to come on the wireless card and get the following

$iwconfig
lo no wireless extensions.

wlan0 IEEE 802.11b ESSID:"WLAN" Nickname:"localhost.localdomain"
Mode:Auto Frequency:2.462GHz Access Point: CA:FA:FA:77:29:08
Bit Rate=54Mb/s Tx-Power:9 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:off
Power Management:off
Link Quality:100/100 Signal level:-57 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:1936 Missed beacon:0

eth0 no wireless extensions.

trying to ping another computer on the network gives a 'connect: Network is unreachable' error and this is what I get when trying to activate it,

$ifup wlan0
Cannot get driver information: No such device

Determining IP information for wlan0... failed.

I've got lights now, surely this must be almost there???

ifcfg-wlan0
ONBOOT=no
USERCTL=yes
PEERDNS=yes
GATEWAY=
TYPE=Wireless
DHCP_HOSTNAME=
IPADDR=
DEVICE=wlan0
HWADDR=00:30:bd:95:17:01
BOOTPROTO=dhcp
DOMAIN=
NETMASK=
ESSID=WLAN
CHANNEL=11
MODE=Auto
RATE=Auto

driver init script 14E4:4320.conf
NdisVersion|0x50001
Environment|1
BusType|5

RadioState|0
PowerSaveMode|0
PLCPHeader|0
frag|2346
rts|2347
NetworkAddress|
PwrOut|100
IBSSGMode|2
Locale|0
Rate|0
Channel|11

Can you think of <i>anything</i> I can try? Thanks again

Hangdog42 09-12-2004 08:18 AM

If your wireless settings are OK (there is nothing obviously wrong in your iwconfig output but I don't know your network settings), then the problem is that your card doesn't have an IP address yet. You can either request one via DHCP or you can assing a static one. For DHCP I think the Fedora command is:

dhclient wlan0

If you want to assign and IP then do:

ifconfig wlan0 1.2.3.4 and replace 1.2.3.4 with the IP you want to use. Then set your route:
route add default gw 5.6.7.8 and replace 5.6.7.8 with the IP of your router.

You also need to check your /etc/resolv.conf file and make sure that your ISPs DNS are listed there.

st00 09-13-2004 12:09 PM

Got it working!!!!!!! Woooohoooo!!!!
I had to change the mode to managed, then it was all systems go!! Thanks for all the help.


All times are GMT -5. The time now is 03:11 PM.