LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 02-18-2006, 06:23 AM   #1
maxmil
LQ Newbie
 
Registered: Feb 2006
Posts: 21

Rep: Reputation: 15
Beginner on Debian with "no DHCPOFFERS recieved"


Hello,

I'm relatively new to Linux and have successfully installed Debian Sarge. Up till now i've had it working with my ethernet card but am now configuring a wireless pci card (its a laptop with a Belkin 54g pci card).

I successfully followed a VERY good tutorial at ndsiwrapper and i think that the module has been correctly installed.

I am now configuring my wlan0.

I have asigned the ESSID id, the mode and the WEP code. When i do iwconfig wlan0 i get the following output:

wlan0 IEEE 802.11g ESSID:"WLAN_78"
Mode:Managed Frequency:2.412 GHz Access Point: 00:03:C9:E7:4D:CE
Bit Rate:24 Mb/s Tx-Power:20 dBm Sensitivity=-120 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:0C00-30DA-718A-78 Security mode: open
Power Management: off
Link Quality:100/100 Signal level:-29 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I then bring down my ethernet connection with ifdown eth0 and try to bring up my new wlan0 interface with ifup wlan0

The first time that i did this there was an error saying that the wlan0 interface was not present. I solved this by adding the line:

iface wlan0 inet dhcp

to etc/network/interfaces. I copied another line that said iface eth0 inet dhcp.

ifup wlan0 now executes but fails. This is the output.

Listening on LPF/wlan0/00:11:50:8f:c1:21
Sending on LPF/wlan0/00:11:50:8f:c1:21
Sending on Socket/fallback/fallback-net
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
No DHCPOFFERS received.
No working leases in persistent database.

Exiting.

Failed to bring up wlan0.

*********************************************************

What could be the cause of my problems? Are there any other tests that i can do to check my devices and configuration?

One more detail that i have'nt mentioned and that may be important is that when i issue the command iwconfig wlan0 i get a warning that says:

Warning: Driver for device wlan0 recommend version 18 of Wireless Extension,
but has been compiled with version 16, therefore some driver features
may not be available...

Do i need to correct this?

Last edited by maxmil; 02-18-2006 at 06:44 AM.
 
Old 02-18-2006, 02:12 PM   #2
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
you need to do "dhclient wlan0"
please let me know how you get on
good luck master
 
Old 02-18-2006, 02:14 PM   #3
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
and dont be concerned with the warning it will still run like a charm im sure
 
Old 02-19-2006, 04:51 AM   #4
maxmil
LQ Newbie
 
Registered: Feb 2006
Posts: 21

Original Poster
Rep: Reputation: 15
Thanks for your response. I tried dhclient wlan0 but it gives pretty much the same output as ifup wlan0. Thats to say that it does'nt get past the DHCPDISCOVER call.

I'm not a network specialist but another thing that i've noticed is that when i issue iwconfig wlan0 in the configuration the network protocol that the card uses is IEEE 802.11g whilst when i do iwlist wlan0 scan the access point that i'm trying to connect to uses protocol IEEE 802.11b.

Could this be a problem?
 
Old 02-19-2006, 02:21 PM   #5
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
what wireless router do you have?
can you ping your router?
disable your wep and try again
allso in your router config this is my example i type "http://192.168.1.1" when it brings up my routers home page click on wireless i am given the choice to accept only wireless mode with G,wireless mode with B, or mixed. I have mine set on only accept G,as my wireless card is a motorola wireless 802.11g check the settings of yours, if in doubt set it to mixed just for now
 
Old 02-20-2006, 03:19 AM   #6
maxmil
LQ Newbie
 
Registered: Feb 2006
Posts: 21

Original Poster
Rep: Reputation: 15
You're absolutely right, its a problem with my router. I have just succesfully connected to another wireless network that i have within range. The strange thing is that the other router is almost the same as mine, its just an earlier model.

My router is a CT-536+ 802.11g Wireless ADSL2+ Router (i can't give to the url to de product because this forum won't let me post urls until i have at least 5 posts but searching for CT-536 on Comtrends international website should bring up the specifications). My pci wireless network card is a Belkin 54g.

Reading the specifications of the router it says that by default it is set to receive mode G. It has default configuration, the only thing that i've changed is the password and desactivated WEP.

In the browser configuration interface there is nothing that allows me to accept either mode G or mode B. However it looks to me like it is already set to receive mode G. The field "Band" has value "2.4Ghz 802.11g" and below there is another field "54g Mode" that is set to "Auto".

Whats more from windows (on the same machine) the card connects to the router without a problem.

If you were willing i would be happy to pass you my ip and a user and password for the router (by mail) so that you could have a squint at the config.

I really apreciate your help.

Last edited by maxmil; 02-20-2006 at 03:20 AM.
 
Old 02-20-2006, 01:14 PM   #7
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
out of interest did you try resetting the router to default settings
 
Old 02-20-2006, 01:44 PM   #8
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
allso i am right in saying you have not tried to set a static ip for your wireless connection, and you are sure ndiswrapper is loaded. ie type "lsmod" and you can see ndiswrapper listed if not type "modprobe ndiswrapper" as root
what i am allso getting at is the lights on your wireless card are lit up
 
Old 02-20-2006, 01:58 PM   #9
maxmil
LQ Newbie
 
Registered: Feb 2006
Posts: 21

Original Poster
Rep: Reputation: 15
Hoooorrraaayyy!!

I'm connected. After reinstalling the factory settings it worked!! A very obvious but very good idea. Now that i know how to make it work my natural instinct would be to try and brake it again to expose the problem. However, i don't want to tempt fate quite yet, maybe i'll just let it be for a couple of weeks.

Thanks a load for your help.
 
Old 02-20-2006, 02:03 PM   #10
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
im glad to hear it would you like to know how to give it a static ip now
 
Old 02-21-2006, 02:35 AM   #11
maxmil
LQ Newbie
 
Registered: Feb 2006
Posts: 21

Original Poster
Rep: Reputation: 15
I'm quite happy with a dynamic ip i think. But tell me, why should i prefer a static one? Would i configure it in /etc/network/interfaces?
 
Old 02-21-2006, 10:06 AM   #12
master
Member
 
Registered: Oct 2003
Location: Birmingham/Eng/UK
Distribution: /Debian3.1/suse/XP/Win7
Posts: 677

Rep: Reputation: 30
yes you would configure it in /etc/network/interfaces and its good to get your computer to talk to another one on your home network.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Xlib: extension "XFree86-DRI" missing on display ":0.0"." zaps Linux - Games 9 05-14-2007 03:07 PM
Debian Boot Up Problem - stuck at "BR" & "I" jc70417 Debian 2 08-30-2005 04:36 PM
Debian no DHCPOFFERS recieved firefly2442 Linux - Networking 3 01-12-2005 03:12 AM
"sar" and "iostat" equivalents on Debian? aditya_shah Debian 8 08-01-2004 11:53 PM
"expect" shell beginner question, please help me out yuzuohong Linux - General 1 06-28-2003 01:17 PM


All times are GMT -5. The time now is 10:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration